mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/meson to 0.54.0-1
This commit is contained in:
parent
1fd47d82e1
commit
37e1599dd0
3 changed files with 96 additions and 49 deletions
|
@ -0,0 +1,88 @@
|
||||||
|
From f61bab556a2cf6aae7935f6add8b00657666b5e2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||||
|
Date: Mon, 30 Mar 2020 01:27:39 +0200
|
||||||
|
Subject: [PATCH] Fix meson_jar_template so test suite passes
|
||||||
|
|
||||||
|
It was generating an extra comma.
|
||||||
|
|
||||||
|
The Meson build system
|
||||||
|
Version: 0.54.0
|
||||||
|
Source dir: /tmp/tmp34halxhe
|
||||||
|
Build dir: /tmp/tmp34halxhe/build
|
||||||
|
Build type: native build
|
||||||
|
|
||||||
|
meson.build:6:15: ERROR: Expecting rparen got comma.
|
||||||
|
'Foo.java',,
|
||||||
|
^
|
||||||
|
For a block that started at 5,3
|
||||||
|
jar('tmp34halxhe',
|
||||||
|
^
|
||||||
|
|
||||||
|
A full log can be found at /tmp/tmp34halxhe/build/meson-logs/meson-log.txt
|
||||||
|
Using "tmp34halxhe" (name of current directory) as project name.
|
||||||
|
Using "tmp34halxhe" (project name) as name of executable to build.
|
||||||
|
Detected source files: Foo.java
|
||||||
|
Detected language: java
|
||||||
|
Generated meson.build file:
|
||||||
|
|
||||||
|
project('tmp34halxhe', 'java',
|
||||||
|
version : '0.1',
|
||||||
|
default_options : ['warning_level=3'])
|
||||||
|
|
||||||
|
jar('tmp34halxhe',
|
||||||
|
'Foo.java',,
|
||||||
|
main_class: tmp34halxhe,
|
||||||
|
install : true)
|
||||||
|
|
||||||
|
It was also missing quotes around the main class name.
|
||||||
|
|
||||||
|
The Meson build system
|
||||||
|
Version: 0.54.0
|
||||||
|
Source dir: /tmp/tmpjm5cg44a
|
||||||
|
Build dir: /tmp/tmpjm5cg44a/build
|
||||||
|
Build type: native build
|
||||||
|
Project name: tmpjm5cg44a
|
||||||
|
Project version: 0.1
|
||||||
|
Java compiler for the host machine: javac (unknown 1.8.0)
|
||||||
|
Host machine cpu family: x86_64
|
||||||
|
Host machine cpu: x86_64
|
||||||
|
|
||||||
|
meson.build:5:0: ERROR: Unknown variable "tmpjm5cg44a".
|
||||||
|
|
||||||
|
A full log can be found at /tmp/tmpjm5cg44a/build/meson-logs/meson-log.txt
|
||||||
|
Using "tmpjm5cg44a" (name of current directory) as project name.
|
||||||
|
Using "tmpjm5cg44a" (project name) as name of executable to build.
|
||||||
|
Detected source files: Foo.java
|
||||||
|
Detected language: java
|
||||||
|
Generated meson.build file:
|
||||||
|
|
||||||
|
project('tmpjm5cg44a', 'java',
|
||||||
|
version : '0.1',
|
||||||
|
default_options : ['warning_level=3'])
|
||||||
|
|
||||||
|
jar('tmpjm5cg44a',
|
||||||
|
'Foo.java',
|
||||||
|
main_class: tmpjm5cg44a,
|
||||||
|
install : true)
|
||||||
|
---
|
||||||
|
mesonbuild/templates/mesontemplates.py | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/mesonbuild/templates/mesontemplates.py b/mesonbuild/templates/mesontemplates.py
|
||||||
|
index 2739c9d8..6b341a21 100644
|
||||||
|
--- a/mesonbuild/templates/mesontemplates.py
|
||||||
|
+++ b/mesonbuild/templates/mesontemplates.py
|
||||||
|
@@ -27,8 +27,8 @@ meson_jar_template = '''project('{project_name}', '{language}',
|
||||||
|
default_options : [{default_options}])
|
||||||
|
|
||||||
|
jar('{executable}',
|
||||||
|
- {sourcespec},{depspec},
|
||||||
|
- main_class: {main_class},
|
||||||
|
+ {sourcespec},{depspec}
|
||||||
|
+ main_class: '{main_class}',
|
||||||
|
install : true)
|
||||||
|
'''
|
||||||
|
|
||||||
|
--
|
||||||
|
2.26.0
|
||||||
|
|
|
@ -1,41 +0,0 @@
|
||||||
From a798616f8ac85c02f0830269410a16c54cbd0cab Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
||||||
Date: Thu, 27 Feb 2020 15:53:43 +0100
|
|
||||||
Subject: [PATCH] environment: Fix construction of CudaLinker
|
|
||||||
|
|
||||||
The 0.53.2 test suite has a new failure:
|
|
||||||
|
|
||||||
Traceback (most recent call last):
|
|
||||||
File "run_project_tests.py", line 1024, in <module>
|
|
||||||
detect_system_compiler()
|
|
||||||
File "run_project_tests.py", line 964, in detect_system_compiler
|
|
||||||
comp = env.compiler_from_language(lang, MachineChoice.HOST)
|
|
||||||
File "/build/meson/src/meson-0.53.2/mesonbuild/environment.py", line 1565, in compiler_from_language
|
|
||||||
comp = self.detect_cuda_compiler(for_machine)
|
|
||||||
File "/build/meson/src/meson-0.53.2/mesonbuild/environment.py", line 1131, in detect_cuda_compiler
|
|
||||||
linker = CudaLinker(compiler, for_machine, 'nvlink', CudaCompiler.LINKER_PREFIX, [], version=CudaLinker.parse_version())
|
|
||||||
File "/build/meson/src/meson-0.53.2/mesonbuild/linkers.py", line 963, in __init__
|
|
||||||
super().__init__('nvlink', *args, **kwargs)
|
|
||||||
TypeError: __init__() takes 6 positional arguments but 7 positional arguments (and 1 keyword-only argument) were given
|
|
||||||
|
|
||||||
Fixes: c708c52ca225 ("linkers: Update the linker names to be more consistent")
|
|
||||||
---
|
|
||||||
mesonbuild/environment.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
|
|
||||||
index 39c6b542..ebadd576 100644
|
|
||||||
--- a/mesonbuild/environment.py
|
|
||||||
+++ b/mesonbuild/environment.py
|
|
||||||
@@ -1128,7 +1128,7 @@ class Environment:
|
|
||||||
cpp_compiler = self.detect_cpp_compiler(for_machine)
|
|
||||||
cls = CudaCompiler
|
|
||||||
self.coredata.add_lang_args(cls.language, cls, for_machine, self)
|
|
||||||
- linker = CudaLinker(compiler, for_machine, 'nvlink', CudaCompiler.LINKER_PREFIX, [], version=CudaLinker.parse_version())
|
|
||||||
+ linker = CudaLinker(compiler, for_machine, CudaCompiler.LINKER_PREFIX, [], version=CudaLinker.parse_version())
|
|
||||||
return cls(ccache + compiler, version, for_machine, is_cross, exe_wrap, host_compiler=cpp_compiler, info=info, linker=linker)
|
|
||||||
raise EnvironmentException('Could not find suitable CUDA compiler: "' + ' '.join(compilers) + '"')
|
|
||||||
|
|
||||||
--
|
|
||||||
2.25.1
|
|
||||||
|
|
|
@ -6,7 +6,7 @@
|
||||||
# - disable lto in arch-meson
|
# - disable lto in arch-meson
|
||||||
|
|
||||||
pkgname=meson
|
pkgname=meson
|
||||||
pkgver=0.53.2
|
pkgver=0.54.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='High productivity build system'
|
pkgdesc='High productivity build system'
|
||||||
url='https://mesonbuild.com/'
|
url='https://mesonbuild.com/'
|
||||||
|
@ -17,16 +17,16 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
||||||
'gtkmm3' 'gtest' 'gmock' 'protobuf' 'wxgtk' 'python-gobject' 'gobject-introspection'
|
'gtkmm3' 'gtest' 'gmock' 'protobuf' 'wxgtk' 'python-gobject' 'gobject-introspection'
|
||||||
'itstool' 'gtk3' 'java-environment=8' 'gtk-doc' 'llvm' 'clang' 'sdl2' 'graphviz'
|
'itstool' 'gtk3' 'java-environment=8' 'gtk-doc' 'llvm' 'clang' 'sdl2' 'graphviz'
|
||||||
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
|
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
|
||||||
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'cuda' 'nasm' 'gnustep-base'
|
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
|
||||||
'libelf' 'python-pytest-xdist')
|
'python-pytest-xdist') # 'cuda')
|
||||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
||||||
skip-test.diff
|
skip-test.diff
|
||||||
0001-environment-Fix-construction-of-CudaLinker.patch
|
0001-Fix-meson_jar_template-so-test-suite-passes.patch
|
||||||
arch-meson)
|
arch-meson)
|
||||||
sha512sums=('005340f0faaa8fc5065b916355af6c2e3311da59fae67c781eb9ca47c5430dca85e9aa1052c5e92b3da8546b4b197fe623a6d48b073a24e05535141ba59ecac7'
|
sha512sums=('e3c97ffd9409a543e45c8be7b12d4e8437de8dbd0cd236fbe092952d7d0833728d46ff6b679c8a73dae4c4016fdf38b43b56f3959a95968a29db109ebfe254e7'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
|
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
|
||||||
'c214888ef7b095e1baa68743a065438cd4270032c457580d5e6e2f728b694abfe07b609c17b11d6b9f66b0f5ba2702552084508f69003072dc45ae01b09d8eb2'
|
'1203c844466409fceb6e3bd4f419762d7dcd460f4dbf412eda7d966b002dd69710af97d9135fc399c71fdcd191aa512bf180e60562f5996932e2827acf591eb2'
|
||||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||||
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
|
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||||
|
|
||||||
|
@ -36,8 +36,8 @@ prepare() {
|
||||||
# Our containers do not allow sanitizers to run
|
# Our containers do not allow sanitizers to run
|
||||||
patch -Np1 -i ../skip-test.diff
|
patch -Np1 -i ../skip-test.diff
|
||||||
|
|
||||||
# Fix CUDA
|
# https://github.com/mesonbuild/meson/pull/6868
|
||||||
patch -Np1 -i ../0001-environment-Fix-construction-of-CudaLinker.patch
|
patch -Np1 -i ../0001-Fix-meson_jar_template-so-test-suite-passes.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
Loading…
Reference in a new issue