mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
added extra/vigra
This commit is contained in:
parent
cd68fb6bf8
commit
38038d4c0c
2 changed files with 98 additions and 0 deletions
65
extra/vigra/PKGBUILD
Normal file
65
extra/vigra/PKGBUILD
Normal file
|
@ -0,0 +1,65 @@
|
|||
# $Id$
|
||||
# Maintainer: AndyRTR <andyrtr@archlinux.org>
|
||||
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - build v5 with -DCMAKE_CXX_FLAGS=-std=c++11 -DWITH_BOOST_THREAD=1 to fix FTBFS
|
||||
|
||||
pkgbase=vigra
|
||||
pkgname=('vigra' 'vigra-doc')
|
||||
pkgver=1.11.0
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://hci.iwr.uni-heidelberg.de/vigra/"
|
||||
license=('custom:MIT')
|
||||
makedepends=(# runtime deps
|
||||
'libpng' 'libtiff' 'openexr' 'gcc-libs' 'sh' 'hdf5' 'fftw'
|
||||
# additional makedeps
|
||||
'cmake' 'python-nose' 'doxygen' 'python-sphinx' 'boost' 'python-numpy')
|
||||
source=(https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz)
|
||||
md5sums=('7f80d289e03a2f2e8c8e85f3ff29d988')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"/${pkgbase}-${pkgver}
|
||||
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DPYTHON_EXECUTABLE=/usr/bin/python \
|
||||
-DWITH_OPENEXR=true \
|
||||
-DWITH_VIGRANUMPY=1 \
|
||||
-DDOCINSTALL=share/doc \
|
||||
$([ $CARCH == arm ] && echo "-DCMAKE_CXX_FLAGS=-std=c++11 -DWITH_BOOST_THREAD=1")
|
||||
make
|
||||
}
|
||||
|
||||
#check() {
|
||||
# cd "${srcdir}"/${pkgname}-${pkgver}
|
||||
# make -j1 -k check #|| /bin/true # i686 fails
|
||||
#}
|
||||
|
||||
package_vigra() {
|
||||
pkgdesc="Computer vision library"
|
||||
depends=('libpng' 'libtiff' 'openexr' 'gcc-libs' 'sh' 'hdf5' 'fftw')
|
||||
optdepends=('python: for python bindings'
|
||||
'boost-libs: for python bindings')
|
||||
|
||||
cd "${srcdir}"/${pkgbase}-${pkgver}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
# license
|
||||
install -D -m644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
||||
|
||||
# remove doc
|
||||
rm -rf "${pkgdir}"/usr/share/doc
|
||||
}
|
||||
|
||||
package_vigra-doc() {
|
||||
pkgdesc="Computer vision library - documentation and examples"
|
||||
#depends=('vigra')
|
||||
#arch=('any')
|
||||
|
||||
cd "${srcdir}"/${pkgbase}-${pkgver}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
# cleanup
|
||||
rm -rf "${pkgdir}"/usr/{bin,include,lib}
|
||||
|
||||
# license
|
||||
install -D -m644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
||||
}
|
33
extra/vigra/vigra-1.7.1.gcc460.patch
Normal file
33
extra/vigra/vigra-1.7.1.gcc460.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
diff -baur vigra-1.7.1.old/include/vigra/random_forest.hxx vigra-1.7.1/include/vigra/random_forest.hxx
|
||||
--- vigra-1.7.1.old/include/vigra/random_forest.hxx 2010-12-03 17:40:34.000000000 +0000
|
||||
+++ vigra-1.7.1/include/vigra/random_forest.hxx 2011-01-28 00:16:32.000000000 +0000
|
||||
@@ -43,6 +43,7 @@
|
||||
#include <set>
|
||||
#include <list>
|
||||
#include <numeric>
|
||||
+#include <stddef.h>
|
||||
#include "mathutil.hxx"
|
||||
#include "array_vector.hxx"
|
||||
#include "sized_int.hxx"
|
||||
diff -baur vigra-1.7.1.old/include/vigra/sifImport.hxx vigra-1.7.1/include/vigra/sifImport.hxx
|
||||
--- vigra-1.7.1.old/include/vigra/sifImport.hxx 2010-12-03 17:40:34.000000000 +0000
|
||||
+++ vigra-1.7.1/include/vigra/sifImport.hxx 2011-01-28 00:23:31.000000000 +0000
|
||||
@@ -57,6 +57,7 @@
|
||||
#include <fstream>
|
||||
#include <cstring>
|
||||
#include <vector>
|
||||
+#include <stddef.h>
|
||||
#include "vigra/multi_array.hxx"
|
||||
|
||||
namespace vigra {
|
||||
diff -baur vigra-1.7.1.old/include/vigra/multi_iterator.hxx vigra-1.7.1/include/vigra/multi_iterator.hxx
|
||||
--- vigra-1.7.1.old/include/vigra/multi_iterator.hxx 2010-12-03 17:40:34.000000000 +0000
|
||||
+++ vigra-1.7.1/include/vigra/multi_iterator.hxx 2011-01-28 00:23:31.000000000 +0000
|
||||
@@ -41,6 +41,7 @@
|
||||
#define VIGRA_MULTI_ITERATOR_HXX
|
||||
|
||||
#include <sys/types.h>
|
||||
+#include <stddef.h>
|
||||
#include "tinyvector.hxx"
|
||||
#include "iteratortags.hxx"
|
||||
|
Loading…
Reference in a new issue