mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added alarm/uboot-pandaboard
This commit is contained in:
parent
92a30cf86f
commit
38099d6293
3 changed files with 76 additions and 0 deletions
38
alarm/uboot-pandaboard/PKGBUILD
Normal file
38
alarm/uboot-pandaboard/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
# U-Boot: Pandaboard and Pandaboard ES
|
||||||
|
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
|
||||||
|
pkgname=uboot-pandaboard
|
||||||
|
pkgver=2013.04
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
|
||||||
|
arch=('armv7h')
|
||||||
|
url="http://git.denx.de/u-boot.git/"
|
||||||
|
license=('GPL')
|
||||||
|
makedepends=('git')
|
||||||
|
source=("uboot::git://git.denx.de/u-boot.git#tag=v${pkgver}"
|
||||||
|
'http://raw.github.com/eewiki/u-boot-patches/master/v${pkgver}/0001-omap4_common-uEnv.txt-bootz-n-fixes.patch'
|
||||||
|
'alarm.patch'
|
||||||
|
'uEnv.txt')
|
||||||
|
md5sums=('SKIP'
|
||||||
|
'7472e6e0c10c59ca53442bb85a33278e'
|
||||||
|
'2a411ced08f8c536b76b47df64a36d17'
|
||||||
|
'9d4d647761d7e5dac7b6368970c74eb5')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd uboot
|
||||||
|
patch -p1 -i "${srcdir}"/0001-omap4_common-uEnv.txt-bootz-n-fixes.patch
|
||||||
|
patch -p1 -i "${srcdir}"/alarm.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd uboot
|
||||||
|
make distclean
|
||||||
|
make omap4_panda_config
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd uboot
|
||||||
|
mkdir -p "${pkgdir}"/boot
|
||||||
|
cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
|
||||||
|
}
|
29
alarm/uboot-pandaboard/alarm.patch
Normal file
29
alarm/uboot-pandaboard/alarm.patch
Normal file
|
@ -0,0 +1,29 @@
|
||||||
|
diff -urN a/include/configs/omap4_common.h b/include/configs/omap4_common.h
|
||||||
|
--- a/include/configs/omap4_common.h 2013-05-29 14:33:35.068105081 -0600
|
||||||
|
+++ b/include/configs/omap4_common.h 2013-05-29 14:41:54.424745536 -0600
|
||||||
|
@@ -158,6 +158,7 @@
|
||||||
|
"fdtaddr=0x80f80000\0" \
|
||||||
|
"bootpart=0:2\0" \
|
||||||
|
"bootdir=/boot\0" \
|
||||||
|
+ "fdtdir=/boot/dtbs\0" \
|
||||||
|
"bootfile=zImage\0" \
|
||||||
|
"usbtty=cdc_acm\0" \
|
||||||
|
"vram=16M\0" \
|
||||||
|
@@ -166,7 +167,7 @@
|
||||||
|
"buddy=none\0" \
|
||||||
|
"mmcdev=0\0" \
|
||||||
|
"mmcpart=1\0" \
|
||||||
|
- "mmcroot=/dev/mmcblk0p2 ro\0" \
|
||||||
|
+ "mmcroot=/dev/mmcblk0p2 rw\0" \
|
||||||
|
"mmcrootfstype=ext4 rootwait fixrtc\0" \
|
||||||
|
"mmcargs=setenv bootargs console=${console} " \
|
||||||
|
"buddy=${buddy} "\
|
||||||
|
@@ -193,7 +194,7 @@
|
||||||
|
"setenv fdtfile omap4-sdp.dtb; fi; " \
|
||||||
|
"if test $board_name = panda; then " \
|
||||||
|
"setenv fdtfile omap4-panda-es.dtb; fi\0" \
|
||||||
|
- "loadfdt=load mmc ${bootpart} ${fdtaddr} ${bootdir}/${fdtfile}\0" \
|
||||||
|
+ "loadfdt=load mmc ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}\0" \
|
||||||
|
|
||||||
|
#define CONFIG_BOOTCOMMAND \
|
||||||
|
"run findfdt; " \
|
9
alarm/uboot-pandaboard/uEnv.txt
Normal file
9
alarm/uboot-pandaboard/uEnv.txt
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
#SPI: enable for userspace spi access on expansion header
|
||||||
|
#buddy=spidev
|
||||||
|
|
||||||
|
#Video Resolution:
|
||||||
|
#dvimode=1280x720MR-16@60
|
||||||
|
|
||||||
|
#Partitions: default settings:
|
||||||
|
#mmcroot=/dev/mmcblk0p2 rw
|
||||||
|
#mmcrootfstype=ext4 rootwait fixrtc
|
Loading…
Reference in a new issue