extra/blender to 4.0.2-3

This commit is contained in:
Kevin Mihelich 2023-12-12 01:33:42 +00:00
parent c25e48bbb6
commit 387d9e580f
3 changed files with 10 additions and 36 deletions

View file

@ -1,7 +1,7 @@
pkgbase = blender
pkgdesc = A fully integrated 3D graphics creation suite
pkgver = 4.0.2
pkgrel = 2
pkgrel = 3
epoch = 17
url = https://www.blender.org
arch = x86_64

View file

@ -18,7 +18,7 @@ buildarch=8
pkgname=blender
pkgver=4.0.2
pkgrel=2
pkgrel=3
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -56,7 +56,14 @@ sha512sums=('SKIP'
prepare() {
cd "$pkgname"
cp -r "$srcdir"/assets assets
# Create expected path for assets
mkdir -p "$srcdir"/lib
# Copy assets to expected location
cp -r "$srcdir"/assets "$srcdir"/lib/assets
# Remove this directory to prevent it being packaged
rm -r "$srcdir"/lib/assets/.makepkg/
# Copy addons to expected location
cp -r "$srcdir"/blender-addons scripts/addons
cp -r "$srcdir"/blender-addons-contrib scripts/addons_contrib

View file

@ -1,33 +0,0 @@
From d7794f3540cc9837173ed375ea5db4651c1c24df Mon Sep 17 00:00:00 2001
From: "Werner, Stefan" <stefan.werner@intel.com>
Date: Mon, 5 Jun 2023 11:49:17 +0200
Subject: [PATCH] Cycles: Fixed SYCL build with newer compilers
---
intern/cycles/util/math.h | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/intern/cycles/util/math.h b/intern/cycles/util/math.h
index 99415d2ee9b..289bd5d4baf 100644
--- a/intern/cycles/util/math.h
+++ b/intern/cycles/util/math.h
@@ -101,7 +101,6 @@ using std::isfinite;
using std::isnan;
using std::sqrt;
# else
-using sycl::sqrt;
# define isfinite(x) sycl::isfinite((x))
# define isnan(x) sycl::isnan((x))
# endif
@@ -795,7 +794,10 @@ ccl_device float bits_to_01(uint bits)
#if !defined(__KERNEL_GPU__)
# if defined(__GNUC__)
-# define popcount(x) __builtin_popcount(x)
+ccl_device_inline uint popcount(uint x)
+{
+ return __builtin_popcount(x);
+}
# else
ccl_device_inline uint popcount(uint x)
{