mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/calligra to 3.2.1-33
This commit is contained in:
parent
fdd221b70b
commit
38ba500868
2 changed files with 9 additions and 52 deletions
|
@ -9,7 +9,7 @@
|
|||
pkgname=calligra
|
||||
pkgdesc='A set of applications for productivity and creative usage'
|
||||
pkgver=3.2.1
|
||||
pkgrel=32
|
||||
pkgrel=33
|
||||
arch=(x86_64)
|
||||
url='https://www.calligra-suite.org/'
|
||||
license=(FDL1.2 GPL2 LGPL)
|
||||
|
@ -29,27 +29,30 @@ optdepends=('libwpg: Corel WordPerfect Graphics image importer'
|
|||
'qt5-webengine: for Calligra Gemini')
|
||||
source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
calligra-openexr3.patch
|
||||
poppler-22.03.0.patch
|
||||
068cd9ae.patch
|
||||
2ac46db5.patch
|
||||
62f51070.patch)
|
||||
62f51070.patch
|
||||
https://invent.kde.org/office/calligra/-/commit/236bacbe.patch
|
||||
https://invent.kde.org/office/calligra/-/commit/6b75bec7.patch)
|
||||
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
|
||||
'SKIP'
|
||||
'96fbe4f06bf184e60ff653a1574f0f0523af5b4672ced2a501cd54642961dffe'
|
||||
'92593726793577e314ba25359450ee8c3f84b75fb4e99d9cd6baf4ca5df6d2d0'
|
||||
'4516d15421209e5d8c8b5008140dbcb1eefa96b0e96e0da49b343e1799a8cefd'
|
||||
'c88e6d7a1f67c1b5413b624aa67fca2841205fdf4201f6682f69bae737582922'
|
||||
'8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867')
|
||||
'8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867'
|
||||
'94ce2242774d18df21dd594f2d9dce752ffda0349b2c2c872dfe39cb73353aab'
|
||||
'0eb880b19f32fe4045831415fe5849e43db09be3f7550c4abfe21e4511dfb1a5')
|
||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||
options=(debug)
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgname-$pkgver -p1 < calligra-openexr3.patch # Fix build with OpenEXR 3
|
||||
patch -d $pkgname-$pkgver -p1 < poppler-22.03.0.patch # Fix build with poppler 22.03.0
|
||||
patch -d $pkgname-$pkgver -p1 < 068cd9ae.patch # Remove dynamic exception specifications
|
||||
patch -d $pkgname-$pkgver -p1 < 2ac46db5.patch # Prerequisite for the following patch
|
||||
patch -d $pkgname-$pkgver -p1 < 62f51070.patch # Fix fontconfig linking
|
||||
patch -d $pkgname-$pkgver -p1 < 236bacbe.patch # Fix build with poppler 22.03.0
|
||||
patch -d $pkgname-$pkgver -p1 < 6b75bec7.patch # Fix build with poppler 22.04.0
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/CMakeLists.txt calligra-3.2.1/filters/karbon/pdf/CMakeLists.txt
|
||||
--- calligra-3.2.1.orig/filters/karbon/pdf/CMakeLists.txt 2020-05-14 09:51:30.000000000 +0300
|
||||
+++ calligra-3.2.1/filters/karbon/pdf/CMakeLists.txt 2022-03-02 12:19:08.039939530 +0200
|
||||
@@ -14,6 +14,10 @@ if(Poppler_VERSION VERSION_LESS "0.83.0"
|
||||
add_definitions("-DHAVE_POPPLER_PRE_0_83")
|
||||
endif()
|
||||
|
||||
+if(Poppler_VERSION VERSION_LESS "22.3.0")
|
||||
+ add_definitions("-DHAVE_POPPLER_PRE_22_3")
|
||||
+endif()
|
||||
+
|
||||
set(pdf2svg_PART_SRCS PdfImportDebug.cpp PdfImport.cpp SvgOutputDev.cpp )
|
||||
|
||||
add_library(calligra_filter_pdf2svg MODULE ${pdf2svg_PART_SRCS})
|
||||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/Pdf2OdgImport.cpp calligra-3.2.1/filters/karbon/pdf/Pdf2OdgImport.cpp
|
||||
--- calligra-3.2.1.orig/filters/karbon/pdf/Pdf2OdgImport.cpp 2020-05-14 09:51:30.000000000 +0300
|
||||
+++ calligra-3.2.1/filters/karbon/pdf/Pdf2OdgImport.cpp 2022-03-02 12:20:35.125605950 +0200
|
||||
@@ -86,8 +86,12 @@ KoFilter::ConversionStatus Pdf2OdgImport
|
||||
if (! globalParams)
|
||||
return KoFilter::NotImplemented;
|
||||
|
||||
+#ifdef HAVE_POPPLER_PRE_22_3
|
||||
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data());
|
||||
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0);
|
||||
+#else
|
||||
+ PDFDoc * pdfDoc = new PDFDoc(std::make_unique<GooString>(QFile::encodeName(m_chain->inputFile()).data()));
|
||||
+#endif
|
||||
if (! pdfDoc) {
|
||||
#ifdef HAVE_POPPLER_PRE_0_83
|
||||
delete globalParams;
|
||||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/PdfImport.cpp calligra-3.2.1/filters/karbon/pdf/PdfImport.cpp
|
||||
--- calligra-3.2.1.orig/filters/karbon/pdf/PdfImport.cpp 2020-05-14 09:51:30.000000000 +0300
|
||||
+++ calligra-3.2.1/filters/karbon/pdf/PdfImport.cpp 2022-03-02 12:21:46.197510028 +0200
|
||||
@@ -73,8 +73,12 @@ KoFilter::ConversionStatus PdfImport::co
|
||||
if (! globalParams)
|
||||
return KoFilter::NotImplemented;
|
||||
|
||||
+#ifdef HAVE_POPPLER_PRE_22_3
|
||||
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data());
|
||||
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0);
|
||||
+#else
|
||||
+ PDFDoc * pdfDoc = new PDFDoc(std::make_unique<GooString>(QFile::encodeName(m_chain->inputFile()).data()));
|
||||
+#endif
|
||||
if (! pdfDoc) {
|
||||
#ifdef HAVE_POPPLER_PRE_0_83
|
||||
delete globalParams;
|
Loading…
Reference in a new issue