mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/opendht to 3.2.0-1
This commit is contained in:
parent
37a5fa3aa1
commit
38bea2d280
3 changed files with 31 additions and 18 deletions
|
@ -1,7 +1,7 @@
|
||||||
pkgbase = opendht
|
pkgbase = opendht
|
||||||
pkgdesc = C++17 Distributed Hash Table (DHT) implementation
|
pkgdesc = C++17 Distributed Hash Table (DHT) implementation
|
||||||
pkgver = 3.1.9
|
pkgver = 3.2.0
|
||||||
pkgrel = 4
|
pkgrel = 1
|
||||||
epoch = 1
|
epoch = 1
|
||||||
url = https://github.com/savoirfairelinux/opendht
|
url = https://github.com/savoirfairelinux/opendht
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
|
@ -10,8 +10,8 @@ pkgbase = opendht
|
||||||
makedepends = git
|
makedepends = git
|
||||||
makedepends = cmake
|
makedepends = cmake
|
||||||
makedepends = msgpack-cxx
|
makedepends = msgpack-cxx
|
||||||
makedepends = asio
|
|
||||||
makedepends = restinio
|
makedepends = restinio
|
||||||
|
makedepends = asio
|
||||||
makedepends = cython
|
makedepends = cython
|
||||||
makedepends = python-setuptools
|
makedepends = python-setuptools
|
||||||
depends = glibc
|
depends = glibc
|
||||||
|
@ -22,11 +22,13 @@ pkgbase = opendht
|
||||||
depends = jsoncpp
|
depends = jsoncpp
|
||||||
depends = libjsoncpp.so
|
depends = libjsoncpp.so
|
||||||
depends = fmt
|
depends = fmt
|
||||||
depends = http-parser
|
|
||||||
depends = openssl
|
depends = openssl
|
||||||
|
depends = llhttp
|
||||||
optdepends = python: to use the Python bindings
|
optdepends = python: to use the Python bindings
|
||||||
optdepends = msgpack-cxx: linking against opendht
|
optdepends = msgpack-cxx: linking against opendht
|
||||||
source = git+https://github.com/savoirfairelinux/opendht#commit=4eaa53a4a6c5bee338c0363a765a68505bd75085
|
source = git+https://github.com/savoirfairelinux/opendht#tag=v3.2.0
|
||||||
sha256sums = a62ef74869dde75c52ae3b26d187499be58d293b41aed3730d277793ecb4a420
|
source = llhttp.patch
|
||||||
|
sha256sums = 12f71503ba7253ca5545676ffed7a6fea9497e0227c9e2112d1901b7c8a63412
|
||||||
|
sha256sums = 0f0b394656f719508ea83dd3ea87b08245fa1413a91e50a144dede20b2e3ca22
|
||||||
|
|
||||||
pkgname = opendht
|
pkgname = opendht
|
||||||
|
|
|
@ -7,30 +7,28 @@
|
||||||
|
|
||||||
pkgname=opendht
|
pkgname=opendht
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgver=3.1.9
|
pkgver=3.2.0
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc="C++17 Distributed Hash Table (DHT) implementation"
|
pkgdesc="C++17 Distributed Hash Table (DHT) implementation"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://github.com/savoirfairelinux/opendht"
|
url="https://github.com/savoirfairelinux/opendht"
|
||||||
license=(GPL3)
|
license=(GPL3)
|
||||||
depends=(glibc gnutls nettle readline argon2 jsoncpp libjsoncpp.so fmt http-parser openssl)
|
depends=(glibc gnutls nettle readline argon2 jsoncpp libjsoncpp.so fmt openssl llhttp)
|
||||||
makedepends=(git cmake msgpack-cxx asio restinio cython python-setuptools cppunit)
|
makedepends=(git cmake msgpack-cxx restinio asio cython python-setuptools cppunit)
|
||||||
optdepends=('python: to use the Python bindings'
|
optdepends=('python: to use the Python bindings'
|
||||||
'msgpack-cxx: linking against opendht')
|
'msgpack-cxx: linking against opendht')
|
||||||
_commit=4eaa53a4a6c5bee338c0363a765a68505bd75085
|
source=(git+${url}#tag=v$pkgver
|
||||||
source=(git+${url}#commit=${_commit})
|
llhttp.patch)
|
||||||
sha256sums=('a62ef74869dde75c52ae3b26d187499be58d293b41aed3730d277793ecb4a420')
|
sha256sums=('12f71503ba7253ca5545676ffed7a6fea9497e0227c9e2112d1901b7c8a63412'
|
||||||
|
'0f0b394656f719508ea83dd3ea87b08245fa1413a91e50a144dede20b2e3ca22')
|
||||||
|
|
||||||
pkgver() {
|
prepare() {
|
||||||
cd ${pkgname}
|
patch -d $pkgname -p1 < llhttp.patch # Fix llhttp lib name
|
||||||
git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./;s/-/+/'
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cmake -B build -S ${pkgname} \
|
cmake -B build -S ${pkgname} \
|
||||||
-DCMAKE_BUILD_TYPE=None \
|
|
||||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
|
||||||
-DOPENDHT_DOCUMENTATION=OFF \
|
-DOPENDHT_DOCUMENTATION=OFF \
|
||||||
-DOPENDHT_TESTS=ON \
|
-DOPENDHT_TESTS=ON \
|
||||||
-DOPENDHT_SYSTEMD=ON \
|
-DOPENDHT_SYSTEMD=ON \
|
||||||
|
|
13
extra/opendht/llhttp.patch
Normal file
13
extra/opendht/llhttp.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index 57f767af..6b9403ef 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -97,7 +97,7 @@ if (NOT MSVC)
|
||||||
|
|
||||||
|
# llhttp
|
||||||
|
find_path(LLHTTP_INCLUDE_DIR llhttp.h)
|
||||||
|
- find_library(LLHTTP_LIBRARY libllhttp)
|
||||||
|
+ find_library(LLHTTP_LIBRARY llhttp)
|
||||||
|
if (LLHTTP_INCLUDE_DIR AND LLHTTP_LIBRARY)
|
||||||
|
message(STATUS "Found llhttp ${LLHTTP_INCLUDE_DIR} ${LLHTTP_LIBRARY}")
|
||||||
|
add_library(llhttp_static STATIC IMPORTED)
|
Loading…
Reference in a new issue