mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt to 4.7.3-1
This commit is contained in:
parent
79c9b78f2e
commit
39d4318d4f
2 changed files with 18 additions and 101 deletions
|
@ -1,16 +1,19 @@
|
|||
# $Id: PKGBUILD 117207 2011-03-29 18:21:55Z andrea $
|
||||
# $Id: PKGBUILD 122539 2011-05-04 13:21:18Z andrea $
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Pierre Schmitz <pierre@archlinux.de>
|
||||
|
||||
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
||||
# - Just say NO to x86 optimizations ;)
|
||||
# - disabled distcc, ccache - bad things happen
|
||||
# - don't use -no-neon on armv7
|
||||
# - make -j1
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.7.2
|
||||
pkgrel=6
|
||||
pkgver=4.7.3
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt.nokia.com/'
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -18,18 +21,16 @@ makedepends=('libtiff' 'libpng' 'libmng' 'sqlite3' 'ca-certificates' 'glib2' 'db
|
|||
'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
|
||||
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'mesa' 'postgresql-libs'
|
||||
'mysql' 'unixodbc' 'cups' 'gtk2')
|
||||
options=('!libtool')
|
||||
options=('!libtool' '!distcc' '!ccache')
|
||||
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
||||
source=("ftp://ftp.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop'
|
||||
'blacklist-fraudulent-comodo-certificates.patch')
|
||||
md5sums=('66b992f5c21145df08c99d21847f4fdb'
|
||||
'qtconfig.desktop')
|
||||
md5sums=('49b96eefb1224cc529af6fe5608654fe'
|
||||
'fc211414130ab2764132e7370f8e5caa'
|
||||
'85179f5e0437514f8639957e1d8baf62'
|
||||
'f11852b97583610f3dbb669ebc3e21bc'
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
||||
'af1259401447f4de59f1d4c2cbedafed')
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd')
|
||||
|
||||
build() {
|
||||
unset QMAKESPEC
|
||||
|
@ -43,6 +44,12 @@ build() {
|
|||
sed -i "/^QMAKE_RPATH/s| -Wl,-rpath,||g" mkspecs/common/g++.conf
|
||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" mkspecs/common/g++.conf
|
||||
|
||||
if [ "${CARCH}" = "armv7" ]; then
|
||||
useneon=""
|
||||
else
|
||||
useneon="-no-neon"
|
||||
fi
|
||||
|
||||
./configure -confirm-license -opensource \
|
||||
-prefix /usr \
|
||||
-docdir /usr/share/doc/qt \
|
||||
|
@ -90,9 +97,8 @@ build() {
|
|||
-no-ssse3 \
|
||||
-no-sse4.1 \
|
||||
-no-sse4.2 \
|
||||
-no-avx \
|
||||
-no-neon
|
||||
make
|
||||
-no-avx ${useneon}
|
||||
make -j1
|
||||
}
|
||||
|
||||
package_qt() {
|
||||
|
|
|
@ -1,89 +0,0 @@
|
|||
diff --git a/src/network/ssl/qsslcertificate.cpp b/src/network/ssl/qsslcertificate.cpp
|
||||
index 618ac79..a5cdf01 100644
|
||||
--- a/src/network/ssl/qsslcertificate.cpp
|
||||
+++ b/src/network/ssl/qsslcertificate.cpp
|
||||
@@ -219,17 +219,19 @@ bool QSslCertificate::isNull() const
|
||||
Returns true if this certificate is valid; otherwise returns
|
||||
false.
|
||||
|
||||
- Note: Currently, this function only checks that the current
|
||||
+ Note: Currently, this function checks that the current
|
||||
data-time is within the date-time range during which the
|
||||
- certificate is considered valid. No other checks are
|
||||
- currently performed.
|
||||
+ certificate is considered valid, and checks that the
|
||||
+ certificate is not in a blacklist of fraudulent certificates.
|
||||
|
||||
\sa isNull()
|
||||
*/
|
||||
bool QSslCertificate::isValid() const
|
||||
{
|
||||
const QDateTime currentTime = QDateTime::currentDateTime();
|
||||
- return currentTime >= d->notValidBefore && currentTime <= d->notValidAfter;
|
||||
+ return currentTime >= d->notValidBefore &&
|
||||
+ currentTime <= d->notValidAfter &&
|
||||
+ ! QSslCertificatePrivate::isBlacklisted(*this);
|
||||
}
|
||||
|
||||
/*!
|
||||
@@ -798,6 +800,30 @@ QList<QSslCertificate> QSslCertificatePrivate::certificatesFromDer(const QByteAr
|
||||
return certificates;
|
||||
}
|
||||
|
||||
+// These certificates are known to be fraudulent and were created during the comodo
|
||||
+// compromise. See http://www.comodo.com/Comodo-Fraud-Incident-2011-03-23.html
|
||||
+static const char *certificate_blacklist[] = {
|
||||
+ "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e",
|
||||
+ "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06",
|
||||
+ "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3",
|
||||
+ "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29",
|
||||
+ "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71",
|
||||
+ "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47",
|
||||
+ "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43",
|
||||
+ "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0",
|
||||
+ "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0",
|
||||
+ 0
|
||||
+};
|
||||
+
|
||||
+bool QSslCertificatePrivate::isBlacklisted(const QSslCertificate &certificate)
|
||||
+{
|
||||
+ for (int a = 0; certificate_blacklist[a] != 0; a++) {
|
||||
+ if (certificate.serialNumber() == certificate_blacklist[a])
|
||||
+ return true;
|
||||
+ }
|
||||
+ return false;
|
||||
+}
|
||||
+
|
||||
#ifndef QT_NO_DEBUG_STREAM
|
||||
QDebug operator<<(QDebug debug, const QSslCertificate &certificate)
|
||||
{
|
||||
diff --git a/src/network/ssl/qsslcertificate_p.h b/src/network/ssl/qsslcertificate_p.h
|
||||
index cdceb0f..1ce33d3 100644
|
||||
--- a/src/network/ssl/qsslcertificate_p.h
|
||||
+++ b/src/network/ssl/qsslcertificate_p.h
|
||||
@@ -96,6 +96,7 @@ public:
|
||||
static QSslCertificate QSslCertificate_from_X509(X509 *x509);
|
||||
static QList<QSslCertificate> certificatesFromPem(const QByteArray &pem, int count = -1);
|
||||
static QList<QSslCertificate> certificatesFromDer(const QByteArray &der, int count = -1);
|
||||
+ static bool isBlacklisted(const QSslCertificate &certificate);
|
||||
|
||||
friend class QSslSocketBackendPrivate;
|
||||
|
||||
diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
|
||||
index 0866534..2427193 100644
|
||||
--- a/src/network/ssl/qsslsocket_openssl.cpp
|
||||
+++ b/src/network/ssl/qsslsocket_openssl.cpp
|
||||
@@ -1193,6 +1193,13 @@ bool QSslSocketBackendPrivate::startHandshake()
|
||||
X509 *x509 = q_SSL_get_peer_certificate(ssl);
|
||||
configuration.peerCertificate = QSslCertificatePrivate::QSslCertificate_from_X509(x509);
|
||||
q_X509_free(x509);
|
||||
+ if (QSslCertificatePrivate::isBlacklisted(configuration.peerCertificate)) {
|
||||
+ q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
|
||||
+ q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
|
||||
+ emit q->error(QAbstractSocket::SslHandshakeFailedError);
|
||||
+ plainSocket->disconnectFromHost();
|
||||
+ return false;
|
||||
+ }
|
||||
|
||||
// Start translating errors.
|
||||
QList<QSslError> errors;
|
Loading…
Reference in a new issue