core/initscripts to 2012.06.3

This commit is contained in:
Kevin Mihelich 2012-07-15 18:25:26 -04:00
parent 2812cf6d01
commit 39dfbce6dd
3 changed files with 45 additions and 25 deletions

View file

@ -0,0 +1,28 @@
From 55bd14c586f0f64b8ee5515161be1aa1098d3226 Mon Sep 17 00:00:00 2001
From: Dave Reisner <dreisner@archlinux.org>
Date: Tue, 3 Jul 2012 22:28:05 -0400
Subject: [initscripts][PATCH] remove /run/nologin before leaving rc.multi
To: arch-projects@archlinux.org
systemd-186 writes this file when running systemd-tmpfiles, but
initscripts never removes it. This disallows all non-root logins.
Reported-by: Dan McGee <dan@archlinux.org>
Signed-off-by: Dave Reisner <dreisner@archlinux.org>
---
rc.multi | 2 ++
1 file changed, 2 insertions(+)
diff --git a/rc.multi b/rc.multi
index daf2372..7d4acaa 100755
--- a/rc.multi
+++ b/rc.multi
@@ -31,4 +31,6 @@ run_hook multi_end
bootlogd_stop
+rm -f /run/nologin
+
# vim: set ts=2 sw=2 noet:
--
1.7.11.1

View file

@ -5,13 +5,11 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - inittab serial setup for v5/v7
# - patch to adjust naming to ALARM, fix remounting root, turn off LEDs on shutdown
plugrel=1
# - patch to adjust naming to ALARM, turn off LEDs on shutdown
pkgname=initscripts
pkgver=2012.06.2
pkgrel=1
pkgver=2012.06.3
pkgrel=2
pkgdesc="System initialization/bootup scripts"
arch=('any')
url="http://www.archlinux.org"
@ -26,18 +24,21 @@ optdepends=('bridge-utils: Network bridging support'
makedepends=(asciidoc)
install=initscripts.install
source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz"
'0001-remove-run-nologin-before-leaving-rc.multi.patch'
'wireless.conf.d'
'alarm.patch'
'rc.conf')
md5sums=('db1891a58ec03bb912e7935aa8723b4f'
md5sums=('34493c768b587ac59c6ee7e14f275c1d'
'87f02d111e0c613dd9fc61a9613f9c92'
'027576534885b8d5dded9be546057b12'
'e77890fd546ca599a2bd129b040c0b05'
'a314e2858690154344b3a5a754f23dd3'
'c618e099f522f861e08a475f8960a6c2')
package() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -p1 -i "${srcdir}/alarm.patch"
patch -Np1 <"$srcdir/0001-remove-run-nologin-before-leaving-rc.multi.patch"
cp "${srcdir}/rc.conf" .
[ "${CARCH}" == "arm" ] && sed -i 's/@TTY@/ttyS0/' inittab
[ "${CARCH}" == "armv7h" ] && sed -i 's/@TTY@/ttyO2/' inittab

View file

@ -1,6 +1,6 @@
diff -urN a/inittab b/inittab
--- a/inittab 2012-05-05 08:25:45.000000000 -0600
+++ b/inittab 2012-05-05 11:55:08.000000000 -0600
--- a/inittab 2012-06-29 07:26:59.000000000 -0600
+++ b/inittab 2012-07-15 16:02:29.969505191 -0600
@@ -24,12 +24,13 @@
su:S:wait:/sbin/sulogin -p
@ -20,9 +20,9 @@ diff -urN a/inittab b/inittab
# Serial Virtual Console for KVM and others VMs
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux
diff -urN a/rc.shutdown b/rc.shutdown
--- a/rc.shutdown 2012-05-05 08:25:45.000000000 -0600
+++ b/rc.shutdown 2012-05-05 11:55:08.000000000 -0600
@@ -87,6 +87,10 @@
--- a/rc.shutdown 2012-06-29 07:26:59.000000000 -0600
+++ b/rc.shutdown 2012-07-15 16:02:29.969505191 -0600
@@ -76,6 +76,10 @@
run_hook shutdown_poweroff
@ -34,10 +34,10 @@ diff -urN a/rc.shutdown b/rc.shutdown
# decide what we want to do
diff -urN a/rc.sysinit b/rc.sysinit
--- a/rc.sysinit 2012-05-05 08:25:45.000000000 -0600
+++ b/rc.sysinit 2012-05-05 11:55:08.000000000 -0600
@@ -7,8 +7,8 @@
. /etc/rc.d/functions
--- a/rc.sysinit 2012-06-29 07:26:59.000000000 -0600
+++ b/rc.sysinit 2012-07-15 16:02:29.969505191 -0600
@@ -13,8 +13,8 @@
fi
echo " "
-printhl "Arch Linux\n"
@ -47,12 +47,3 @@ diff -urN a/rc.sysinit b/rc.sysinit
printsep
# mount the api filesystems
@@ -148,7 +148,7 @@
fsck_reboot $fsckret
status "Remounting Root" \
- mount -o remount /
+ mount -o remount,rw /
# now mount all the local filesystems
run_hook sysinit_premount