community/blender to 2.79.b.git3.32432d91-10

This commit is contained in:
Kevin Mihelich 2018-10-07 22:09:28 +00:00
parent ccbd8b28d0
commit 3a36fc1b42
2 changed files with 18 additions and 2 deletions

View file

@ -22,7 +22,7 @@ _gitcommit=32432d91bbec558cbd88e54aece61b0d641c1761
pkgname=blender
pkgver=2.79.b
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git3.${_gitcommit:0:8}
pkgrel=9
pkgrel=10
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -44,7 +44,8 @@ source=("git://git.blender.org/blender-addons.git"
ffmpeg4.0.patch
tree_hpp.patch
util_sseb.patch
openvdb3-abi.patch)
openvdb3-abi.patch
stl_export_iter.patch)
if [[ -n $_gittag ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
elif [[ -n $_gitcommit ]]; then
@ -60,6 +61,7 @@ md5sums=('SKIP'
'feea89510de171946c41c6208461f453'
'53da216adbc2a9d555a59c15b8f0ef08'
'3f9613fcb7ea61214982272e9c20a294'
'f21e971208232d8d78d1a4c41013a101'
'SKIP')
prepare() {
@ -78,6 +80,7 @@ prepare() {
patch -Np1 -i "$srcdir"/tree_hpp.patch
patch -Np1 -i "$srcdir"/util_sseb.patch
patch -Np1 -i "$srcdir"/openvdb3-abi.patch
patch -Np1 -i "$srcdir"/stl_export_iter.patch
}
build() {

View file

@ -0,0 +1,13 @@
diff --git a/release/scripts/addons/io_mesh_stl/blender_utils.py b/release/scripts/addons/io_mesh_stl/blender_utils.py
index 864335ab..c74853db 100644
--- a/release/scripts/addons/io_mesh_stl/blender_utils.py
+++ b/release/scripts/addons/io_mesh_stl/blender_utils.py
@@ -86,7 +86,7 @@ def faces_from_mesh(ob, global_matrix, use_mesh_modifiers=False, triangulate=Tru
try:
mesh = ob.to_mesh(bpy.context.scene, use_mesh_modifiers, "PREVIEW")
except RuntimeError:
- raise StopIteration
+ return
mat = global_matrix * ob.matrix_world
mesh.transform(mat)