mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/grub to 2.06.r499.ge67a551a4-2
This commit is contained in:
parent
3fb3199850
commit
3a3747e5cd
2 changed files with 34 additions and 2 deletions
|
@ -0,0 +1,28 @@
|
|||
From ac560966d09295663fa9516d8d137e0c0fd04c06 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Mon, 12 Jun 2023 07:42:01 +0200
|
||||
Subject: [PATCH 1/1] support dropins for default configuration
|
||||
|
||||
---
|
||||
util/grub-mkconfig.in | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/util/grub-mkconfig.in b/util/grub-mkconfig.in
|
||||
index 1a945085c..4338dceef 100644
|
||||
--- a/util/grub-mkconfig.in
|
||||
+++ b/util/grub-mkconfig.in
|
||||
@@ -160,6 +160,11 @@ fi
|
||||
if test -f ${sysconfdir}/default/grub ; then
|
||||
. ${sysconfdir}/default/grub
|
||||
fi
|
||||
+for dropin in ${sysconfdir}/default/grub.d/*.cfg ; do
|
||||
+ if test -f "${dropin}" ; then
|
||||
+ . "${dropin}"
|
||||
+ fi
|
||||
+done
|
||||
|
||||
if [ "x${GRUB_DISABLE_UUID}" = "xtrue" ]; then
|
||||
if [ -z "${GRUB_DISABLE_LINUX_UUID}" ]; then
|
||||
--
|
||||
2.41.0
|
||||
|
|
@ -31,9 +31,9 @@ pkgdesc='GNU GRand Unified Bootloader (2)'
|
|||
epoch=2
|
||||
_commit='e67a551a48192a04ab705fca832d82f850162b64'
|
||||
_pkgver=2.06.r499.ge67a551a4
|
||||
_unifont_ver='14.0.04'
|
||||
_unifont_ver='15.0.06'
|
||||
pkgver=${_pkgver/-/}
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
url='https://www.gnu.org/software/grub/'
|
||||
arch=('x86_64')
|
||||
license=('GPL3')
|
||||
|
@ -73,6 +73,7 @@ source=("git+https://git.savannah.gnu.org/git/grub.git#commit=${_commit}"
|
|||
"https://ftp.gnu.org/gnu/unifont/unifont-${_unifont_ver}/unifont-${_unifont_ver}.bdf.gz"{,.sig}
|
||||
'0001-00_header-add-GRUB_COLOR_-variables.patch'
|
||||
'0002-10_linux-detect-archlinux-initramfs.patch'
|
||||
'0003-support-dropins-for-default-configuration.patch'
|
||||
'0004-10_linux-add-archlinuxarm-s-default-kernel-path.patch'
|
||||
'grub.default'
|
||||
'sbat.csv')
|
||||
|
@ -140,6 +141,9 @@ prepare() {
|
|||
echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
|
||||
patch -Np1 -i "${srcdir}/0002-10_linux-detect-archlinux-initramfs.patch"
|
||||
|
||||
echo "Patch to support dropins for default configuration..."
|
||||
patch -Np1 -i "${srcdir}/0003-support-dropins-for-default-configuration.patch"
|
||||
|
||||
echo "Patch to detect of Arch Linux ARM kernel images by grub-mkconfig..."
|
||||
patch -Np1 -i "${srcdir}/0004-10_linux-add-archlinuxarm-s-default-kernel-path.patch"
|
||||
|
||||
|
|
Loading…
Reference in a new issue