mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/cppcheck to 2.11.1-1
This commit is contained in:
parent
c99da5241d
commit
3a4a8b659e
2 changed files with 4 additions and 24 deletions
|
@ -6,7 +6,7 @@
|
||||||
# - remove makedepend on pandoc, don't generate manuals
|
# - remove makedepend on pandoc, don't generate manuals
|
||||||
|
|
||||||
pkgname=cppcheck
|
pkgname=cppcheck
|
||||||
pkgver=2.11
|
pkgver=2.11.1
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='A tool for static C/C++ code analysis'
|
pkgdesc='A tool for static C/C++ code analysis'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
|
@ -31,18 +31,15 @@ optdepends=(
|
||||||
'python-pygments: cppcheck-htmlreport'
|
'python-pygments: cppcheck-htmlreport'
|
||||||
'clang: for cppcheck-gui integration'
|
'clang: for cppcheck-gui integration'
|
||||||
)
|
)
|
||||||
_commit='f156b1ecb20af834d6d70a20b9485533e2b5bdaf'
|
_commit='13746898140fa229018b57acdb18091942c8ea05'
|
||||||
source=(
|
source=(
|
||||||
"$pkgname::git+https://github.com/danmar/cppcheck.git#commit=$_commit"
|
"$pkgname::git+https://github.com/danmar/cppcheck.git#commit=$_commit"
|
||||||
'translations-location.patch'
|
'translations-location.patch'
|
||||||
'ftbfs-version-string.patch'
|
|
||||||
)
|
)
|
||||||
sha512sums=('SKIP'
|
sha512sums=('SKIP'
|
||||||
'd3528834d719017ec3a0e08005a293089b556622928defa1b37f940e62cb01165dcbd741e6d5e989c0156fb8789f7e63702af8b2390738648b2300a92f4ab0ae'
|
'd3528834d719017ec3a0e08005a293089b556622928defa1b37f940e62cb01165dcbd741e6d5e989c0156fb8789f7e63702af8b2390738648b2300a92f4ab0ae')
|
||||||
'd8ee5ad49e1d62571677c730b688853220ff74a6cb7d45ab35360c6c1c4819a1e064eb18835913bc62f36f6273da5d50e86d68bc9f9bf9fcd0a3dd4ff949d176')
|
|
||||||
b2sums=('SKIP'
|
b2sums=('SKIP'
|
||||||
'8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f'
|
'8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f')
|
||||||
'3dda14b1c4530ba408884a00395e78db3bc507788a5c7f98f441650a78deec8ac22231d6473a39efbe21237beb20a31f85b6c8abf761b29ab2598a1672cee4b5')
|
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd "$pkgname"
|
cd "$pkgname"
|
||||||
|
@ -55,14 +52,6 @@ prepare() {
|
||||||
|
|
||||||
# fix location of translations
|
# fix location of translations
|
||||||
patch -p1 -i "$srcdir/translations-location.patch"
|
patch -p1 -i "$srcdir/translations-location.patch"
|
||||||
|
|
||||||
# FTBFS due to GCC13
|
|
||||||
git cherry-pick --no-commit f4030c4b1ae8ac3001bfc9f85e24a51ad2f08d79
|
|
||||||
|
|
||||||
# FTBFS due to version string
|
|
||||||
# https://sourceforge.net/p/cppcheck/discussion/general/thread/12b363e1af/
|
|
||||||
# https://sourceforge.net/p/cppcheck/discussion/development/thread/e57efb2b62/
|
|
||||||
patch -p1 -i "$srcdir/ftbfs-version-string.patch"
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,9 +0,0 @@
|
||||||
--- a/cmake/versions.cmake
|
|
||||||
+++ b/cmake/versions.cmake
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
# Version for libraries CPP
|
|
||||||
-SET(VERSION "2.11")
|
|
||||||
+SET(VERSION "2.11.0")
|
|
||||||
STRING(REGEX MATCHALL "[0-9]+" VERSION_PARTS "${VERSION}")
|
|
||||||
LIST(GET VERSION_PARTS 0 VERSION_MAJOR)
|
|
||||||
LIST(GET VERSION_PARTS 1 VERSION_MINOR)
|
|
Loading…
Reference in a new issue