community/clementine to 1.3.1-20

This commit is contained in:
Kevin Mihelich 2018-09-25 23:21:30 +00:00
parent 3fa42ef806
commit 3a4f81ae64
3 changed files with 9 additions and 62 deletions

View file

@ -8,7 +8,7 @@
pkgname=clementine
pkgver=1.3.1
pkgrel=19
pkgrel=20
pkgdesc='A modern music player and library organizer'
url='http://www.clementine-player.org/'
license=('GPL')
@ -26,16 +26,12 @@ optdepends=('gst-plugins-base: "Base" plugin libraries'
'gvfs: Various devices support')
source=("git+https://github.com/clementine-player/Clementine.git#tag=${pkgver}"
'clementine-gcc6.patch'
'add-missing-functional-includes-5630.patch'
'clementine-1.3.1-chromaprint-1.4.0.patch'
'clementine-cryptopp6.patch'
'https://github.com/clementine-player/Clementine/commit/75f9439843a0e9cdc26cd739d5e1dbd93bd974bc.patch')
'clementine-chromaprint1.4.0.patch'
'clementine-cryptopp6.patch')
sha256sums=('SKIP'
'05bd4dc0138eed084332fa1a688a96858418731f337f54e0d8ab0853123f40ee'
'213a1c2eb3f3c1d2904ed855ad851c10705d04cfa20b36b843b60003469fdc1a'
'4cc9c9df599df4a595c6acf4e129a54296c0a8e537627435e3df14e1e95447b0'
'e9c09dca76ed8fae2ecb089571396c9293f546871fb2f27cc37010dd5cba9e46'
'd4dbd7f09da7a554f86237476b96e3ca097117b7ab2acd706088c72203d8b64f')
'e9c09dca76ed8fae2ecb089571396c9293f546871fb2f27cc37010dd5cba9e46')
prepare() {
if [[ -d build ]]; then
@ -48,13 +44,15 @@ prepare() {
# Fix build with GCC 6
patch -p1 -i ../clementine-gcc6.patch
# https://github.com/clementine-player/Clementine/pull/5630
patch -p1 -i ../add-missing-functional-includes-5630.patch
git cherry-pick -n 8a6cc8b5069265e1e92e22def985e22c5955e503
# Fix build with chromaprint 1.4.0
patch -p1 -i ../clementine-1.3.1-chromaprint-1.4.0.patch
patch -p1 -i ../clementine-chromaprint1.4.0.patch
# Fix build with crypto++ 6.0.0 due to https://github.com/weidai11/cryptopp/issues/442
patch -p1 -i ../clementine-cryptopp6.patch
# FS#58413
patch -Np1 -i ../75f9439843a0e9cdc26cd739d5e1dbd93bd974bc.patch
git cherry-pick -n -m 1 75f9439843a0e9cdc26cd739d5e1dbd93bd974bc
# Fix DI.FM
git cherry-pick -n ddfa5e63f1ef0e243a007efbe576fceb9b2442e8
if [[ $CARCH == "aarch64" ]]; then
sed -i 's/fpic/fPIC/' 3rdparty/vreen/vreen/cmake/CommonUtils.cmake

View file

@ -1,51 +0,0 @@
From 8a6cc8b5069265e1e92e22def985e22c5955e503 Mon Sep 17 00:00:00 2001
From: Morris Hafner <mmha@users.noreply.github.com>
Date: Mon, 13 Feb 2017 17:46:46 +0100
Subject: [PATCH] Add missing <functional> includes (#5630)
---
src/core/mergedproxymodel.cpp | 1 +
src/devices/giolister.cpp | 1 +
src/library/groupbydialog.cpp | 2 ++
3 files changed, 4 insertions(+)
diff --git a/src/core/mergedproxymodel.cpp b/src/core/mergedproxymodel.cpp
index 56217f6fd..8c210d391 100644
--- a/src/core/mergedproxymodel.cpp
+++ b/src/core/mergedproxymodel.cpp
@@ -23,6 +23,7 @@
#include <QStringList>
+#include <functional>
#include <limits>
// boost::multi_index still relies on these being in the global namespace.
diff --git a/src/devices/giolister.cpp b/src/devices/giolister.cpp
index aa3bddb34..5f63ef248 100644
--- a/src/devices/giolister.cpp
+++ b/src/devices/giolister.cpp
@@ -17,6 +17,7 @@
#include "config.h"
+#include <functional>
#include <memory>
#include <QFile>
diff --git a/src/library/groupbydialog.cpp b/src/library/groupbydialog.cpp
index 5efdc9f36..e5f711b34 100644
--- a/src/library/groupbydialog.cpp
+++ b/src/library/groupbydialog.cpp
@@ -20,6 +20,8 @@
#include <QPushButton>
+#include <functional>
+
// boost::multi_index still relies on these being in the global namespace.
using std::placeholders::_1;
using std::placeholders::_2;
--
2.13.4