mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/mysql-workbench to 6.3.9-4
This commit is contained in:
parent
ad7cb72eb3
commit
3a8ab5ada9
2 changed files with 72 additions and 5 deletions
62
community/mysql-workbench/0005-gdal-use-CPLFree.patch
Normal file
62
community/mysql-workbench/0005-gdal-use-CPLFree.patch
Normal file
|
@ -0,0 +1,62 @@
|
|||
From 97d26e5edfccead3fe3a10b732de51caa427eb60 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Tue, 16 May 2017 09:31:39 +0200
|
||||
Subject: [PATCH 1/1] gdal: use CPLFree()
|
||||
|
||||
OGRFree() is deprecated as of gdal 2.2.0, so use CPLFree() instead.
|
||||
|
||||
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||
---
|
||||
backend/wbpublic/grt/spatial_handler.cpp | 4 ++--
|
||||
backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp | 6 +++---
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/backend/wbpublic/grt/spatial_handler.cpp b/backend/wbpublic/grt/spatial_handler.cpp
|
||||
index 9b357603..ee36fa03 100644
|
||||
--- a/backend/wbpublic/grt/spatial_handler.cpp
|
||||
+++ b/backend/wbpublic/grt/spatial_handler.cpp
|
||||
@@ -443,7 +443,7 @@ spatial::Importer::Importer() : _geometry(NULL), _interrupt(false), _srid(0) {
|
||||
|
||||
spatial::Importer::~Importer() {
|
||||
if (_geometry != NULL)
|
||||
- OGRFree(_geometry);
|
||||
+ CPLFree(_geometry);
|
||||
}
|
||||
|
||||
OGRGeometry *spatial::Importer::steal_data() {
|
||||
@@ -495,7 +495,7 @@ std::string spatial::Importer::as_wkt() {
|
||||
logError("Error exporting data to WKT (%i)\n", err);
|
||||
} else {
|
||||
std::string tmp(data);
|
||||
- OGRFree(data);
|
||||
+ CPLFree(data);
|
||||
return tmp;
|
||||
}
|
||||
}
|
||||
diff --git a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
|
||||
index d2eb8495..7a7948bf 100644
|
||||
--- a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
|
||||
+++ b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
|
||||
@@ -47,7 +47,7 @@ static grt::StringRef getGeoRepresentation(grt::StringRef data, bool outputAsJso
|
||||
OGRGeometryFactory::createFromWkb((unsigned char *)const_cast<char *>(&(*((*data).begin() + 4))), NULL, &geometry);
|
||||
if (ret_val != OGRERR_NONE) {
|
||||
if (geometry)
|
||||
- OGRFree(geometry);
|
||||
+ CPLFree(geometry);
|
||||
throw std::exception();
|
||||
}
|
||||
|
||||
@@ -61,8 +61,8 @@ static grt::StringRef getGeoRepresentation(grt::StringRef data, bool outputAsJso
|
||||
|
||||
if (err == OGRERR_NONE && data != NULL) {
|
||||
grt::StringRef tmp(data);
|
||||
- OGRFree(data);
|
||||
- OGRFree(geometry);
|
||||
+ CPLFree(data);
|
||||
+ CPLFree(geometry);
|
||||
return tmp;
|
||||
} else
|
||||
throw std::runtime_error("Conversion of OGR geometry data failed");
|
||||
--
|
||||
2.13.0
|
||||
|
|
@ -13,10 +13,10 @@ buildarch=28
|
|||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=6.3.9
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
_mysql_version=5.7.18
|
||||
_connector_version=1.1.8
|
||||
_gdal_version=2.1.3
|
||||
_connector_version=1.1.9
|
||||
_gdal_version=2.2.0
|
||||
_boost_version=1.59.0
|
||||
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -40,20 +40,22 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0003-add-option-to-hide-nonstandard-server-warning.patch'
|
||||
'0004-fix-build-for-i686.patch'
|
||||
'0005-gdal-use-CPLFree.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('607af29481821b25c13c8b28011162c9d6d5e9ef96df5f664408116b88308951'
|
||||
'SKIP'
|
||||
'0b5d71ed608656cd8181d3bb0434d3e36bac192899038dbdddf5a7594aaea1a2'
|
||||
'SKIP'
|
||||
'85ff10bd056128562f92b440eb27766cfcd558b474bfddc1153f7dd8feb5f963'
|
||||
'3e31847a69a4e5c113b7c483731317ec4533858e3195d3a85026a0e2f509d2e4'
|
||||
'SKIP'
|
||||
'b489793627e6cb8d2ff8d7737b61daf58382fe189fae4c581ddfd48c04b49005'
|
||||
'0d4c326862e0f118e17418c042c2bcd037b25abd3fb198e1fc5d40b11a9fc8ea'
|
||||
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
|
||||
'9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7'
|
||||
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
|
||||
'0d65832bc5a73d4cfecef4b552bb78a30ce6020a5fabe5558dcf2ade8341b593'
|
||||
'3c9097af599f08388c471d6fd02f40ea72e5759eaa89f731e662852a5e67feea'
|
||||
'68295716c55e5f7b07b3ec1162b512b33a0563952a0eb4ef6fd71d852c61de11'
|
||||
'0965b4f12a0ae26bea131f05c7383d4a9b068d556b092ad23e19e1d8f6895531'
|
||||
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
||||
|
||||
prepare() {
|
||||
|
@ -72,6 +74,9 @@ prepare() {
|
|||
# fix build for i686
|
||||
patch -Np1 < "${srcdir}"/0004-fix-build-for-i686.patch
|
||||
|
||||
# gdal: use CPLFree()
|
||||
patch -Np1 < "${srcdir}"/0005-gdal-use-CPLFree.patch
|
||||
|
||||
# we need python 2.x
|
||||
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
|
||||
CMakeLists.txt
|
||||
|
|
Loading…
Reference in a new issue