mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/polymake to 4.6-4
This commit is contained in:
parent
29de5a48f8
commit
3afa44185c
2 changed files with 26 additions and 3 deletions
|
@ -8,7 +8,7 @@ highmem=1
|
||||||
|
|
||||||
pkgname=polymake
|
pkgname=polymake
|
||||||
pkgver=4.6
|
pkgver=4.6
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
_perlver=`perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]).".".($v->[2]);'`
|
_perlver=`perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]).".".($v->[2]);'`
|
||||||
pkgdesc='Open source software for research in polyhedral geometry'
|
pkgdesc='Open source software for research in polyhedral geometry'
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
|
@ -18,8 +18,15 @@ depends=(normaliz singular ppl lrs perl-xml-writer perl-xml-libxml perl-xml-libx
|
||||||
perl-term-readline-gnu perl-term-readkey perl-json sympol perl=$_perlver)
|
perl-term-readline-gnu perl-term-readkey perl-json sympol perl=$_perlver)
|
||||||
makedepends=(ninja cddlib ant boost bliss libnsl jdk8-openjdk permlib nauty)
|
makedepends=(ninja cddlib ant boost bliss libnsl jdk8-openjdk permlib nauty)
|
||||||
optdepends=('java-runtime: java module')
|
optdepends=('java-runtime: java module')
|
||||||
source=(https://polymake.org/lib/exe/fetch.php/download/polymake-${pkgver/.r/r}-minimal.tar.bz2)
|
source=(https://polymake.org/lib/exe/fetch.php/download/polymake-${pkgver/.r/r}-minimal.tar.bz2
|
||||||
sha256sums=('423a44ddef11eaea8457ab15dd5d86ddb7a8bcc6c9bb11776f9e2958d7dcf9d0')
|
perl-5.36.patch)
|
||||||
|
sha256sums=('423a44ddef11eaea8457ab15dd5d86ddb7a8bcc6c9bb11776f9e2958d7dcf9d0'
|
||||||
|
'497d447f3371858382e29b3b1149d09560d7be4847c5709b34cc83c043077c21')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd polymake-$pkgver
|
||||||
|
patch -Np1 -i ../perl-5.36.patch
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd polymake-$pkgver
|
cd polymake-$pkgver
|
||||||
|
|
16
community/polymake/perl-5.36.patch
Normal file
16
community/polymake/perl-5.36.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
diff --git a/lib/core/src/perl/RefHash.xxs b/lib/core/src/perl/RefHash.xxs
|
||||||
|
index 42ee53cd..5cc3f73f 100644
|
||||||
|
--- a/lib/core/src/perl/RefHash.xxs
|
||||||
|
+++ b/lib/core/src/perl/RefHash.xxs
|
||||||
|
@@ -71,7 +71,11 @@ SV* tmp_keysv::set(SV* keysv)
|
||||||
|
Copy(obj.keyp, HEK_KEY(hekp), sizeof(SV*), char);
|
||||||
|
HEK_LEN(hekp) = sizeof(SV*);
|
||||||
|
HEK_HASH(hekp) = U32(obj.keyl >> 4); // hash value
|
||||||
|
+#if PerlVersion >= 5360
|
||||||
|
+ HEK_FLAGS(hekp) = HVhek_NOTSHARED;
|
||||||
|
+#else
|
||||||
|
HEK_FLAGS(hekp) = HVhek_UNSHARED;
|
||||||
|
+#endif
|
||||||
|
sv.sv_any = &xpv;
|
||||||
|
sv.sv_refcnt = 1;
|
||||||
|
sv.sv_flags = SVt_PVIV | SVf_IVisUV | SVf_POK | SVp_POK | PmFlagsForHashKey;
|
Loading…
Reference in a new issue