mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/llvm to 4.0.1-1
This commit is contained in:
parent
1389930c93
commit
3b29c36e74
5 changed files with 10 additions and 402 deletions
|
@ -1,74 +0,0 @@
|
||||||
From bc72a21666a9efc78e71b0296313f6e1449649fa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Konstantin Zhuravlyov <kzhuravl_dev@outlook.com>
|
|
||||||
Date: Wed, 22 Mar 2017 21:48:18 +0000
|
|
||||||
Subject: [PATCH] [AMDGPU] Fix bug 31610
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D31258
|
|
||||||
|
|
||||||
|
|
||||||
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@298551 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
lib/Target/AMDGPU/AMDGPURuntimeMetadata.h | 8 ++++----
|
|
||||||
lib/Target/AMDGPU/MCTargetDesc/AMDGPURuntimeMD.cpp | 5 ++---
|
|
||||||
2 files changed, 6 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/Target/AMDGPU/AMDGPURuntimeMetadata.h b/lib/Target/AMDGPU/AMDGPURuntimeMetadata.h
|
|
||||||
index ed147ff4c43..36e7a0c42a9 100644
|
|
||||||
--- a/lib/Target/AMDGPU/AMDGPURuntimeMetadata.h
|
|
||||||
+++ b/lib/Target/AMDGPU/AMDGPURuntimeMetadata.h
|
|
||||||
@@ -40,8 +40,8 @@ namespace AMDGPU {
|
|
||||||
namespace RuntimeMD {
|
|
||||||
|
|
||||||
// Version and revision of runtime metadata
|
|
||||||
- const unsigned char MDVersion = 2;
|
|
||||||
- const unsigned char MDRevision = 0;
|
|
||||||
+ const uint32_t MDVersion = 2;
|
|
||||||
+ const uint32_t MDRevision = 0;
|
|
||||||
|
|
||||||
// Name of keys for runtime metadata.
|
|
||||||
namespace KeyName {
|
|
||||||
@@ -215,7 +215,7 @@ namespace RuntimeMD {
|
|
||||||
struct Metadata {
|
|
||||||
std::string Name;
|
|
||||||
std::string Language;
|
|
||||||
- std::vector<uint8_t> LanguageVersion;
|
|
||||||
+ std::vector<uint32_t> LanguageVersion;
|
|
||||||
std::vector<uint32_t> ReqdWorkGroupSize;
|
|
||||||
std::vector<uint32_t> WorkGroupSizeHint;
|
|
||||||
std::string VecTypeHint;
|
|
||||||
@@ -265,7 +265,7 @@ namespace RuntimeMD {
|
|
||||||
namespace Program {
|
|
||||||
// In-memory representation of program information.
|
|
||||||
struct Metadata {
|
|
||||||
- std::vector<uint8_t> MDVersionSeq;
|
|
||||||
+ std::vector<uint32_t> MDVersionSeq;
|
|
||||||
std::vector<std::string> PrintfInfo;
|
|
||||||
std::vector<Kernel::Metadata> Kernels;
|
|
||||||
|
|
||||||
diff --git a/lib/Target/AMDGPU/MCTargetDesc/AMDGPURuntimeMD.cpp b/lib/Target/AMDGPU/MCTargetDesc/AMDGPURuntimeMD.cpp
|
|
||||||
index 0e87d750f5d..7c96898297c 100644
|
|
||||||
--- a/lib/Target/AMDGPU/MCTargetDesc/AMDGPURuntimeMD.cpp
|
|
||||||
+++ b/lib/Target/AMDGPU/MCTargetDesc/AMDGPURuntimeMD.cpp
|
|
||||||
@@ -49,7 +49,6 @@ static cl::opt<bool>
|
|
||||||
CheckRuntimeMDParser("amdgpu-check-rtmd-parser", cl::Hidden,
|
|
||||||
cl::desc("Check AMDGPU runtime metadata YAML parser"));
|
|
||||||
|
|
||||||
-LLVM_YAML_IS_FLOW_SEQUENCE_VECTOR(uint8_t)
|
|
||||||
LLVM_YAML_IS_FLOW_SEQUENCE_VECTOR(uint32_t)
|
|
||||||
LLVM_YAML_IS_FLOW_SEQUENCE_VECTOR(std::string)
|
|
||||||
LLVM_YAML_IS_SEQUENCE_VECTOR(Kernel::Metadata)
|
|
||||||
@@ -297,9 +296,9 @@ static Kernel::Metadata getRuntimeMDForKernel(const Function &F) {
|
|
||||||
auto Node = MD->getOperand(0);
|
|
||||||
if (Node->getNumOperands() > 1) {
|
|
||||||
Kernel.Language = "OpenCL C";
|
|
||||||
- uint16_t Major = mdconst::extract<ConstantInt>(Node->getOperand(0))
|
|
||||||
+ uint32_t Major = mdconst::extract<ConstantInt>(Node->getOperand(0))
|
|
||||||
->getZExtValue();
|
|
||||||
- uint16_t Minor = mdconst::extract<ConstantInt>(Node->getOperand(1))
|
|
||||||
+ uint32_t Minor = mdconst::extract<ConstantInt>(Node->getOperand(1))
|
|
||||||
->getZExtValue();
|
|
||||||
Kernel.LanguageVersion.push_back(Major);
|
|
||||||
Kernel.LanguageVersion.push_back(Minor);
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
|
@ -1,193 +0,0 @@
|
||||||
From a61fc423f3c043314efd4c0cdb1367de2077ac36 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Fiselier <eric@efcs.ca>
|
|
||||||
Date: Fri, 10 Feb 2017 01:59:20 +0000
|
|
||||||
Subject: [PATCH] [CMake] Fix pthread handling for out-of-tree builds
|
|
||||||
|
|
||||||
LLVM defines `PTHREAD_LIB` which is used by AddLLVM.cmake and various projects
|
|
||||||
to correctly link the threading library when needed. Unfortunately
|
|
||||||
`PTHREAD_LIB` is defined by LLVM's `config-ix.cmake` file which isn't installed
|
|
||||||
and therefore can't be used when configuring out-of-tree builds. This causes
|
|
||||||
such builds to fail since `pthread` isn't being correctly linked.
|
|
||||||
|
|
||||||
This patch attempts to fix that problem by renaming and exporting
|
|
||||||
`LLVM_PTHREAD_LIB` as part of`LLVMConfig.cmake`. I renamed `PTHREAD_LIB`
|
|
||||||
because It seemed likely to cause collisions with downstream users of
|
|
||||||
`LLVMConfig.cmake`.
|
|
||||||
|
|
||||||
|
|
||||||
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@294690 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
cmake/config-ix.cmake | 2 +-
|
|
||||||
cmake/modules/AddLLVM.cmake | 6 +++---
|
|
||||||
cmake/modules/LLVMConfig.cmake.in | 4 ++++
|
|
||||||
examples/ParallelJIT/CMakeLists.txt | 2 +-
|
|
||||||
lib/CodeGen/CMakeLists.txt | 2 +-
|
|
||||||
lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt | 2 +-
|
|
||||||
lib/Fuzzer/CMakeLists.txt | 4 ++--
|
|
||||||
lib/Support/CMakeLists.txt | 2 +-
|
|
||||||
unittests/ExecutionEngine/Orc/CMakeLists.txt | 2 +-
|
|
||||||
unittests/Support/CMakeLists.txt | 2 +-
|
|
||||||
utils/unittest/CMakeLists.txt | 4 ++--
|
|
||||||
11 files changed, 18 insertions(+), 14 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/cmake/config-ix.cmake b/cmake/config-ix.cmake
|
|
||||||
index 50bcc508a80..6bd2b535500 100755
|
|
||||||
--- a/cmake/config-ix.cmake
|
|
||||||
+++ b/cmake/config-ix.cmake
|
|
||||||
@@ -115,7 +115,7 @@ if(HAVE_LIBPTHREAD)
|
|
||||||
set(CMAKE_THREAD_PREFER_PTHREAD TRUE)
|
|
||||||
set(THREADS_HAVE_PTHREAD_ARG Off)
|
|
||||||
find_package(Threads REQUIRED)
|
|
||||||
- set(PTHREAD_LIB ${CMAKE_THREAD_LIBS_INIT})
|
|
||||||
+ set(LLVM_PTHREAD_LIB ${CMAKE_THREAD_LIBS_INIT})
|
|
||||||
endif()
|
|
||||||
|
|
||||||
# Don't look for these libraries on Windows. Also don't look for them if we're
|
|
||||||
diff --git a/cmake/modules/AddLLVM.cmake b/cmake/modules/AddLLVM.cmake
|
|
||||||
index b3c7746c480..cb4171c9bc8 100644
|
|
||||||
--- a/cmake/modules/AddLLVM.cmake
|
|
||||||
+++ b/cmake/modules/AddLLVM.cmake
|
|
||||||
@@ -718,11 +718,11 @@ macro(add_llvm_executable name)
|
|
||||||
if(NOT ARG_IGNORE_EXTERNALIZE_DEBUGINFO)
|
|
||||||
llvm_externalize_debuginfo(${name})
|
|
||||||
endif()
|
|
||||||
- if (PTHREAD_LIB)
|
|
||||||
+ if (LLVM_PTHREAD_LIB)
|
|
||||||
# libpthreads overrides some standard library symbols, so main
|
|
||||||
# executable must be linked with it in order to provide consistent
|
|
||||||
# API for all shared libaries loaded by this executable.
|
|
||||||
- target_link_libraries(${name} ${PTHREAD_LIB})
|
|
||||||
+ target_link_libraries(${name} ${LLVM_PTHREAD_LIB})
|
|
||||||
endif()
|
|
||||||
endmacro(add_llvm_executable name)
|
|
||||||
|
|
||||||
@@ -1027,7 +1027,7 @@ function(add_unittest test_suite test_name)
|
|
||||||
# libpthreads overrides some standard library symbols, so main
|
|
||||||
# executable must be linked with it in order to provide consistent
|
|
||||||
# API for all shared libaries loaded by this executable.
|
|
||||||
- target_link_libraries(${test_name} gtest_main gtest ${PTHREAD_LIB})
|
|
||||||
+ target_link_libraries(${test_name} gtest_main gtest ${LLVM_PTHREAD_LIB})
|
|
||||||
|
|
||||||
add_dependencies(${test_suite} ${test_name})
|
|
||||||
get_target_property(test_suite_folder ${test_suite} FOLDER)
|
|
||||||
diff --git a/cmake/modules/LLVMConfig.cmake.in b/cmake/modules/LLVMConfig.cmake.in
|
|
||||||
index 2aea2dcaa54..7a8eb367472 100644
|
|
||||||
--- a/cmake/modules/LLVMConfig.cmake.in
|
|
||||||
+++ b/cmake/modules/LLVMConfig.cmake.in
|
|
||||||
@@ -45,6 +45,10 @@ set(LLVM_ENABLE_PIC @LLVM_ENABLE_PIC@)
|
|
||||||
|
|
||||||
set(LLVM_BUILD_32_BITS @LLVM_BUILD_32_BITS@)
|
|
||||||
|
|
||||||
+if (NOT "@LLVM_PTHREAD_LIB@" STREQUAL "")
|
|
||||||
+ set(LLVM_PTHREAD_LIB "@LLVM_PTHREAD_LIB@")
|
|
||||||
+endif()
|
|
||||||
+
|
|
||||||
set(LLVM_ENABLE_PLUGINS @LLVM_ENABLE_PLUGINS@)
|
|
||||||
set(LLVM_EXPORT_SYMBOLS_FOR_PLUGINS @LLVM_EXPORT_SYMBOLS_FOR_PLUGINS@)
|
|
||||||
set(LLVM_PLUGIN_EXT @LLVM_PLUGIN_EXT@)
|
|
||||||
diff --git a/examples/ParallelJIT/CMakeLists.txt b/examples/ParallelJIT/CMakeLists.txt
|
|
||||||
index e85b470f503..deeee072b33 100644
|
|
||||||
--- a/examples/ParallelJIT/CMakeLists.txt
|
|
||||||
+++ b/examples/ParallelJIT/CMakeLists.txt
|
|
||||||
@@ -11,4 +11,4 @@ add_llvm_example(ParallelJIT
|
|
||||||
ParallelJIT.cpp
|
|
||||||
)
|
|
||||||
|
|
||||||
-target_link_libraries(ParallelJIT ${PTHREAD_LIB})
|
|
||||||
+target_link_libraries(ParallelJIT ${LLVM_PTHREAD_LIB})
|
|
||||||
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
|
|
||||||
index a1e5fd46610..a9a3d85f3c2 100644
|
|
||||||
--- a/lib/CodeGen/CMakeLists.txt
|
|
||||||
+++ b/lib/CodeGen/CMakeLists.txt
|
|
||||||
@@ -150,7 +150,7 @@ add_llvm_library(LLVMCodeGen
|
|
||||||
${LLVM_MAIN_INCLUDE_DIR}/llvm/CodeGen
|
|
||||||
${LLVM_MAIN_INCLUDE_DIR}/llvm/CodeGen/PBQP
|
|
||||||
|
|
||||||
- LINK_LIBS ${PTHREAD_LIB}
|
|
||||||
+ LINK_LIBS ${LLVM_PTHREAD_LIB}
|
|
||||||
|
|
||||||
DEPENDS
|
|
||||||
intrinsics_gen
|
|
||||||
diff --git a/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt b/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt
|
|
||||||
index 3b8c4b973e6..e6c33b2ecc2 100644
|
|
||||||
--- a/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt
|
|
||||||
+++ b/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt
|
|
||||||
@@ -4,7 +4,7 @@ if( HAVE_LIBDL )
|
|
||||||
set(LLVM_INTEL_JIT_LIBS ${CMAKE_DL_LIBS})
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-set(LLVM_INTEL_JIT_LIBS ${PTHREAD_LIB} ${LLVM_INTEL_JIT_LIBS})
|
|
||||||
+set(LLVM_INTEL_JIT_LIBS ${LLVM_PTHREAD_LIB} ${LLVM_INTEL_JIT_LIBS})
|
|
||||||
|
|
||||||
|
|
||||||
add_llvm_library(LLVMIntelJITEvents
|
|
||||||
diff --git a/lib/Fuzzer/CMakeLists.txt b/lib/Fuzzer/CMakeLists.txt
|
|
||||||
index 5ba126e69cc..f490b3681b9 100644
|
|
||||||
--- a/lib/Fuzzer/CMakeLists.txt
|
|
||||||
+++ b/lib/Fuzzer/CMakeLists.txt
|
|
||||||
@@ -34,12 +34,12 @@ if( LLVM_USE_SANITIZE_COVERAGE )
|
|
||||||
add_library(LLVMFuzzerNoMain STATIC
|
|
||||||
$<TARGET_OBJECTS:LLVMFuzzerNoMainObjects>
|
|
||||||
)
|
|
||||||
- target_link_libraries(LLVMFuzzerNoMain ${PTHREAD_LIB})
|
|
||||||
+ target_link_libraries(LLVMFuzzerNoMain ${LLVM_PTHREAD_LIB})
|
|
||||||
add_library(LLVMFuzzer STATIC
|
|
||||||
FuzzerMain.cpp
|
|
||||||
$<TARGET_OBJECTS:LLVMFuzzerNoMainObjects>
|
|
||||||
)
|
|
||||||
- target_link_libraries(LLVMFuzzer ${PTHREAD_LIB})
|
|
||||||
+ target_link_libraries(LLVMFuzzer ${LLVM_PTHREAD_LIB})
|
|
||||||
|
|
||||||
if( LLVM_INCLUDE_TESTS )
|
|
||||||
add_subdirectory(test)
|
|
||||||
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
|
|
||||||
index 3301364cf2c..f7cfa760ba0 100644
|
|
||||||
--- a/lib/Support/CMakeLists.txt
|
|
||||||
+++ b/lib/Support/CMakeLists.txt
|
|
||||||
@@ -17,7 +17,7 @@ elseif( CMAKE_HOST_UNIX )
|
|
||||||
if( LLVM_ENABLE_THREADS AND HAVE_LIBATOMIC )
|
|
||||||
set(system_libs ${system_libs} atomic)
|
|
||||||
endif()
|
|
||||||
- set(system_libs ${system_libs} ${PTHREAD_LIB})
|
|
||||||
+ set(system_libs ${system_libs} ${LLVM_PTHREAD_LIB})
|
|
||||||
if ( LLVM_ENABLE_ZLIB AND HAVE_LIBZ )
|
|
||||||
set(system_libs ${system_libs} z)
|
|
||||||
endif()
|
|
||||||
diff --git a/unittests/ExecutionEngine/Orc/CMakeLists.txt b/unittests/ExecutionEngine/Orc/CMakeLists.txt
|
|
||||||
index 68f6d0c28d7..80c344e040a 100644
|
|
||||||
--- a/unittests/ExecutionEngine/Orc/CMakeLists.txt
|
|
||||||
+++ b/unittests/ExecutionEngine/Orc/CMakeLists.txt
|
|
||||||
@@ -21,4 +21,4 @@ add_llvm_unittest(OrcJITTests
|
|
||||||
RPCUtilsTest.cpp
|
|
||||||
)
|
|
||||||
|
|
||||||
-target_link_libraries(OrcJITTests ${PTHREAD_LIB})
|
|
||||||
+target_link_libraries(OrcJITTests ${LLVM_PTHREAD_LIB})
|
|
||||||
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
|
|
||||||
index 4c9bb5eea38..ea260792282 100644
|
|
||||||
--- a/unittests/Support/CMakeLists.txt
|
|
||||||
+++ b/unittests/Support/CMakeLists.txt
|
|
||||||
@@ -64,4 +64,4 @@ add_llvm_unittest(SupportTests
|
|
||||||
)
|
|
||||||
|
|
||||||
# ManagedStatic.cpp uses <pthread>.
|
|
||||||
-target_link_libraries(SupportTests ${PTHREAD_LIB})
|
|
||||||
+target_link_libraries(SupportTests ${LLVM_PTHREAD_LIB})
|
|
||||||
diff --git a/utils/unittest/CMakeLists.txt b/utils/unittest/CMakeLists.txt
|
|
||||||
index a50733af9aa..b42ac834e3a 100644
|
|
||||||
--- a/utils/unittest/CMakeLists.txt
|
|
||||||
+++ b/utils/unittest/CMakeLists.txt
|
|
||||||
@@ -40,8 +40,8 @@ if (NOT LLVM_ENABLE_THREADS)
|
|
||||||
add_definitions( -DGTEST_HAS_PTHREAD=0 )
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-find_library(PTHREAD_LIBRARY_PATH pthread)
|
|
||||||
-if (PTHREAD_LIBRARY_PATH)
|
|
||||||
+find_library(LLVM_PTHREAD_LIBRARY_PATH pthread)
|
|
||||||
+if (LLVM_PTHREAD_LIBRARY_PATH)
|
|
||||||
list(APPEND LIBS pthread)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
From f5f712dfcac6ee99381c5aca212950276f1743e8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Fiselier <eric@efcs.ca>
|
|
||||||
Date: Fri, 10 Feb 2017 01:59:20 +0000
|
|
||||||
Subject: [PATCH] [CMake] Fix pthread handling for out-of-tree builds
|
|
||||||
|
|
||||||
LLVM defines `PTHREAD_LIB` which is used by AddLLVM.cmake and various projects
|
|
||||||
to correctly link the threading library when needed. Unfortunately
|
|
||||||
`PTHREAD_LIB` is defined by LLVM's `config-ix.cmake` file which isn't installed
|
|
||||||
and therefore can't be used when configuring out-of-tree builds. This causes
|
|
||||||
such builds to fail since `pthread` isn't being correctly linked.
|
|
||||||
|
|
||||||
This patch attempts to fix that problem by renaming and exporting
|
|
||||||
`LLVM_PTHREAD_LIB` as part of`LLVMConfig.cmake`. I renamed `PTHREAD_LIB`
|
|
||||||
because It seemed likely to cause collisions with downstream users of
|
|
||||||
`LLVMConfig.cmake`.
|
|
||||||
|
|
||||||
|
|
||||||
git-svn-id: https://llvm.org/svn/llvm-project/clang-tools-extra/trunk@294690 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
include-fixer/plugin/CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/include-fixer/plugin/CMakeLists.txt b/include-fixer/plugin/CMakeLists.txt
|
|
||||||
index 2799fd4a..df792ea1 100644
|
|
||||||
--- a/include-fixer/plugin/CMakeLists.txt
|
|
||||||
+++ b/include-fixer/plugin/CMakeLists.txt
|
|
||||||
@@ -9,5 +9,5 @@ add_clang_library(clangIncludeFixerPlugin
|
|
||||||
clangParse
|
|
||||||
clangSema
|
|
||||||
clangTooling
|
|
||||||
- ${PTHREAD_LIB}
|
|
||||||
+ ${LLVM_PTHREAD_LIB}
|
|
||||||
)
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
|
@ -1,78 +0,0 @@
|
||||||
From 548cd5eb4f45de4ec71b3421a98c9462aed75c91 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Fiselier <eric@efcs.ca>
|
|
||||||
Date: Fri, 10 Feb 2017 01:59:20 +0000
|
|
||||||
Subject: [PATCH] [CMake] Fix pthread handling for out-of-tree builds
|
|
||||||
|
|
||||||
LLVM defines `PTHREAD_LIB` which is used by AddLLVM.cmake and various projects
|
|
||||||
to correctly link the threading library when needed. Unfortunately
|
|
||||||
`PTHREAD_LIB` is defined by LLVM's `config-ix.cmake` file which isn't installed
|
|
||||||
and therefore can't be used when configuring out-of-tree builds. This causes
|
|
||||||
such builds to fail since `pthread` isn't being correctly linked.
|
|
||||||
|
|
||||||
This patch attempts to fix that problem by renaming and exporting
|
|
||||||
`LLVM_PTHREAD_LIB` as part of`LLVMConfig.cmake`. I renamed `PTHREAD_LIB`
|
|
||||||
because It seemed likely to cause collisions with downstream users of
|
|
||||||
`LLVMConfig.cmake`.
|
|
||||||
|
|
||||||
|
|
||||||
git-svn-id: https://llvm.org/svn/llvm-project/lld/trunk@294690 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
COFF/CMakeLists.txt | 2 +-
|
|
||||||
ELF/CMakeLists.txt | 2 +-
|
|
||||||
lib/ReaderWriter/MachO/CMakeLists.txt | 2 +-
|
|
||||||
unittests/CoreTests/CMakeLists.txt | 2 +-
|
|
||||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/COFF/CMakeLists.txt b/COFF/CMakeLists.txt
|
|
||||||
index 0eebe9348..8f24e36c0 100644
|
|
||||||
--- a/COFF/CMakeLists.txt
|
|
||||||
+++ b/COFF/CMakeLists.txt
|
|
||||||
@@ -43,7 +43,7 @@ add_lld_library(lldCOFF
|
|
||||||
|
|
||||||
LINK_LIBS
|
|
||||||
lldCore
|
|
||||||
- ${PTHREAD_LIB}
|
|
||||||
+ ${LLVM_PTHREAD_LIB}
|
|
||||||
|
|
||||||
DEPENDS
|
|
||||||
COFFOptionsTableGen
|
|
||||||
diff --git a/ELF/CMakeLists.txt b/ELF/CMakeLists.txt
|
|
||||||
index 5652b9351..0d1e5b214 100644
|
|
||||||
--- a/ELF/CMakeLists.txt
|
|
||||||
+++ b/ELF/CMakeLists.txt
|
|
||||||
@@ -54,7 +54,7 @@ add_lld_library(lldELF
|
|
||||||
LINK_LIBS
|
|
||||||
lldConfig
|
|
||||||
lldCore
|
|
||||||
- ${PTHREAD_LIB}
|
|
||||||
+ ${LLVM_PTHREAD_LIB}
|
|
||||||
|
|
||||||
DEPENDS
|
|
||||||
ELFOptionsTableGen
|
|
||||||
diff --git a/lib/ReaderWriter/MachO/CMakeLists.txt b/lib/ReaderWriter/MachO/CMakeLists.txt
|
|
||||||
index 3b0698525..5a96d87f1 100644
|
|
||||||
--- a/lib/ReaderWriter/MachO/CMakeLists.txt
|
|
||||||
+++ b/lib/ReaderWriter/MachO/CMakeLists.txt
|
|
||||||
@@ -28,7 +28,7 @@ add_lld_library(lldMachO
|
|
||||||
LINK_LIBS
|
|
||||||
lldCore
|
|
||||||
lldYAML
|
|
||||||
- ${PTHREAD_LIB}
|
|
||||||
+ ${LLVM_PTHREAD_LIB}
|
|
||||||
)
|
|
||||||
|
|
||||||
include_directories(.)
|
|
||||||
diff --git a/unittests/CoreTests/CMakeLists.txt b/unittests/CoreTests/CMakeLists.txt
|
|
||||||
index 98405d5c7..72e7c443f 100644
|
|
||||||
--- a/unittests/CoreTests/CMakeLists.txt
|
|
||||||
+++ b/unittests/CoreTests/CMakeLists.txt
|
|
||||||
@@ -3,5 +3,5 @@ add_lld_unittest(CoreTests
|
|
||||||
)
|
|
||||||
|
|
||||||
target_link_libraries(CoreTests
|
|
||||||
- ${PTHREAD_LIB}
|
|
||||||
+ ${LLVM_PTHREAD_LIB}
|
|
||||||
)
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
|
@ -16,8 +16,8 @@ buildarch=28
|
||||||
highmem=1
|
highmem=1
|
||||||
|
|
||||||
pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'lld' 'lldb' 'clang' 'clang-tools-extra')
|
pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'lld' 'lldb' 'clang' 'clang-tools-extra')
|
||||||
pkgver=4.0.0
|
pkgver=4.0.1
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
_ocaml_ver=4.04.1
|
_ocaml_ver=4.04.1
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://llvm.org/"
|
url="http://llvm.org/"
|
||||||
|
@ -33,33 +33,26 @@ source=(http://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
|
||||||
http://releases.llvm.org/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
|
http://releases.llvm.org/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
|
||||||
http://releases.llvm.org/$pkgver/lld-$pkgver.src.tar.xz{,.sig}
|
http://releases.llvm.org/$pkgver/lld-$pkgver.src.tar.xz{,.sig}
|
||||||
http://releases.llvm.org/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
|
http://releases.llvm.org/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
|
||||||
0001-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
0002-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
0003-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
0001-AMDGPU-Fix-bug-31610.patch
|
|
||||||
lldb-gcc7.patch
|
lldb-gcc7.patch
|
||||||
lldb-libedit.patch
|
lldb-libedit.patch
|
||||||
llvm-config.h)
|
llvm-config.h)
|
||||||
sha256sums=('8d10511df96e73b8ff9e7abbfb4d4d432edbdbe965f1f4f07afaf370b8a533be'
|
sha256sums=('da783db1f82d516791179fe103c71706046561f7972b18f0049242dee6712b51'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'cea5f88ebddb30e296ca89130c83b9d46c2d833685e2912303c828054c4dc98a'
|
'61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'41b7d37eb128fd362ab3431be5244cf50325bb3bb153895735c5bacede647c99'
|
'35d1e64efc108076acbe7392566a52c35df9ec19778eb9eb12245fc7d8b915b6'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'd3f25b23bef24c305137e6b44f7e81c51bbec764c119e01512a9bd2330be3115'
|
'a3c87794334887b93b7a766c507244a7cdcce1d48b2e9249fc9a94f2c3beb440'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'33e06457b9ce0563c89b11ccc7ccabf9cff71b83571985a5bf8684c9150e7502'
|
'63ce10e533276ca353941ce5ab5cc8e8dcd99dbdd9c4fa49f344a212f29d36ed'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'2dbd8f05c662c1c9f11270fc9d0c63b419ddc988095e0ad107ed911cf882033d'
|
'8432d2dfd86044a0fc21713e0b5c1d98e1d8aad863cf67562879f47f841ac47b'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'ead18f586f1ee902b01bebd1f7f9feec07be271fe3229d67808b8016fe99d512'
|
|
||||||
'6d4e7541a70981d8c5162d92bf5604eec3f61536cc1a3ebc9f118dc892ae879b'
|
|
||||||
'a33a0106909b04c2a551a817d7184462e62995abaa01e5940cd3e67d28f141d5'
|
|
||||||
'cddd04be4fd822e03ff16b7640618e424d475d3bf04494c0d38aa225b920f00e'
|
|
||||||
'10cca2f593c711b1b547f479f9f783ab88f9a64b356519d9aa1367e0ff6da73a'
|
'10cca2f593c711b1b547f479f9f783ab88f9a64b356519d9aa1367e0ff6da73a'
|
||||||
'b80bda6dc26792e499b3150e13c3017be4a65280b4b9f5c9f4c07b55a46d93b6'
|
'b80bda6dc26792e499b3150e13c3017be4a65280b4b9f5c9f4c07b55a46d93b6'
|
||||||
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
|
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
|
||||||
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D')
|
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D'
|
||||||
|
'11E521D646982372EB577A1F8F0871F202119294')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$srcdir/llvm-$pkgver.src"
|
cd "$srcdir/llvm-$pkgver.src"
|
||||||
|
@ -70,10 +63,6 @@ prepare() {
|
||||||
mv "$srcdir/lld-$pkgver.src" tools/lld
|
mv "$srcdir/lld-$pkgver.src" tools/lld
|
||||||
mv "$srcdir/lldb-$pkgver.src" tools/lldb
|
mv "$srcdir/lldb-$pkgver.src" tools/lldb
|
||||||
|
|
||||||
patch -Np1 -i ../0001-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
patch -Np1 -i ../0001-AMDGPU-Fix-bug-31610.patch
|
|
||||||
patch -Np1 -d tools/clang/tools/extra <../0002-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
patch -Np1 -d tools/lld <../0003-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
|
||||||
patch -Np0 -d tools/lldb <../lldb-gcc7.patch
|
patch -Np0 -d tools/lldb <../lldb-gcc7.patch
|
||||||
patch -Np1 -d tools/lldb <../lldb-libedit.patch
|
patch -Np1 -d tools/lldb <../lldb-libedit.patch
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue