mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/glibc to 2.20-4
This commit is contained in:
parent
d86040e5c6
commit
3b612928d7
2 changed files with 22 additions and 10 deletions
|
@ -16,7 +16,7 @@ noautobuild=1
|
|||
|
||||
pkgname=glibc
|
||||
pkgver=2.20
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="GNU C Library"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/libc"
|
||||
|
@ -36,7 +36,7 @@ source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
|
|||
locale-gen)
|
||||
md5sums=('948a6e06419a01bd51e97206861595b0'
|
||||
'SKIP'
|
||||
'7414dd9a268e93111a9ffd7e13b7fa53'
|
||||
'8cfa2a0fa2a9aad8b86a138587d6261f'
|
||||
'905370139382428ef2b97b247c0970bf'
|
||||
'07ac979b6ab5eeb778d55f041529d623'
|
||||
'476e9113489f93b348b21e144b6a8fcf')
|
||||
|
@ -45,7 +45,7 @@ validpgpkeys=('F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF') # Carlos O'Donell
|
|||
prepare() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
# glibc-2.20..33ceaf61
|
||||
# glibc-2.20..d73ac1bb
|
||||
patch -p1 -i $srcdir/glibc-2.20-roundup.patch
|
||||
|
||||
# ALARM: patch for hard-float ld-linux soname
|
||||
|
|
|
@ -1,8 +1,14 @@
|
|||
diff --git a/ChangeLog b/ChangeLog
|
||||
index f343428..f9f3407 100644
|
||||
index f343428..ac7d980 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,88 @@
|
||||
@@ -1,3 +1,94 @@
|
||||
+2014-11-24 Siddhesh Poyarekar <siddhesh@redhat.com>
|
||||
+
|
||||
+ [BZ #17266]
|
||||
+ * misc/sys/cdefs.h: Define __extern_always_inline for clang
|
||||
+ 4.2 and newer.
|
||||
+
|
||||
+2014-11-19 Carlos O'Donell <carlos@redhat.com>
|
||||
+ Florian Weimer <fweimer@redhat.com>
|
||||
+ Joseph Myers <joseph@codesourcery.com>
|
||||
|
@ -181,7 +187,7 @@ index aa755de..0656645 100644
|
|||
extern double __gamma_r_finite (double, int *);
|
||||
__extern_always_inline double __NTH (tgamma (double __d))
|
||||
diff --git a/misc/sys/cdefs.h b/misc/sys/cdefs.h
|
||||
index 04db956..01e81ba 100644
|
||||
index 04db956..711ac1d 100644
|
||||
--- a/misc/sys/cdefs.h
|
||||
+++ b/misc/sys/cdefs.h
|
||||
@@ -131,7 +131,6 @@
|
||||
|
@ -192,7 +198,7 @@ index 04db956..01e81ba 100644
|
|||
|
||||
#if __GNUC_PREREQ (4,3)
|
||||
# define __warndecl(name, msg) \
|
||||
@@ -318,12 +317,13 @@
|
||||
@@ -318,12 +317,19 @@
|
||||
# define __attribute_artificial__ /* Ignore */
|
||||
#endif
|
||||
|
||||
|
@ -206,13 +212,19 @@ index 04db956..01e81ba 100644
|
|||
+ inline semantics, unless -fgnu89-inline is used. Using __GNUC_STDC_INLINE__
|
||||
+ or __GNUC_GNU_INLINE is not a good enough check for gcc because gcc versions
|
||||
+ older than 4.3 may define these macros and still not guarantee GNU inlining
|
||||
+ semantics. */
|
||||
+#if !defined __cplusplus || __GNUC_PREREQ (4,3)
|
||||
+ semantics.
|
||||
+
|
||||
+ clang++ identifies itself as gcc-4.2, but has support for GNU inlining
|
||||
+ semantics, that can be checked fot by using the __GNUC_STDC_INLINE_ and
|
||||
+ __GNUC_GNU_INLINE__ macro definitions. */
|
||||
+#if (!defined __cplusplus || __GNUC_PREREQ (4,3) \
|
||||
+ || (defined __clang__ && (defined __GNUC_STDC_INLINE__ \
|
||||
+ || defined __GNUC_GNU_INLINE__)))
|
||||
+# if defined __GNUC_STDC_INLINE__ || defined __cplusplus
|
||||
# define __extern_inline extern __inline __attribute__ ((__gnu_inline__))
|
||||
# define __extern_always_inline \
|
||||
extern __always_inline __attribute__ ((__gnu_inline__))
|
||||
@@ -331,9 +331,10 @@
|
||||
@@ -331,9 +337,10 @@
|
||||
# define __extern_inline extern __inline
|
||||
# define __extern_always_inline extern __always_inline
|
||||
# endif
|
||||
|
|
Loading…
Reference in a new issue