From 3b9709692df1b43c287d86d956355520b9a5fc1a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 25 Aug 2016 18:01:02 +0000
Subject: [PATCH] community/percona-server to 5.7.14_7-1

---
 community/percona-server/PKGBUILD        | 14 +++++--------
 community/percona-server/make_pair.patch | 25 ------------------------
 2 files changed, 5 insertions(+), 34 deletions(-)
 delete mode 100644 community/percona-server/make_pair.patch

diff --git a/community/percona-server/PKGBUILD b/community/percona-server/PKGBUILD
index 5e34004f1..180f46d2d 100644
--- a/community/percona-server/PKGBUILD
+++ b/community/percona-server/PKGBUILD
@@ -8,7 +8,7 @@
 
 pkgbase=percona-server
 pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
-pkgver=5.7.13_6
+pkgver=5.7.14_7
 _boost_ver=1.59.0
 _pkgver=${pkgver/_/-}
 _myver=${pkgver/_rel*}
@@ -20,7 +20,6 @@ license=('GPL' 'AGPL')
 url="http://www.percona.com/software/percona-server/"
 source=("http://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona-Server-$_pkgver/source/tarball/percona-server-$_pkgver.tar.gz"
         "http://sourceforge.net/projects/boost/files/boost/${_boost_ver}/boost_${_boost_ver//./_}.tar.gz"
-        'make_pair.patch'
         'my.cnf'
         'mysql-user.conf')
 
@@ -28,8 +27,6 @@ prepare() {
 	cd $pkgbase-$_pkgver
 	rm -v sql/sql_yacc.{cc,h}
 
-	patch -p1 -i "$srcdir"/make_pair.patch
-
 	sed 's|${fullhostname}|"archbuild"|' \
 		-i storage/tokudb/PerconaFT/cmake_modules/TokuSetupCTest.cmake
 }
@@ -64,12 +61,12 @@ build() {
 		-DWITH_ZLIB=system \
 		-DWITH_SSL=system \
 		-DWITH_LIBWRAP=OFF \
-    -DCMAKE_EXE_LINKER_FLAGS='-ljemalloc' \
+		-DCMAKE_EXE_LINKER_FLAGS='-ljemalloc' \
 		-DWITH_UNIT_TESTS=OFF \
 		-DWITH_PAM=ON \
 		-DWITH_EXTRA_CHARSETS=complex \
 		-DWITH_EMBEDDED_SERVER=ON \
-	  -DWITH_EMBEDDED_SHARED_LIBRARY=ON \
+		-DWITH_EMBEDDED_SHARED_LIBRARY=ON \
 		-DWITH_INNODB_MEMCACHED=ON \
 		-DWITH_INNOBASE_STORAGE_ENGINE=ON \
 		-DWITH_PARTITION_STORAGE_ENGINE=ON \
@@ -78,7 +75,7 @@ build() {
 		-DWITH_BLACKHOLE_STORAGE_ENGINE=ON \
 		-DWITH_FEDERATED_STORAGE_ENGINE=OFF \
 		-DWITH_EXAMPLE_STORAGE_ENGINE=OFF \
-	  -DWITH_SYSTEMD=1 \
+		-DWITH_SYSTEMD=1 \
 		-DCMAKE_C_FLAGS="-fPIC $CFLAGS -fno-strict-aliasing -DBIG_JOINS=1 -fomit-frame-pointer -fno-delete-null-pointer-checks" \
 		-DCMAKE_CXX_FLAGS="-fPIC $CXXFLAGS -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-delete-null-pointer-checks -Wno-error=nonnull-compare -Wno-deprecated-declarations -Wno-misleading-indentation -Wno-maybe-uninitialized" \
 		-DCMAKE_CXX_FLAGS="-fPIC $CXXFLAGS -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-delete-null-pointer-checks" \
@@ -174,8 +171,7 @@ package_percona-server() {
 	rm usr/share/man/man1/mysql-test-run.pl.1
 }
 
-sha256sums=('ce6867394d43c6814300ebe26310544bb504e0f558c8a3b8278ea6aa838fd645'
+sha256sums=('b204ffac56bfc8cf092acca3ce73d63b00450b59f554acd1daeb5a573eec2c1d'
             '47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac'
-            '1db0f48f06545307898bfed9305e5b4c2997ee97375cd8d0b2a36ee93370d00f'
             'ae451839c368f0db25a63bb0a6a890194897a8e74818bd4245140933c29e5f83'
             'e638a2657085f15b6728f43c1fd6aa551b27608fbf6b435e33afd3606a0cfb0e')
diff --git a/community/percona-server/make_pair.patch b/community/percona-server/make_pair.patch
deleted file mode 100644
index d55f422bc..000000000
--- a/community/percona-server/make_pair.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 34ec0d65ede8392ba3e0f114d72672b3f517f964 Mon Sep 17 00:00:00 2001
-From: Christian Hesse <mail@eworm.de>
-Date: Tue, 10 May 2016 01:09:34 +0200
-Subject: [PATCH] do not pass type to std::make_pair()
-
-We not pass type template arguments to std::make_pair()
-explicitly, and let the compiler deduce them on its own.
-This fixes compiler error on GCC 6.1.1.
----
- client/auth_utils.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/client/auth_utils.cc b/client/auth_utils.cc
-index 21416bb..03fd71c 100644
---- a/client/auth_utils.cc
-+++ b/client/auth_utils.cc
-@@ -61,7 +61,7 @@ int parse_cnf_file(istream &sin, map<string, string > *options,
-     getline(sin, option_value);
-     trim(&option_value);
-     if (option_name.length() > 0)
--      options->insert(make_pair<string, string >(option_name, option_value));
-+      options->insert(make_pair(option_name, option_value));
-   }
-   return ALL_OK;
-   } catch(...)