core/glib2 to 2.64.3-1

This commit is contained in:
Kevin Mihelich 2020-05-22 12:58:43 +00:00
parent 50c747400e
commit 3c15fca2c9
2 changed files with 5 additions and 37 deletions

View file

@ -1,25 +0,0 @@
From 5a422c572991549f0d063af09b6fe0b6b7e958a3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 7 Sep 2018 20:03:35 -0600
Subject: [PATCH] arm atomic
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index aa7d8e4f7..f102127fc 100644
--- a/meson.build
+++ b/meson.build
@@ -1555,7 +1555,7 @@ else
error('GLib must be built with -march=i486 or later.')
endif
endif
-glibconfig_conf.set('G_ATOMIC_LOCK_FREE', have_atomic_lock_free)
+#glibconfig_conf.set('G_ATOMIC_LOCK_FREE', have_atomic_lock_free)
# === Threads ===
--
2.18.0

View file

@ -2,12 +2,11 @@
# Maintainer: Jan de Groot <jgc@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix v5 FTBFS with meson
# - disable docs
pkgbase=glib2
pkgname=(glib2 glib2-docs)
pkgver=2.64.2
pkgver=2.64.3
pkgrel=1
pkgdesc="Low level core library"
url="https://wiki.gnome.org/Projects/GLib"
@ -17,16 +16,14 @@ depends=(pcre libffi libutil-linux zlib)
makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux
meson dbus)
checkdepends=(desktop-file-utils)
_commit=e264e6fcf7f5199e137314b0d1ebca7648613148 # tags/2.64.2^0
_commit=af1edc1c338d9a8b2a99bdd0e6cc6bede51f40b4 # tags/2.64.3^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
noisy-glib-compile-schemas.diff
glib-compile-schemas.hook gio-querymodules.hook
0001-arm-atomic.patch)
glib-compile-schemas.hook gio-querymodules.hook)
sha256sums=('SKIP'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
'557c88177f011ced17bdeac1af3f882b2ca33b386a866fdf900b35f927a2bbe8'
'fdd5e589e3c38903cfae63eaf37cd9c51304ce971c97553ca1f2c9083a0d61b0')
'557c88177f011ced17bdeac1af3f882b2ca33b386a866fdf900b35f927a2bbe8')
pkgver() {
cd glib
@ -38,10 +35,6 @@ prepare() {
# Suppress noise from glib-compile-schemas.hook
git apply -3 ../noisy-glib-compile-schemas.diff
if [[ $CARCH == "arm" ]]; then
patch -Np1 -i ../0001-arm-atomic.patch
fi
}
build() {
@ -50,7 +43,7 @@ build() {
-D selinux=disabled \
-D man=true \
-D gtk_doc=false
ninja -C build
meson compile -C build
}
check() {