core/linux-armv7 to 4.17.0-1

This commit is contained in:
Kevin Mihelich 2018-06-05 03:20:20 +00:00
parent 66267ee872
commit 3c45d51cc7
15 changed files with 242 additions and 294 deletions

View file

@ -1,4 +1,4 @@
From cfaf96614497debcf1bc54ed9b4c45678eee282e Mon Sep 17 00:00:00 2001
From 8d124d916897d965eafd7e85524d38756fb2d5ce Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/13] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
};
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From e47ba83e454cf97a7b3d33e5b5b625682ae1cd49 Mon Sep 17 00:00:00 2001
From 6f181867df1ccab0836928cc91a9388239b89086 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/13] ARM: atags/fdt: retrieve MAC addresses from Marvell
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
}
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 51132fdfa4b66feb87499903f568132b7ec92785 Mon Sep 17 00:00:00 2001
From a89566aa1896a895360380a6a4e66b997c059e02 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/13] SMILE Plug device tree file
@ -9,15 +9,15 @@ dts with the LED definitions.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/armada-370-smileplug.dts | 173 +++++++++++++++++++++++++++++
arch/arm/boot/dts/armada-370-smileplug.dts | 173 +++++++++++++++++++++
2 files changed, 174 insertions(+)
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index ade7a38543dc..4bd5a6614e93 100644
index 7e2424957809..431a7ca68751 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1072,6 +1072,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -1100,6 +1100,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From ab62597d0e8a83ba11af33f294a58b4462e9369a Mon Sep 17 00:00:00 2001
From 80d34ee9819ed5400e37d4a9801f976d1c8281c0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/13] fix mvsdio eMMC timing
@ -34,5 +34,5 @@ index 210247b3d11a..1a1802dc9ef4 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.16.2
2.17.0

View file

@ -1,11 +1,11 @@
From 8bb2616581e4e5aa7395bec730995629be259954 Mon Sep 17 00:00:00 2001
From 0818bb121a785e899a143871e7b567b4ab1cde91 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/13] net/smsc95xx: Allow mac address to be set as a
parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
@ -92,5 +92,5 @@ index 309b88acd3d0..7bc9feb891a1 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 877e229054b1ecdcb350356475f2654e66c13288 Mon Sep 17 00:00:00 2001
From 0879744ffdf15d57e51a023edac391acf3af80da Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/13] set default cubietruck led triggers
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
index 8c9bedc602ec..b3a765ba03fd 100644
index 5649161de1d7..2be64a886555 100644
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
@@ -80,6 +80,7 @@
@ -29,5 +29,5 @@ index 8c9bedc602ec..b3a765ba03fd 100644
};
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 75c68a3a6868e6e0891e807b51249523bdfae611 Mon Sep 17 00:00:00 2001
From 655d9afac9327f9ac6884e82146508f1c0a66c01 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/13] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 556ea78b8e32..f3a3fe4af289 100644
index d7ad07fd48f9..53c31c01713b 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -418,7 +418,7 @@
@ -26,5 +26,5 @@ index 556ea78b8e32..f3a3fe4af289 100644
regulator-always-on;
regulator-boot-on;
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 728f5a9864ab09dd0485102e62ff6d4483c184fc Mon Sep 17 00:00:00 2001
From 288a284da4996b5420bda1635a2240d0615912a3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/13] ARM: dove: enable ethernet on D3Plug
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 4ab3153b568ce58a01e0e379ffe8061c4f0435b6 Mon Sep 17 00:00:00 2001
From 19a5d3c65f38ed602ab452ab7226d533b4ca66df Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/13] power: add power sequence library
@ -31,15 +31,15 @@ Tested-by Joshua Clayton <stillcompiling@gmail.com>
Reviewed-by: Matthias Kaehlcke <mka@chromium.org>
Tested-by: Matthias Kaehlcke <mka@chromium.org>
---
Documentation/power/power-sequence/design.rst | 54 +++++
Documentation/power/power-sequence/design.rst | 54 ++++
MAINTAINERS | 9 +
drivers/power/Kconfig | 1 +
drivers/power/Makefile | 1 +
drivers/power/pwrseq/Kconfig | 20 ++
drivers/power/pwrseq/Makefile | 2 +
drivers/power/pwrseq/core.c | 293 ++++++++++++++++++++++++++
drivers/power/pwrseq/pwrseq_generic.c | 210 ++++++++++++++++++
include/linux/power/pwrseq.h | 84 ++++++++
drivers/power/pwrseq/core.c | 293 ++++++++++++++++++
drivers/power/pwrseq/pwrseq_generic.c | 210 +++++++++++++
include/linux/power/pwrseq.h | 84 +++++
9 files changed, 674 insertions(+)
create mode 100644 Documentation/power/power-sequence/design.rst
create mode 100644 drivers/power/pwrseq/Kconfig
@ -109,10 +109,10 @@ index 000000000000..554608e5f3b6
+.. kernel-doc:: drivers/power/pwrseq/core.c
+ :export:
diff --git a/MAINTAINERS b/MAINTAINERS
index 4623caf8d72d..7569287f8b33 100644
index 9c125f705f78..31042fc6c400 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11086,6 +11086,15 @@ F: drivers/firmware/psci*.c
@@ -11247,6 +11247,15 @@ F: drivers/firmware/psci*.c
F: include/linux/psci.h
F: include/uapi/linux/psci.h
@ -786,5 +786,5 @@ index 000000000000..c5b278f5f2ae
+
+#endif /* __LINUX_PWRSEQ_H */
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 939bdab48c863e3f6ab60b4397a8467e05bc2ace Mon Sep 17 00:00:00 2001
From 3725bba0f1591b698482f4b144dc311199ef492b Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/13] usb: core: add power sequence handling for USB devices
@ -22,12 +22,12 @@ Reviewed-by: Vaibhav Hiremath <hvaibhav.linux@gmail.com>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
---
drivers/usb/Kconfig | 1 +
drivers/usb/core/hub.c | 49 +++++++++++++++++++++++++++++++++++++++++++++----
drivers/usb/core/hub.c | 49 ++++++++++++++++++++++++++++++++++++++----
drivers/usb/core/hub.h | 1 +
3 files changed, 47 insertions(+), 4 deletions(-)
diff --git a/drivers/usb/Kconfig b/drivers/usb/Kconfig
index 148f3ee70286..575a866422be 100644
index 987fc5ba6321..bd09fc8ff763 100644
--- a/drivers/usb/Kconfig
+++ b/drivers/usb/Kconfig
@@ -45,6 +45,7 @@ config USB
@ -39,7 +39,7 @@ index 148f3ee70286..575a866422be 100644
---help---
Universal Serial Bus (USB) is a specification for a serial bus
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index c5c1f6cf3228..a7de648c3f76 100644
index aa9968d90a48..14b93b844aaa 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -28,6 +28,7 @@
@ -50,7 +50,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
#include <linux/uaccess.h>
#include <asm/byteorder.h>
@@ -1649,6 +1650,7 @@ static void hub_disconnect(struct usb_interface *intf)
@@ -1654,6 +1655,7 @@ static void hub_disconnect(struct usb_interface *intf)
hub->error = 0;
hub_quiesce(hub, HUB_DISCONNECT);
@ -58,7 +58,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
mutex_lock(&usb_port_peer_mutex);
/* Avoid races with recursively_mark_NOTATTACHED() */
@@ -1695,11 +1697,41 @@ static bool hub_descriptor_is_sane(struct usb_host_interface *desc)
@@ -1700,11 +1702,41 @@ static bool hub_descriptor_is_sane(struct usb_host_interface *desc)
return true;
}
@ -100,7 +100,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
desc = intf->cur_altsetting;
hdev = interface_to_usbdev(intf);
@@ -1790,6 +1822,7 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
@@ -1795,6 +1827,7 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
INIT_DELAYED_WORK(&hub->leds, led_work);
INIT_DELAYED_WORK(&hub->init_work, NULL);
INIT_WORK(&hub->events, hub_event);
@ -108,7 +108,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
usb_get_intf(intf);
usb_get_dev(hdev);
@@ -1803,11 +1836,14 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
@@ -1808,11 +1841,14 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
if (id->driver_info & HUB_QUIRK_CHECK_PORT_AUTOSUSPEND)
hub->quirk_check_port_auto_suspend = 1;
@ -126,7 +126,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
}
static int
@@ -3621,14 +3657,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
@@ -3633,14 +3669,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
/* stop hub_wq and related activity */
hub_quiesce(hub, HUB_SUSPEND);
@ -148,7 +148,7 @@ index c5c1f6cf3228..a7de648c3f76 100644
return 0;
}
diff --git a/drivers/usb/core/hub.h b/drivers/usb/core/hub.h
index 2a700ccc868c..3a0e6e6b22b0 100644
index 4dc769ee9c74..b5d5c4818f90 100644
--- a/drivers/usb/core/hub.h
+++ b/drivers/usb/core/hub.h
@@ -70,6 +70,7 @@ struct usb_hub {
@ -160,5 +160,5 @@ index 2a700ccc868c..3a0e6e6b22b0 100644
/**
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 1392b78fdeca809beb269413d788a864c4f2f261 Mon Sep 17 00:00:00 2001
From bc2e28fa4c09da9f27de359a576ad46f0c108dae Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/13] ARM: dts: imx6qdl: Enable usb node children with <reg>
@ -14,7 +14,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/dts/imx6qdl.dtsi b/arch/arm/boot/dts/imx6qdl.dtsi
index 59ff86695a14..a4957bf2a82f 100644
index c003e62bf290..7ffd2f1f769e 100644
--- a/arch/arm/boot/dts/imx6qdl.dtsi
+++ b/arch/arm/boot/dts/imx6qdl.dtsi
@@ -983,6 +983,8 @@
@ -45,5 +45,5 @@ index 59ff86695a14..a4957bf2a82f 100644
interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From bd2a35c39515f939b10d76c60cebafc621a4dcfd Mon Sep 17 00:00:00 2001
From b2ad93788d10a09f72eb170cf0f13ddecc540ff4 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/13] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
@ -17,7 +17,7 @@ Tested-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
1 file changed, 12 insertions(+), 14 deletions(-)
diff --git a/arch/arm/boot/dts/imx6qdl-udoo.dtsi b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
index 4161b7d4323a..442a6d69ede8 100644
index 906387915dc5..d3cc0b666e0d 100644
--- a/arch/arm/boot/dts/imx6qdl-udoo.dtsi
+++ b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
@@ -9,6 +9,8 @@
@ -76,5 +76,5 @@ index 4161b7d4323a..442a6d69ede8 100644
&usdhc3 {
--
2.16.2
2.17.0

View file

@ -1,4 +1,4 @@
From 160685d2e3325c31b65fec8d7635a5f82d22c073 Mon Sep 17 00:00:00 2001
From 90445c490f11a0afefc9ccbae3ca5893ad0ddb15 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/13] ARM: dts: imx6q-evi: Fix onboard hub reset line
@ -15,7 +15,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
1 file changed, 7 insertions(+), 18 deletions(-)
diff --git a/arch/arm/boot/dts/imx6q-evi.dts b/arch/arm/boot/dts/imx6q-evi.dts
index e0aea782c666..6f3afffc8faa 100644
index fcd257bc5ac3..d32fa81bba95 100644
--- a/arch/arm/boot/dts/imx6q-evi.dts
+++ b/arch/arm/boot/dts/imx6q-evi.dts
@@ -54,18 +54,6 @@
@ -70,5 +70,5 @@ index e0aea782c666..6f3afffc8faa 100644
>;
};
--
2.16.2
2.17.0

View file

@ -4,10 +4,10 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-4.16
_srcname=linux-4.17
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=4.16.13
pkgver=4.17.0
pkgrel=1
rcnrel=armv7-x0
arch=('armv7h')
@ -16,7 +16,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
@ -37,23 +37,22 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook')
md5sums=('1357fb4ee7c288fdeac5d4e0048f5c18'
'ace51349b2f09e3731709b95b8053289'
'7f304b9a4267eed27ef5541b7db9df28'
'38440ef4a8c52fae52c02e7b17698e9f'
'62016c2311ad894a145e2100074c5c65'
'7bb0eb2d0fb06666bedd4dc2cdbaa02c'
'ceb4743e81f96a78c7e6e9fdfae50ccb'
'3a9da57d484c6bcdcd620f0931827a24'
'd1ab6fc88aeb28013d496231b3c63682'
'6abeec83b3a5f5ea2676fe03ea97df73'
'10a0febbe2af946a12137cb574bd676b'
'966ddd9affd0237bf9fe7298eb26bfe5'
'32eed86641825eaed7e6f78c14cc19d8'
'21b75ae79dcb0994f7fd99f5062a8ef9'
'854888245f29013be06f762c6162a5b2'
'267d9dc5a1ec7232a2849cfad322209c'
'8d90eb8d943b5a2d6563bac2ca20ddda'
md5sums=('5bb13a03274b66b56c85b26682e407d7'
'b9e5c7fbb3025d4ec02b61319a1a9fad'
'659aa5898b6182ba855dff9584d0b77b'
'09112f7298d00fb453b6789286d01334'
'ada6bd5d1519869a0f60cc3523ea2394'
'7cf7295dd4150ecc78d9a37156946286'
'ff1771ffab749185fc5a0df1bd78ce4f'
'6580171cfdb1bca4f9e901be68aeeed0'
'2f3ad2a6d64ae13f6d80046efa067050'
'b8653cacf717217278c649bd2dea0f20'
'61f629a249a38aef979cab2be4d7bb7f'
'7e20b2245d031eb8443b040dac280a13'
'a4d211d0d0920f6f529c22273e1c4708'
'8b7f6296bb24f5d6b1d2088cd0fdcb79'
'52e2a87d059ea401640195b9f9253673'
'bed4ffb7600b1d746699d9d807de9527'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -64,7 +63,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# RCN patch
git apply ../patch-${pkgver%.0}-${rcnrel}.diff

File diff suppressed because it is too large Load diff