mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/nodejs to 4.2.1-1
This commit is contained in:
parent
00efbf1ab2
commit
3c66d9f274
2 changed files with 14 additions and 16 deletions
|
@ -1,27 +1,25 @@
|
|||
From 3ea8b43a40ae4c31c684d75a18d27961efa3aab1 Mon Sep 17 00:00:00 2001
|
||||
From 3248eca016badde88fe1f8cb97c08344ee182a23 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 16 Sep 2015 17:51:00 -0600
|
||||
Date: Tue, 13 Oct 2015 20:45:53 -0600
|
||||
Subject: [PATCH] arm fixes
|
||||
|
||||
---
|
||||
configure | 7 +++++--
|
||||
configure | 5 ++++-
|
||||
deps/v8/build/toolchain.gypi | 4 ++--
|
||||
2 files changed, 7 insertions(+), 4 deletions(-)
|
||||
2 files changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 6c8dfde..cc7dbfa 100755
|
||||
index b4936f1..53192eb 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -603,9 +603,12 @@ def configure_arm(o):
|
||||
@@ -626,8 +626,11 @@ def configure_arm(o):
|
||||
if is_arch_armv7():
|
||||
o['variables']['arm_fpu'] = 'vfpv3'
|
||||
arm_fpu = 'vfpv3'
|
||||
o['variables']['arm_version'] = '7'
|
||||
- else:
|
||||
+ elif is_arch_armv6():
|
||||
o['variables']['arm_fpu'] = 'vfpv2'
|
||||
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
|
||||
+ o['variables']['arm_version'] = '6'
|
||||
+ else:
|
||||
else:
|
||||
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
|
||||
+ o['variables']['arm_fpu'] = ''
|
||||
+ o['variables']['arm_version'] = '5'
|
||||
|
||||
|
@ -50,5 +48,5 @@ index 4dbf42b..8d3e968 100644
|
|||
}],
|
||||
],
|
||||
--
|
||||
2.5.2
|
||||
2.6.1
|
||||
|
||||
|
|
|
@ -9,8 +9,8 @@
|
|||
# Contributor: Jason Plum <jplum@archlinuxarm.org>
|
||||
|
||||
pkgname=nodejs
|
||||
pkgver=4.2.0
|
||||
pkgrel=2
|
||||
pkgver=4.2.1
|
||||
pkgrel=1
|
||||
pkgdesc='Evented I/O for V8 javascript'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://nodejs.org/'
|
||||
|
@ -21,8 +21,8 @@ makedepends=('python2' 'procps-ng')
|
|||
optdepends=('npm: nodejs package manager')
|
||||
source=("http://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz"
|
||||
'0001-arm-fixes.patch')
|
||||
sha256sums=('94ea40efeb598fed6e1a78990b698da73275c49876ec551dc36e11513c99fb6b'
|
||||
'13f14499c0a83d282ac07d1116a2d9196b4ae37dbd6914865f0b6549158789c4')
|
||||
sha256sums=('8861b9f4c3b4db380fcda19a710c0430c3d62d03ee176c64db63eef95a672663'
|
||||
'8fa868fca31bac8d62c5fae17fa64bcb0d38d0f42a9c53e9339c94a8267dbb78')
|
||||
|
||||
set_flags_for_arm() {
|
||||
if [ "$CARCH" == "arm" ]; then
|
||||
|
|
Loading…
Reference in a new issue