mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
alarm/xf86-video-armsoc-odroid fix
This commit is contained in:
parent
7f0d99b01a
commit
3c9f1a583d
2 changed files with 35 additions and 3 deletions
|
@ -14,14 +14,21 @@ makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverpro
|
|||
options=('!libtool')
|
||||
conflicts=(xf86-video-armsoc)
|
||||
provides=(xf86-video-armsoc)
|
||||
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}")
|
||||
md5sums=('SKIP')
|
||||
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}"
|
||||
'xorg.patch')
|
||||
md5sums=('SKIP'
|
||||
'3e27624156b65b23431c77f38f155620')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
echo $(git rev-list --count makepkg).$(git rev-parse --short makepkg)
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../xorg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
|
||||
|
@ -35,4 +42,3 @@ package() {
|
|||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
|
|
26
alarm/xf86-video-armsoc-odroid/xorg.patch
Normal file
26
alarm/xf86-video-armsoc-odroid/xorg.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -urN a/src/armsoc_driver.c b/src/armsoc_driver.c
|
||||
--- a/src/armsoc_driver.c 2014-07-29 20:17:16.708546536 -0600
|
||||
+++ b/src/armsoc_driver.c 2014-07-29 20:17:48.503440926 -0600
|
||||
@@ -1060,7 +1060,7 @@
|
||||
/* Initialize backing store: */
|
||||
xf86SetBackingStore(pScreen);
|
||||
|
||||
- fbdev = xf86GetOptValString(pARMSOC->pOptionInfo,
|
||||
+ fbdev = (char *)xf86GetOptValString(pARMSOC->pOptionInfo,
|
||||
OPTION_INIT_FROM_FBDEV);
|
||||
if (fbdev && *fbdev != '\0') {
|
||||
if (ARMSOCCopyFB(pScrn, fbdev)) {
|
||||
diff -urN a/src/drmmode_display.c b/src/drmmode_display.c
|
||||
--- a/src/drmmode_display.c 2014-07-29 20:17:16.708546536 -0600
|
||||
+++ b/src/drmmode_display.c 2014-07-29 20:17:52.533427544 -0600
|
||||
@@ -353,8 +353,8 @@
|
||||
drmmode_crtc->last_good_y = crtc->y;
|
||||
drmmode_crtc->last_good_rotation = crtc->rotation;
|
||||
if (drmmode_crtc->last_good_mode) {
|
||||
- if (drmmode_crtc->last_good_mode->name)
|
||||
- free(drmmode_crtc->last_good_mode->name);
|
||||
+ //if (drmmode_crtc->last_good_mode->name)
|
||||
+ // free(drmmode_crtc->last_good_mode->name);
|
||||
free(drmmode_crtc->last_good_mode);
|
||||
}
|
||||
drmmode_crtc->last_good_mode = xf86DuplicateMode(&crtc->mode);
|
Loading…
Reference in a new issue