mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webengine to 5.14.0-1
This commit is contained in:
parent
9cd8af1a5c
commit
3ca025e91c
4 changed files with 19 additions and 96 deletions
|
@ -1,4 +1,4 @@
|
|||
From dd9b2eeaa1212cde95b26accbf271fb00f865331 Mon Sep 17 00:00:00 2001
|
||||
From e3857998449fabedad2d5c7077a97ff7efa509ed Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH 1/2] ARM toolchain fixes
|
||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 1/2] ARM toolchain fixes
|
|||
1 file changed, 10 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
|
||||
index 1b0f2205927..9727519cdd0 100644
|
||||
index fa8b17e9db3..7398b7556ec 100644
|
||||
--- a/chromium/build/toolchain/linux/BUILD.gn
|
||||
+++ b/chromium/build/toolchain/linux/BUILD.gn
|
||||
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
|
||||
@@ -30,15 +30,13 @@ clang_toolchain("clang_arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm64") {
|
||||
|
@ -32,7 +32,7 @@ index 1b0f2205927..9727519cdd0 100644
|
|||
|
||||
toolchain_args = {
|
||||
current_cpu = "arm64"
|
||||
@@ -40,15 +38,13 @@ gcc_toolchain("arm64") {
|
||||
@@ -48,15 +46,13 @@ gcc_toolchain("arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm") {
|
||||
|
@ -54,5 +54,5 @@ index 1b0f2205927..9727519cdd0 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.21.0
|
||||
2.24.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 85f28ac094883e20d31775cba258b7e2a333866c Mon Sep 17 00:00:00 2001
|
||||
From 5fee35c4b2aa7e717b5f136a68245b78acf01020 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Jul 2019 07:10:36 -0600
|
||||
Subject: [PATCH 2/2] Fix ARM skia ICE
|
||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 2/2] Fix ARM skia ICE
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
index 9a69fcf1b90..ffb1aaac1f8 100644
|
||||
index 54fbdd25b32..b25877e7cfc 100644
|
||||
--- a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
+++ b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
@@ -559,7 +559,7 @@ SI void sample_clut_16(const skcms_A2B* a2b, I32 ix, F* r, F* g, F* b) {
|
||||
|
||||
@@ -611,7 +611,7 @@ SI void sample_clut_16(const skcms_A2B* a2b, I32 ix, F* r, F* g, F* b) {
|
||||
// GCC 7.2.0 hits an internal compiler error with -finline-functions (or -O3)
|
||||
// when targeting MIPS 64, I think attempting to inline clut() into exec_ops().
|
||||
-#if 1 && defined(__GNUC__) && !defined(__clang__) && defined(__mips64)
|
||||
+#if 1 && defined(__GNUC__) && !defined(__clang__) && (defined(__mips64) || defined(__arm__))
|
||||
// when targeting MIPS 64, i386, or s390x, I think attempting to inline clut() into exec_ops().
|
||||
#if 1 && defined(__GNUC__) && !defined(__clang__) \
|
||||
- && (defined(__mips64) || defined(__i386) || defined(__s390x__))
|
||||
+ && (defined(__mips64) || defined(__i386) || defined(__s390x__) || defined(__arm__))
|
||||
#define MAYBE_NOINLINE __attribute__((noinline))
|
||||
#else
|
||||
#define MAYBE_NOINLINE
|
||||
--
|
||||
2.21.0
|
||||
2.24.0
|
||||
|
||||
|
|
|
@ -9,9 +9,9 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.13.2
|
||||
_qtver=5.14.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=4
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -22,29 +22,16 @@ makedepends=('python2' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
icu65.patch
|
||||
CVE-2019-13720.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=d6e5fc10"
|
||||
qtwebengine-flash.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=e72fd513"
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch)
|
||||
sha256sums=('adcf56b5de6f34744bba2307b696fc75611884f4270e87dfa760d6e99dd711bb'
|
||||
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
|
||||
'3b2ce75214e757f5d0d268fbb1009c2e0c660d19620ae27e8d92a0e492e5d9da'
|
||||
'1a64c4418950b4f9da78fe88c602f7dc274c85197927a3335d35220378ade2df'
|
||||
'f03455dd16275f8abb432278abb908ebdd5f8cf83db73ae63de7a105bbf47109'
|
||||
'2a363b44b8291512bb2bcbce1370b8abfb8a57961e0e5e34150da6e337155a05')
|
||||
sha256sums=('74f8c11cc318612c8d9dc87cf791badb1efe7080c10d8b3ed5843b249a942d32'
|
||||
'6cd3f4877e239c83df5ede59c74db2b2e84b4adce66ef83d30b3b4a3f04677e8'
|
||||
'f389de929c6d27217a1c7e3e7118b06e4d15e17123c96ace2c7a791ecad6bcc7')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd $_pkgfqn
|
||||
patch -p1 -i ../qtwebengine-flash.patch # Fix Flash plugin
|
||||
|
||||
cd src/3rdparty
|
||||
patch -p1 -i "$srcdir"/CVE-2019-13720.patch
|
||||
patch -p1 -d chromium -i "$srcdir"/icu65.patch
|
||||
|
||||
#cd src/3rdparty
|
||||
cd $_pkgfqn/src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
|
||||
}
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
From 5679c3c191ed62b62d8db22f1657a296ee9bfe8e Mon Sep 17 00:00:00 2001
|
||||
From: Frank Tang <ftang@chromium.org>
|
||||
Date: Wed, 30 Oct 2019 22:49:47 +0000
|
||||
Subject: [PATCH] Update ICU to 65.1 from 64 and fix broken tests
|
||||
|
||||
ICU 65-1 release note
|
||||
http://site.icu-project.org/download/65
|
||||
|
||||
CLDR 36 release blog
|
||||
http://blog.unicode.org/2019/10/unicode-cldr-version-36-languagelocale.html
|
||||
|
||||
Most of the test expectation change is due to CLDR 36 update
|
||||
of Grapheme Cluster for Indic languages
|
||||
See the following for related changes in ICU 65.1 in this area:
|
||||
https://unicode-org.atlassian.net/browse/CLDR-10994
|
||||
https://unicode-org.atlassian.net/browse/ICU-13637
|
||||
https://github.com/unicode-org/cldr/blob/master/common/properties/segments/readme.txt
|
||||
|
||||
Bug: chromium:1014272, chromium:1017047
|
||||
Change-Id: I9fc6d4620bf2a4c189940d06d8c79893502db3dd
|
||||
Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng_disabled
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1866059
|
||||
Reviewed-by: Jungshik Shin <jshin@chromium.org>
|
||||
Reviewed-by: Doug Turner <dougt@chromium.org>
|
||||
Reviewed-by: Michael Wasserman <msw@chromium.org>
|
||||
Reviewed-by: Kent Tamura <tkent@chromium.org>
|
||||
Reviewed-by: Trent Apted <tapted@chromium.org>
|
||||
Reviewed-by: Mason Freed <masonfreed@chromium.org>
|
||||
Commit-Queue: Frank Tang <ftang@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#711027}
|
||||
---
|
||||
third_party/blink/renderer/core/dom/document.cc | 2 +-
|
||||
ui/gfx/render_text_harfbuzz.cc | 5 ++++-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
|
||||
index 511aac29086..f188cf548a6 100644
|
||||
--- a/third_party/blink/renderer/core/dom/document.cc
|
||||
+++ b/third_party/blink/renderer/core/dom/document.cc
|
||||
@@ -6191,7 +6191,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
|
||||
|
||||
for (unsigned i = 0; i < length;) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (c == ':') {
|
||||
if (saw_colon)
|
||||
return ParseQualifiedNameResult(kQNMultipleColons);
|
||||
diff --git a/ui/gfx/render_text_harfbuzz.cc b/ui/gfx/render_text_harfbuzz.cc
|
||||
index 50e86af6b97..0339ff3ff8e 100644
|
||||
--- a/ui/gfx/render_text_harfbuzz.cc
|
||||
+++ b/ui/gfx/render_text_harfbuzz.cc
|
||||
@@ -971,7 +971,10 @@ RangeF TextRunHarfBuzz::GetGraphemeBounds(RenderTextHarfBuzz* render_text,
|
||||
++total;
|
||||
}
|
||||
}
|
||||
- DCHECK_GT(total, 0);
|
||||
+ // With ICU 65.1, DCHECK_GT() below fails.
|
||||
+ // See https://crbug.com/1017047 for more details.
|
||||
+ //
|
||||
+ // DCHECK_GT(total, 0);
|
||||
|
||||
// It's possible for |text_index| to point to a diacritical mark, at the end
|
||||
// of |chars|. In this case all the grapheme boundaries come before it. Just
|
Loading…
Reference in a new issue