mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/pacman to 5.0.1-2.1
This commit is contained in:
parent
2924a0a0c8
commit
3cc01b542b
4 changed files with 75 additions and 11 deletions
|
@ -1,7 +1,7 @@
|
|||
From 25b7d2243038723c95402c0e6e1bdaa38817c92f Mon Sep 17 00:00:00 2001
|
||||
From 42c073e4335d45e5f733a67cb1857a7561275d44 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Sep 2014 18:58:16 -0600
|
||||
Subject: [PATCH 1/2] Sychronize filesystem
|
||||
Subject: [PATCH 1/3] Sychronize filesystem
|
||||
|
||||
Since many problems arise from improper flushing of the filesystem,
|
||||
particularly package installations followed by a reboot very shorly after,
|
||||
|
@ -14,7 +14,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
|
||||
index 239d6a1..8a6260a 100644
|
||||
index 1398470..82835ee 100644
|
||||
--- a/lib/libalpm/trans.c
|
||||
+++ b/lib/libalpm/trans.c
|
||||
@@ -230,6 +230,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
|
||||
|
@ -28,5 +28,5 @@ index 239d6a1..8a6260a 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.7.0
|
||||
2.7.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 4a773b741fd6aca6e6f7183e40d40a06e9c65ee3 Mon Sep 17 00:00:00 2001
|
||||
From b6d6499c598caaa50f492c6558b649fcd608a1f6 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 30 Jan 2016 17:19:03 -0700
|
||||
Subject: [PATCH 2/2] Revert "close stdin before running install scripts"
|
||||
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
|
||||
|
||||
This reverts commit e374e6829cea3512f0b4a4069c5a6168f0f8d8a0.
|
||||
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
|
||||
index 001c042..f2d43ee 100644
|
||||
index 4a4847d..5e74462 100644
|
||||
--- a/lib/libalpm/util.c
|
||||
+++ b/lib/libalpm/util.c
|
||||
@@ -602,7 +602,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
|
@ -28,5 +28,5 @@ index 001c042..f2d43ee 100644
|
|||
close(2);
|
||||
while(dup2(child2parent_pipefd[1], 1) == -1 && errno == EINTR);
|
||||
--
|
||||
2.7.0
|
||||
2.7.1
|
||||
|
||||
|
|
|
@ -0,0 +1,60 @@
|
|||
From 2c2a442ba21223de93b1927f8829dbf4ab4c495c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 11 Mar 2016 20:11:24 -0700
|
||||
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
|
||||
pipe"
|
||||
|
||||
This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
|
||||
---
|
||||
lib/libalpm/util.c | 13 +++++++------
|
||||
1 file changed, 7 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
|
||||
index 5e74462..f2d43ee 100644
|
||||
--- a/lib/libalpm/util.c
|
||||
+++ b/lib/libalpm/util.c
|
||||
@@ -586,7 +586,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- if(pipe(parent2child_pipefd) == -1) {
|
||||
+ if(stdin_cb && pipe(parent2child_pipefd) == -1) {
|
||||
_alpm_log(handle, ALPM_LOG_ERROR, _("could not create pipe (%s)\n"), strerror(errno));
|
||||
retval = 1;
|
||||
goto cleanup;
|
||||
@@ -606,9 +606,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
close(2);
|
||||
while(dup2(child2parent_pipefd[1], 1) == -1 && errno == EINTR);
|
||||
while(dup2(child2parent_pipefd[1], 2) == -1 && errno == EINTR);
|
||||
- while(dup2(parent2child_pipefd[0], 0) == -1 && errno == EINTR);
|
||||
- close(parent2child_pipefd[0]);
|
||||
- close(parent2child_pipefd[1]);
|
||||
+ if(stdin_cb) {
|
||||
+ while(dup2(parent2child_pipefd[0], 0) == -1 && errno == EINTR);
|
||||
+ close(parent2child_pipefd[0]);
|
||||
+ close(parent2child_pipefd[1]);
|
||||
+ }
|
||||
close(child2parent_pipefd[0]);
|
||||
close(child2parent_pipefd[1]);
|
||||
if(cwdfd >= 0) {
|
||||
@@ -643,16 +645,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
child2parent->events = POLLIN;
|
||||
fcntl(child2parent->fd, F_SETFL, O_NONBLOCK);
|
||||
close(child2parent_pipefd[1]);
|
||||
- close(parent2child_pipefd[0]);
|
||||
|
||||
if(stdin_cb) {
|
||||
parent2child->fd = parent2child_pipefd[1];
|
||||
parent2child->events = POLLOUT;
|
||||
fcntl(parent2child->fd, F_SETFL, O_NONBLOCK);
|
||||
+ close(parent2child_pipefd[0]);
|
||||
} else {
|
||||
parent2child->fd = -1;
|
||||
parent2child->events = 0;
|
||||
- close(parent2child_pipefd[1]);
|
||||
}
|
||||
|
||||
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
|
||||
--
|
||||
2.7.1
|
||||
|
|
@ -8,10 +8,11 @@
|
|||
# - pacman.conf: architecture=arm/armv6h/armv7h/aarch64, added our aur and alarm repos
|
||||
# - makepkg.conf: adjusted C/CXX/LDFLAGS
|
||||
# - patch to sync filesystem after install/remove
|
||||
# - reverts to allow scriplet input on stdin
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=5.0.1
|
||||
pkgrel=2
|
||||
pkgrel=2.1
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
|
@ -31,13 +32,15 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
|
|||
0001-libmakepkg-fix-is_array-function.patch
|
||||
0001-Sychronize-filesystem.patch
|
||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||
pacman.conf
|
||||
makepkg.conf)
|
||||
md5sums=('377a2664d6007d72d6d8a126add83bcf'
|
||||
'SKIP'
|
||||
'55732144f1048f714f1f93203e9b7728'
|
||||
'11869a104d0944cc86215098cf5a32bf'
|
||||
'd4692c3add0b0dab87036edad3f59626'
|
||||
'b1083094498f63e53de7d2aafea23733'
|
||||
'8968ff77379c5b0143cbe89ed062c33b'
|
||||
'fd59d9fb04abadffb937082c288bb10c'
|
||||
'372fa63a5333ef22a0197d44b2a454ca'
|
||||
'ace945b12a7a429af48b7a50f4119c4c')
|
||||
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD') # Allan McRae <allan@archlinux.org>
|
||||
|
@ -49,6 +52,7 @@ prepare() {
|
|||
|
||||
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
||||
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
patch -p1 -i ../0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue