added community/curaengine

This commit is contained in:
Kevin Mihelich 2018-09-14 13:53:51 +00:00
parent 1fa483bcba
commit 3d17798eba
2 changed files with 66 additions and 0 deletions

View file

@ -0,0 +1,52 @@
# Maintainer: Jelle van der Waa <jelle@archlinux.org>
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - -DBUILD_TESTS=oFF
pkgname=curaengine
pkgver=3.4.1
pkgrel=3
pkgdesc="Engine for processing 3D models into 3D printing instruction for Ultimaker and other GCode based 3D printers."
url="https://github.com/Ultimaker/CuraEngine"
arch=('x86_64')
license=('AGPL')
depends=('arcus')
# TODO: https://github.com/Ultimaker/CuraEngine/blob/master/CMakeLists.txt#L26
# Package polyclipping in the repos
checkdepends=('cppunit')
makedepends=('cmake' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz"
do_not_copy_resource.patch)
md5sums=('825f80f42da70efe6c889d8acb8f6afe'
'07b0f2240737f99830c1a87c1f1f378e')
prepare() {
cd CuraEngine-${pkgver}
patch -Np1 -i ${srcdir}/do_not_copy_resource.patch
}
build() {
cd CuraEngine-${pkgver}
mkdir -p build
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=OFF \
-DCMAKE_BUILD_TYPE=Release
make
}
package() {
cd CuraEngine-${pkgver}/build
make DESTDIR="${pkgdir}" install
}
check() {
cd CuraEngine-${pkgver}/build
make test
}
# vim:set ts=2 sw=2 et:

View file

@ -0,0 +1,14 @@
diff -aur CuraEngine-3.4.1/CMakeLists.txt CuraEngine-3.4.1.old/CMakeLists.txt
--- CuraEngine-3.4.1/CMakeLists.txt 2018-07-09 10:55:15.000000000 +0200
+++ CuraEngine-3.4.1.old/CMakeLists.txt 2018-09-07 20:16:42.621995976 +0200
@@ -252,10 +252,6 @@
endif()
-add_custom_command(TARGET CuraEngine POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy_directory
- ${CMAKE_SOURCE_DIR}/resources $<TARGET_FILE_DIR:CuraEngine>)
-
# Installing CuraEngine.
include(GNUInstallDirs)
install(TARGETS CuraEngine DESTINATION ${CMAKE_INSTALL_BINDIR})