added extra/koffice 2.3.3-11

This commit is contained in:
Kevin Mihelich 2011-11-18 14:09:15 -05:00
parent 2a25b7e4c8
commit 3d3d644971
8 changed files with 1994 additions and 0 deletions

View file

@ -0,0 +1,289 @@
Description: fix build in arm s/double/qreal
Author: Ana Guerrero <ana@debian.org>
Last-Update: 2011-02-13
Applied-Upstream: Calligra master, koffice 2.3 branch
--- a/kplato/libs/ui/kptintervaledit.cpp
+++ b/kplato/libs/ui/kptintervaledit.cpp
@@ -42,7 +42,7 @@ IntervalEdit::IntervalEdit( CalendarDay
setIntervals( intervals );
if ( ! intervals.isEmpty() ) {
startTime->setTime( intervals.last()->endTime() );
- double l = ( intervals.last()->endTime().msecsTo( QTime().addMSecs( -1 ) ) + 1 ) / (1000.0*60.0*60.0);
+ qreal l = ( intervals.last()->endTime().msecsTo( QTime().addMSecs( -1 ) ) + 1 ) / (1000.0*60.0*60.0);
length->setValue( qMin( l, (qreal) 8.0 ) );
}
}
--- a/krita/image/brushengine/kis_paintop.cc
+++ b/krita/image/brushengine/kis_paintop.cc
@@ -86,7 +86,7 @@ KisFixedPaintDeviceSP KisPaintOp::cached
return d->dab;
}
-void KisPaintOp::splitCoordinate(double coordinate, qint32 *whole, double *fraction)
+void KisPaintOp::splitCoordinate(qreal coordinate, qint32 *whole, qreal *fraction)
{
qint32 i = static_cast<qint32>(coordinate);
--- a/krita/image/brushengine/kis_paintop.h
+++ b/krita/image/brushengine/kis_paintop.h
@@ -108,7 +108,7 @@ public:
/**
* Split the coordinate into whole + fraction, where fraction is always >= 0.
*/
- static void splitCoordinate(double coordinate, qint32 *whole, double *fraction);
+ static void splitCoordinate(qreal coordinate, qint32 *whole, qreal *fraction);
/**
* returns the scale and rotation dynamically computed for the single dab
--- a/krita/plugins/extensions/dockers/colorselectorng/kis_color_selector.cpp
+++ b/krita/plugins/extensions/dockers/colorselectorng/kis_color_selector.cpp
@@ -161,12 +161,12 @@ inline int iconSize(qreal width, qreal h
qreal xm = width/2.;
qreal ym = height/2.;
if(xm>=2*ym || ym>=2*xm)
- return qBound(5., radius, 32.);
+ return qBound(qreal(5.), radius, qreal(32.));
qreal a=-2;
qreal b=2.*(xm+ym);
qreal c=radius*radius-xm*xm-ym*ym;
- return qBound(5., ((-b+sqrt(b*b-4*a*c))/(2*a)), 32.);
+ return qBound(qreal(5.), qreal((-b+sqrt(b*b-4*a*c))/(2*a)), qreal(32.));
}
void KisColorSelector::resizeEvent(QResizeEvent* e) {
--- a/krita/plugins/extensions/dockers/colorselectorng/kis_color_selector_simple.cpp
+++ b/krita/plugins/extensions/dockers/colorselectorng/kis_color_selector_simple.cpp
@@ -39,7 +39,7 @@ void KisColorSelectorSimple::setColor(co
emit paramChanged(-1, -1, -1, c.hslSaturationF(), c.lightnessF());
break;
case KisColorSelector::LH:
- m_lastClickPos.setX(qBound(0., c.hueF(), 1.));
+ m_lastClickPos.setX(qBound<qreal>(0., c.hueF(), 1.));
m_lastClickPos.setY(1.-c.lightnessF());
emit paramChanged(c.hueF(), -1, -1, -1, c.lightnessF());
break;
@@ -49,17 +49,17 @@ void KisColorSelectorSimple::setColor(co
emit paramChanged(-1, c.saturationF(), c.valueF(), -1, -1);
break;
case KisColorSelector::VH:
- m_lastClickPos.setX(qBound(0., c.hueF(), 1.));
+ m_lastClickPos.setX(qBound<qreal>(0., c.hueF(), 1.));
m_lastClickPos.setY(c.valueF());
emit paramChanged(c.hueF(), -1, c.valueF(), -1, -1);
break;
case KisColorSelector::hsvSH:
- m_lastClickPos.setX(qBound(0., c.hueF(), 1.));
+ m_lastClickPos.setX(qBound<qreal>(0., c.hueF(), 1.));
m_lastClickPos.setY(1-c.saturationF());
emit paramChanged(c.hueF(), c.saturationF(), -1, -1, -1);
break;
case KisColorSelector::hslSH:
- m_lastClickPos.setX(qBound(0., c.hueF(), 1.));
+ m_lastClickPos.setX(qBound<qreal>(0., c.hueF(), 1.));
m_lastClickPos.setY(1-c.hslSaturationF());
emit paramChanged(c.hueF(), -1, -1, c.hslSaturationF(), -1);
break;
@@ -80,7 +80,7 @@ void KisColorSelectorSimple::setColor(co
emit paramChanged(-1, -1, -1, c.hslSaturationF(), -1);
break;
case KisColorSelector::H:
- m_lastClickPos.setX(1-qBound(0., c.hueF(), 1.));
+ m_lastClickPos.setX(1-qBound<qreal>(0., c.hueF(), 1.));
emit paramChanged(c.hueF(), -1, -1, -1, -1);
break;
default:
--- a/krita/plugins/extensions/dockers/colorselectorng/kis_shade_selector_line.cpp
+++ b/krita/plugins/extensions/dockers/colorselectorng/kis_shade_selector_line.cpp
@@ -139,9 +139,9 @@ void KisShadeSelectorLine::paintEvent(QP
while(hue<0) hue+=1.;
while(hue>1) hue-=1.;
- qreal saturation = qBound(0., m_color.saturationF()+(i*saturationStep)+m_saturationShift, 1.);
+ qreal saturation = qBound<qreal>(0., m_color.saturationF()+(i*saturationStep)+m_saturationShift, 1.);
- qreal value = qBound(0., m_color.valueF()+(i*valueStep)+m_valueShift, 1.);
+ qreal value = qBound<qreal>(0., m_color.valueF()+(i*valueStep)+m_valueShift, 1.);
koColor.fromQColor(QColor::fromHsvF(hue, saturation, value));
--- a/krita/plugins/paintops/defaultpaintops/brush/kis_brushop.h
+++ b/krita/plugins/paintops/defaultpaintops/brush/kis_brushop.h
@@ -51,7 +51,7 @@ public:
KisBrushOp(const KisBrushBasedPaintOpSettings *settings, KisPainter * painter, KisImageWSP image);
virtual ~KisBrushOp();
- double paintAt(const KisPaintInformation& info);
+ qreal paintAt(const KisPaintInformation& info);
virtual KisDistanceInformation paintLine(const KisPaintInformation& pi1, const KisPaintInformation& pi2, const KisDistanceInformation& savedDist = KisDistanceInformation());
private:
--- a/krita/plugins/paintops/defaultpaintops/smudge/kis_smudgeop.cpp
+++ b/krita/plugins/paintops/defaultpaintops/smudge/kis_smudgeop.cpp
@@ -95,7 +95,7 @@ KisSmudgeOp::~KisSmudgeOp()
of the current iteration.
*/
-double KisSmudgeOp::paintAt(const KisPaintInformation& info)
+qreal KisSmudgeOp::paintAt(const KisPaintInformation& info)
{
KisBrushSP brush = m_brush;
@@ -118,7 +118,7 @@ double KisSmudgeOp::paintAt(const KisPai
is where the dab will be positioned and the fractional part determines
the sub-pixel positioning. */
qint32 x, y;
- double xFraction, yFraction;
+ qreal xFraction, yFraction;
splitCoordinate(pt.x(), &x, &xFraction);
splitCoordinate(pt.y(), &y, &yFraction);
--- a/krita/plugins/paintops/deform/kis_deform_paintop.cpp
+++ b/krita/plugins/paintops/deform/kis_deform_paintop.cpp
@@ -94,9 +94,9 @@ qreal KisDeformPaintOp::paintAt(const Ki
KisFixedPaintDeviceSP dab = cachedDab(painter()->device()->colorSpace());
qint32 x;
- double subPixelX;
+ qreal subPixelX;
qint32 y;
- double subPixelY;
+ qreal subPixelY;
QPointF pt = info.pos();
if (m_sizeProperties.jitterEnabled){
@@ -151,7 +151,7 @@ qreal KisDeformPaintOp::paintAt(const Ki
}
-double KisDeformPaintOp::spacing(double /*pressure*/) const
+qreal KisDeformPaintOp::spacing(qreal /*pressure*/) const
{
return m_spacing;
}
--- a/krita/plugins/paintops/hatching/kis_hatching_paintop.cpp
+++ b/krita/plugins/paintops/hatching/kis_hatching_paintop.cpp
@@ -67,7 +67,7 @@ KisHatchingPaintOp::~KisHatchingPaintOp(
delete m_hatchingBrush;
}
-double KisHatchingPaintOp::paintAt(const KisPaintInformation& info)
+qreal KisHatchingPaintOp::paintAt(const KisPaintInformation& info)
{
//------START SIMPLE ERROR CATCHING-------
if (!painter()->device()) return 1;
@@ -104,7 +104,7 @@ double KisHatchingPaintOp::paintAt(const
QPointF pt = info.pos() - hotSpot;
qint32 x, y;
- double xFraction, yFraction;
+ qreal xFraction, yFraction;
splitCoordinate(pt.x(), &x, &xFraction);
splitCoordinate(pt.y(), &y, &yFraction);
--- a/krita/plugins/paintops/hatching/kis_hatching_paintop.h
+++ b/krita/plugins/paintops/hatching/kis_hatching_paintop.h
@@ -50,7 +50,7 @@ public:
* Paint a hatched dab around the mouse cursor according to
* sensor settings and user preferences.
*/
- double paintAt(const KisPaintInformation& info);
+ qreal paintAt(const KisPaintInformation& info);
/**
* Returns a number between -90 and 90, and corresponds to the
--- a/krita/plugins/paintops/sketch/kis_sketch_paintop.cpp
+++ b/krita/plugins/paintops/sketch/kis_sketch_paintop.cpp
@@ -265,7 +265,7 @@ KisDistanceInformation KisSketchPaintOp:
-double KisSketchPaintOp::paintAt(const KisPaintInformation& info)
+qreal KisSketchPaintOp::paintAt(const KisPaintInformation& info)
{
return paintLine(info, info).spacing;
}
--- a/krita/plugins/paintops/sketch/kis_sketch_paintop.h
+++ b/krita/plugins/paintops/sketch/kis_sketch_paintop.h
@@ -38,7 +38,7 @@ public:
KisSketchPaintOp(const KisSketchPaintOpSettings *settings, KisPainter * painter, KisImageWSP image);
virtual ~KisSketchPaintOp();
virtual KisDistanceInformation paintLine(const KisPaintInformation& pi1, const KisPaintInformation& pi2, const KisDistanceInformation& savedDist = KisDistanceInformation());
- double paintAt(const KisPaintInformation& info);
+ qreal paintAt(const KisPaintInformation& info);
private:
// pixel buffer
--- a/krita/plugins/paintops/spray/spray_brush.cpp
+++ b/krita/plugins/paintops/spray/spray_brush.cpp
@@ -74,7 +74,7 @@ qreal SprayBrush::rotationAngle()
if ( m_shapeDynamicsProperties->randomRotation ){
if ( m_properties->gaussian ) {
- rotation = linearInterpolation(rotation ,M_PI * 2.0 * qBound(0.0, m_rand->nextGaussian(0.0, 0.50) , 1.0), m_shapeDynamicsProperties->randomRotationWeight );
+ rotation = linearInterpolation(rotation ,M_PI * 2.0 * qBound<qreal>(0.0, m_rand->nextGaussian(0.0, 0.50) , 1.0), m_shapeDynamicsProperties->randomRotationWeight );
} else {
rotation = linearInterpolation(rotation, M_PI * 2.0 * drand48(), m_shapeDynamicsProperties->randomRotationWeight );
}
@@ -322,9 +322,9 @@ void SprayBrush::paint(KisPaintDeviceSP
QPointF pt = pos - hotSpot;
qint32 ix;
- double xFraction;
+ qreal xFraction;
qint32 iy;
- double yFraction;
+ qreal yFraction;
KisPaintOp::splitCoordinate(pt.x(), &ix, &xFraction);
KisPaintOp::splitCoordinate(pt.y(), &iy, &yFraction);
--- a/krita/plugins/tools/tool_dyna/kis_tool_dyna.cpp
+++ b/krita/plugins/tools/tool_dyna/kis_tool_dyna.cpp
@@ -278,7 +278,7 @@ KoPointerEvent KisToolDyna::filterEvent(
#endif
m_pressure = m_mouse.vel * 100;
- m_pressure = qBound(0.0,m_pressure, 1.0);
+ m_pressure = qBound(qreal(0.0),m_pressure, qreal(1.0));
m_odelx = delx;
m_odely = dely;
--- a/krita/plugins/paintops/waterymixbrush/kis_waterymix_paintop.cpp
+++ b/krita/plugins/paintops/waterymixbrush/kis_waterymix_paintop.cpp
@@ -65,7 +65,7 @@ KisWateryMixPaintOp::~KisWateryMixPaintO
{
}
-double KisWateryMixPaintOp::paintAt(const KisPaintInformation& info)
+qreal KisWateryMixPaintOp::paintAt(const KisPaintInformation& info)
{
//------START SIMPLE ERROR CATCHING-------
if (!painter()->device()) return 1;
@@ -91,7 +91,7 @@ double KisWateryMixPaintOp::paintAt(cons
QPointF pt = info.pos() - hotSpot;
qint32 x, y;
- double xFraction, yFraction;
+ qreal xFraction, yFraction;
splitCoordinate(pt.x(), &x, &xFraction);
splitCoordinate(pt.y(), &y, &yFraction);
@@ -187,4 +187,4 @@ void KisWateryMixPaintOp::absorb ()
void KisWateryMixPaintOp::dilute ()
{
}
-*/
\ No newline at end of file
+*/
--- a/krita/plugins/paintops/waterymixbrush/kis_waterymix_paintop.h
+++ b/krita/plugins/paintops/waterymixbrush/kis_waterymix_paintop.h
@@ -53,7 +53,7 @@ public:
/**
* Document me
*/
- double paintAt(const KisPaintInformation& info);
+ qreal paintAt(const KisPaintInformation& info);
/*
/// Absorb the color beneath the brush

313
extra/koffice/PKGBUILD Normal file
View file

@ -0,0 +1,313 @@
# $Id: PKGBUILD 142653 2011-11-12 17:18:30Z ibiru $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
# ALARM: Kevin Mihelich <kevin@plugapps.com>
# - Added patch to fix building on ARM
plugrel=1
pkgbase=koffice
pkgname=(
'koffice-filters'
'koffice-interfaces'
'koffice-libs'
'koffice-plugins'
'koffice-pics'
'koffice-servicetypes'
'koffice-templates'
'koffice-tools'
'koffice-karbon'
'koffice-karbon-doc'
# 'koffice-kchart'
# 'koffice-kchart-doc'
'koffice-kexi'
'koffice-kexi-doc'
'koffice-kformula'
'koffice-kformula-doc'
'koffice-kounavail'
'koffice-kplato'
# 'koffice-kplato-doc'
'koffice-kpresenter'
'koffice-kpresenter-doc'
'koffice-krita'
# 'koffice-krita-doc' # no krita-doc anymore upstream
'koffice-kspread'
'koffice-kspread-doc'
'koffice-kword'
# 'koffice-kword-doc' # see http://userbase.kde.org/KWord/Manual for documentation (not supplied by upstream anymore in the sources)
'koffice-handbook'
'koffice-thesaurus-doc'
# 'koffice-kdgantt' # still an empty package
)
pkgver=2.3.3
pkgrel=11
arch=('i686' 'x86_64')
url='http://koffice.kde.org'
license=('GPL' 'LGPL' 'FDL')
makedepends=('pkg-config' 'cmake' 'automoc4' 'boost' 'eigen' 'gsl' 'lcms'
'glew' 'qimageblitz' 'kdepimlibs' 'pstoedit' 'poppler-qt' 'libwpd'
'libwpg' 'opengtl' 'libkdcraw' 'oxygen-icons' 'libgsf')
groups=('koffice')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.bz2"
'kde4-koffice-libwpg02.patch' 'gcc46.patch' 'qt48fix.patch' '20_arm_fix.patch')
sha256sums=('31ba0d98c0d29c7b8ab97efdeb6c618b82177b2b0ec85da088178254da43c099'
'69106deb4081d71b5bd8f2e4f5af67ca689e4ce9f2bb49c11dbce5fb3409d612'
'e095c0b2bbedf41da6535a68b2275464dafd3f194566028d0135322f596e4739'
'a20d7412ceeefdf7987b1c5179a740c7ee188e314ffb94cc226967ee194bc2aa'
'3a2debc7ccf6f821cec1cf0e5c2a38bcf9ac08a8673f445f21276f31cafb92b3')
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
patch -p1 -i "${srcdir}/kde4-koffice-libwpg02.patch"
patch -p1 -i "${srcdir}"/gcc46.patch
patch -p1 -i "${srcdir}"/qt48fix.patch
patch -p1 -i "${srcdir}/20_arm_fix.patch"
cd "${srcdir}"
mkdir build
cd build
cmake ../${pkgbase}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
##### 1st package common files, depends, optdepends of the koffice applications #####
package_koffice-filters(){
pkgdesc="Filters for the KDE office suite"
depends=('shared-mime-info' 'libgsf')
optdepends=('libwpd: WordPerfect document importer'
'libwpg: Corel WordPerfect Graphics image importer' 'pstoedit: Karbon EPS import filter'
'libkdcraw: support for raw images' 'poppler: support for pdf'
'koffice-kspread: Kspread filters' 'koffice-karbon: Karbon filters'
'koffice-kplato: Kplato filters')
install=filters.install
cd "${srcdir}/build/filters"
make DESTDIR="${pkgdir}" install
}
package_koffice-interfaces(){
pkgdesc="Interfaces for the KDE office suite"
depends=('koffice-libs')
cd "${srcdir}/build/interfaces"
make DESTDIR="${pkgdir}" install
}
package_koffice-libs(){
pkgdesc="Libs for the KDE office suite"
depends=('kdepimlibs' 'lcms' 'koffice-servicetypes')
cd "${srcdir}/build/libs"
make DESTDIR="${pkgdir}" install
}
package_koffice-plugins(){
pkgdesc="Plugins for the KDE office suite"
depends=('koffice-libs')
replaces=('koffice-kchart')
conflicts=('koffice-kchart')
cd "${srcdir}/build/plugins"
make DESTDIR="${pkgdir}" install
}
package_koffice-pics(){
pkgdesc="Icons for the KDE office suite"
depends=('desktop-file-utils' 'xdg-utils')
install=koffice.install
cd "${srcdir}/build/pics"
make DESTDIR="${pkgdir}" install
}
package_koffice-servicetypes(){
pkgdesc="Servicetypes for the KDE office suite"
cd "${srcdir}/build/servicetypes"
make DESTDIR="${pkgdir}" install
}
package_koffice-templates(){
pkgdesc="Templates for the KDE office suite"
cd "${srcdir}/build/templates"
make DESTDIR="${pkgdir}" install
}
package_koffice-tools(){
pkgdesc="Tools for the KDE office suite"
depends=('koffice-libs' 'oxygen-icons')
cd "${srcdir}/build/tools"
make DESTDIR="${pkgdir}" install
}
#### package common files done #####
#### package apps and their docs #####
package_koffice-karbon(){
pkgdesc="Vector drawing application for KDE"
depends=('koffice-libs' 'koffice-templates' 'oxygen-icons')
optdepends=('koffice-filters: import/export filters')
install=koffice.install
cd "${srcdir}/build/karbon"
make DESTDIR="${pkgdir}" install
}
package_koffice-karbon-doc(){
pkgdesc="Documentation for karbon"
cd "${srcdir}/build/doc/karbon"
make DESTDIR="${pkgdir}" install
}
package_koffice-kexi(){
pkgdesc="Integrated data management application for the KDE office suite"
depends=('koffice-kspread' 'oxygen-icons')
install=koffice.install
cd "${srcdir}/build/kexi"
make DESTDIR="${pkgdir}" install
}
package_koffice-kexi-doc(){
pkgdesc="Documentation for kexi"
cd "${srcdir}/build/doc/kexi"
make DESTDIR="${pkgdir}" install
}
package_koffice-kformula(){
pkgdesc="Formula editor for the KDE office suite"
depends=('koffice-libs')
install=koffice.install
cd "${srcdir}/build/kformula"
make DESTDIR="${pkgdir}" install
}
package_koffice-kformula-doc() {
pkgdesc="Documentation for koffice-kformula"
cd "${srcdir}/build/doc/kformula"
make DESTDIR="${pkgdir}" install
}
package_koffice-kounavail(){
pkgdesc="Kounavail for the KDE office suite"
depends=('koffice-libs')
cd "${srcdir}/build/kounavail"
make DESTDIR="${pkgdir}" install
}
package_koffice-kplato(){
pkgdesc="Project management application for KDE"
depends=('koffice-kword' 'oxygen-icons')
install=koffice.install
cd "${srcdir}/build/kplato"
make DESTDIR="${pkgdir}" install
}
#package_koffice-kplato-doc(){
# pkgdesc="Documentation for kplato"
# cd ${srcdir}/build/doc/kplato
# make DESTDIR="${pkgdir}" install
#}
package_koffice-kpresenter(){
pkgdesc="Presentation tool for KDE"
depends=('koffice-libs' 'koffice-templates' 'oxygen-icons')
optdepends=('koffice-filters: import/export filters')
install=koffice.install
cd "${srcdir}/build/kpresenter"
make DESTDIR="${pkgdir}" install
}
package_koffice-kpresenter-doc(){
pkgdesc="Documentation for kpresenter"
cd "${srcdir}/build/doc/kpresenter"
make DESTDIR="${pkgdir}" install
}
package_koffice-krita(){
pkgdesc="Graphics editor for KDE"
depends=('glew' 'qimageblitz' 'oxygen-icons' 'koffice-templates' \
'koffice-plugins' 'poppler-qt' 'opengtl')
optdepends=('koffice-filters: import/export filters' 'libkdcraw: support for raw images')
install=krita.install
cd "${srcdir}/build/krita"
make DESTDIR="${pkgdir}" install
}
#package_koffice-krita-doc(){
# pkgdesc="Documentation for krita"
# cd ${srcdir}/build/doc/krita
# make DESTDIR="${pkgdir}" install
#}
package_koffice-kspread(){
pkgdesc="Spreadsheet application for KDE"
depends=('gsl' 'koffice-templates' 'koffice-plugins' 'oxygen-icons')
optdepends=('koffice-filters: import/export filters')
install=koffice.install
cd "${srcdir}/build/kspread"
make DESTDIR="${pkgdir}" install
}
package_koffice-kspread-doc(){
pkgdesc="Documentation for kspread"
cd "${srcdir}/build/doc/kspread"
make DESTDIR="${pkgdir}" install
}
package_koffice-kword(){
pkgdesc="Wordprocessor for KDE"
depends=('koffice-templates' 'koffice-pics' 'oxygen-icons' \
'koffice-kounavail' 'koffice-plugins')
optdepends=('koffice-filters: import/export filters')
install=koffice.install
cd "${srcdir}/build/kword"
make DESTDIR="${pkgdir}" install
# some sed lines to have python2 in extension scripts
sed -i "s|/usr/bin/env python|/usr/bin/env python2|" "${pkgdir}/usr/share/apps/kword/scripts/extensions/oouno.py"
sed -i "s|/usr/bin/env python|/usr/bin/env python2|" "${pkgdir}/usr/share/apps/kword/scripts/extensions/importdoxyxml.py"
sed -i "s|/usr/bin/env python|/usr/bin/env python2|" "${pkgdir}/usr/share/apps/kword/scripts/extensions/onlinehelp.py"
}
#package_koffice-kword-doc(){
# pkgdesc="Documentation for kword"
# cd ${srcdir}/build/doc/kword
# make DESTDIR="${pkgdir}" install
#}
##### package apps done #####
#package_koffice-kchart(){
# pkgdesc="Charting tool for KDE"
# depends=('hicolor-icon-theme' 'koffice-interfaces' 'koffice-templates')
# optdepends=('koffice-filters: import/export filters')
# install=koffice.install
# cd "${srcdir}/build/kchart"
# make DESTDIR="${pkgdir}" install
#}
#package_koffice-kchart-doc(){
# pkgdesc="Documentation for kchart"
# cd "${srcdir}/build/doc/kchart"
# make DESTDIR="${pkgdir}" install
#}
#package_koffice-kdgantt(){
# pkgdesc="Gantt for KDE"
# cd "${srcdir}/build/kdgantt"
# make DESTDIR="${pkgdir}" install
#}
package_koffice-handbook() {
pkgdesc="Documentation for koffice"
cd "${srcdir}/build/doc/koffice"
make DESTDIR="${pkgdir}" install
}
package_koffice-thesaurus-doc(){
pkgdesc="Documentation for koffice-thesaurus"
cd "${srcdir}/build/doc/thesaurus"
make DESTDIR="${pkgdir}" install
}

View file

@ -0,0 +1,11 @@
post_install() {
update-mime-database usr/share/mime &> /dev/null
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

23
extra/koffice/gcc46.patch Normal file
View file

@ -0,0 +1,23 @@
diff -up koffice-2.3.2/krita/plugins/formats/exr/exr_converter.cc.gcc46 koffice-2.3.2/krita/plugins/formats/exr/exr_converter.cc
--- koffice-2.3.2/krita/plugins/formats/exr/exr_converter.cc.gcc46 2011-02-17 06:13:40.000000000 -0600
+++ koffice-2.3.2/krita/plugins/formats/exr/exr_converter.cc 2011-02-19 21:15:56.597142885 -0600
@@ -80,6 +80,9 @@ ImageType imfTypeToKisType(Imf::PixelTyp
return IT_FLOAT16;
case Imf::FLOAT:
return IT_FLOAT32;
+ default:
+ // shouldn't reach here
+ return IT_UNSUPPORTED;
}
}
@@ -93,6 +96,9 @@ const KoColorSpace* kisTypeToColorSpace(
case IT_UNKNOWN:
case IT_UNSUPPORTED:
return 0;
+ default:
+ // shouldn't reach here
+ return 0;
}
}

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,12 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,13 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-mime-database usr/share/mime &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,10 @@
--- koffice-2.3.3/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp 2011-02-17 13:10:38.000000000 +0100
+++ koffice-2.3.3/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp 2011-09-08 15:03:31.932039128 +0200
@@ -150,7 +150,6 @@ QDebug operator<<(QDebug dbg, const KDCh
<< "visible="<<ba.isVisible()
<< "brush="<<ba.brush()
<< "pixmapmode="<<ba.pixmapMode()
- << "pixmap="<<ba.pixmap()
<< ")";
return dbg;
}