mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-armv5 to 4.8.14-2
This commit is contained in:
parent
3ec32cf965
commit
3d4070ff4e
5 changed files with 33 additions and 43 deletions
|
@ -1,14 +1,14 @@
|
|||
From 93f953bb8e351b2fad9c03514acf511dbb8390d8 Mon Sep 17 00:00:00 2001
|
||||
From 4f600e3fc66f456687d66b071f51d0d682c6ecc0 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index dc989a8..912be75 100644
|
||||
index 831aa33..0362554 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -60,6 +60,7 @@
|
||||
|
@ -19,7 +19,7 @@ index dc989a8..912be75 100644
|
|||
|
||||
#define CARRIER_CHECK_DELAY (2 * HZ)
|
||||
|
||||
@@ -80,6 +81,10 @@ static bool turbo_mode = true;
|
||||
@@ -82,6 +83,10 @@ static bool turbo_mode = true;
|
||||
module_param(turbo_mode, bool, 0644);
|
||||
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
||||
|
||||
|
@ -30,7 +30,7 @@ index dc989a8..912be75 100644
|
|||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||
u32 *data, int in_pm)
|
||||
{
|
||||
@@ -809,8 +814,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
@@ -910,8 +915,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
|
||||
}
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From a4030e559273b194d3d9e37a79a1e68c846a237b Mon Sep 17 00:00:00 2001
|
||||
From fb613ee2c38b0043c16a429018906eb660638919 Mon Sep 17 00:00:00 2001
|
||||
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
|
||||
Date: Mon, 12 Aug 2013 10:36:25 -0500
|
||||
Subject: [PATCH 1/3] at91: ariag25 updates
|
||||
Subject: [PATCH 2/3] at91: ariag25 updates
|
||||
|
||||
v2: dropped at91sam9x5 usart fix, as merged mainline
|
||||
|
|
@ -1,19 +1,19 @@
|
|||
From 13e3a8ae551398e6d300600b83cddc8a87dfbbb5 Mon Sep 17 00:00:00 2001
|
||||
From 32d36a42a6e572a27e0531d08442c8622bdeb2f5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Jun 2015 13:46:30 -0600
|
||||
Subject: [PATCH 2/3] at91: arietta-g25 support
|
||||
Subject: [PATCH 3/3] at91: arietta-g25 support
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 2 +
|
||||
arch/arm/boot/dts/at91-arietta128.dts | 169 ++++++++++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/at91-arietta256.dts | 169 ++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 340 insertions(+)
|
||||
arch/arm/boot/dts/at91-arietta128.dts | 165 ++++++++++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/at91-arietta256.dts | 165 ++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 332 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/at91-arietta128.dts
|
||||
create mode 100644 arch/arm/boot/dts/at91-arietta256.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index faacd52..3992360 100644
|
||||
index c558ba7..317310c 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -36,6 +36,8 @@ dtb-$(CONFIG_SOC_AT91SAM9) += \
|
||||
|
@ -27,10 +27,10 @@ index faacd52..3992360 100644
|
|||
at91-kizboxmini.dtb \
|
||||
diff --git a/arch/arm/boot/dts/at91-arietta128.dts b/arch/arm/boot/dts/at91-arietta128.dts
|
||||
new file mode 100644
|
||||
index 0000000..e43533d
|
||||
index 0000000..3fb8657
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/at91-arietta128.dts
|
||||
@@ -0,0 +1,169 @@
|
||||
@@ -0,0 +1,165 @@
|
||||
+/*
|
||||
+ * acme-arietta.dts - Device Tree file for Arietta G25
|
||||
+ * Generated by http://dts.acmesystems.it/arietta
|
||||
|
@ -136,10 +136,6 @@ index 0000000..e43533d
|
|||
+ atmel,adc-res = <8 10>;
|
||||
+ atmel,adc-res-names = "lowres", "highres";
|
||||
+ atmel,adc-use-res = "highres";
|
||||
+ trigger@0 {
|
||||
+ trigger-name = "continuous";
|
||||
+ trigger-value = <0x6>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ssc0: ssc@f0010000 {
|
||||
|
@ -202,10 +198,10 @@ index 0000000..e43533d
|
|||
+};
|
||||
diff --git a/arch/arm/boot/dts/at91-arietta256.dts b/arch/arm/boot/dts/at91-arietta256.dts
|
||||
new file mode 100644
|
||||
index 0000000..cbae789
|
||||
index 0000000..34f0ac9
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/at91-arietta256.dts
|
||||
@@ -0,0 +1,169 @@
|
||||
@@ -0,0 +1,165 @@
|
||||
+/*
|
||||
+ * acme-arietta.dts - Device Tree file for Arietta G25
|
||||
+ * Generated by http://dts.acmesystems.it/arietta
|
||||
|
@ -311,10 +307,6 @@ index 0000000..cbae789
|
|||
+ atmel,adc-res = <8 10>;
|
||||
+ atmel,adc-res-names = "lowres", "highres";
|
||||
+ atmel,adc-use-res = "highres";
|
||||
+ trigger@0 {
|
||||
+ trigger-name = "continuous";
|
||||
+ trigger-value = <0x6>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ssc0: ssc@f0010000 {
|
|
@ -8,7 +8,7 @@ _srcname=linux-4.8
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 multi-platform"
|
||||
pkgver=4.8.14
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -16,16 +16,16 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
|||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
'0001-at91-ariag25-updates.patch'
|
||||
'0002-at91-arietta-g25-support.patch'
|
||||
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0002-at91-ariag25-updates.patch'
|
||||
'0003-at91-arietta-g25-support.patch'
|
||||
'config')
|
||||
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
||||
'b8001f580c4da45ee7ae8d928275cf97'
|
||||
'080675211923f58fa49a21985641b3f0'
|
||||
'43d2441c34362094c50247640e83bacd'
|
||||
'647524ddf6881cf75c87f5e8a1ea57a4'
|
||||
'04e8b83be4eafd9c9646d5bec6d5a772')
|
||||
'8effa2a3ad3f2f4383dbc66a19f6f364'
|
||||
'cb5aa24e94ee13ae9ac7d2f05431fae6'
|
||||
'd735d353b37df63ae975bc262ec39ace'
|
||||
'97bc971c797f3fe3a90f65ff5cac51fb')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -34,9 +34,9 @@ prepare() {
|
|||
git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-at91-ariag25-updates.patch
|
||||
git apply ../0002-at91-arietta-g25-support.patch
|
||||
git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0002-at91-ariag25-updates.patch
|
||||
git apply ../0003-at91-arietta-g25-support.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
@ -109,13 +109,11 @@ _package() {
|
|||
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf "${pkgdir}/lib/firmware"
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "${pkgdir}" -name '*.ko' |xargs -P 2 -n 1 gzip -9
|
||||
# make room for external modules
|
||||
ln -s "../extramodules-${_basekernel}-${_kernelname:-ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
||||
ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
||||
# add real version for building modules and running depmod from post_install/upgrade
|
||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}"
|
||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}/version"
|
||||
|
||||
# Now we call depmod...
|
||||
depmod -b "$pkgdir" -F System.map "$_kernver"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.8.0-rc7-1 Kernel Configuration
|
||||
# Linux/arm 4.8.14-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -4538,7 +4538,7 @@ CONFIG_AD7793=m
|
|||
CONFIG_AD7887=m
|
||||
CONFIG_AD7923=m
|
||||
CONFIG_AD799X=m
|
||||
CONFIG_AT91_ADC=y
|
||||
CONFIG_AT91_ADC=m
|
||||
CONFIG_AT91_SAMA5D2_ADC=m
|
||||
CONFIG_CC10001_ADC=m
|
||||
CONFIG_HI8435=m
|
||||
|
|
Loading…
Reference in a new issue