mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Add core/linux-rpi-16k
New kernel package providing 16k framesize for bcm2712/RPi5. Very similar to linux-rpi but built off bcm2712_defconfig. Will work with Pi5 ONLY/will not boot on lower models. Since RPi Foundation has announced the 6.6 move[1] in the near future, just start tracking that branch now. 1. https://forums.raspberrypi.com/viewtopic.php?t=361116
This commit is contained in:
parent
287cc00803
commit
3d631704a8
10 changed files with 9745 additions and 0 deletions
|
@ -0,0 +1,29 @@
|
|||
From 988f69b247fa3a1b70876395342aeb8c7dc2e834 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <graysky@archlinux.us>
|
||||
Date: Mon, 7 Dec 2020 13:03:40 -0500
|
||||
Subject: [PATCH] Make /proc/cpuinfo consistent on arm64 and arm
|
||||
|
||||
Signed-off-by: graysky <graysky@archlinux.us>
|
||||
---
|
||||
arch/arm64/kernel/cpuinfo.c | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/arch/arm64/kernel/cpuinfo.c b/arch/arm64/kernel/cpuinfo.c
|
||||
index 721350d21074..88e2b8fcd7e6 100644
|
||||
--- a/arch/arm64/kernel/cpuinfo.c
|
||||
+++ b/arch/arm64/kernel/cpuinfo.c
|
||||
@@ -153,9 +153,8 @@ static int c_show(struct seq_file *m, void *v)
|
||||
* "processor". Give glibc what it expects.
|
||||
*/
|
||||
seq_printf(m, "processor\t: %d\n", i);
|
||||
- if (compat)
|
||||
- seq_printf(m, "model name\t: ARMv8 Processor rev %d (%s)\n",
|
||||
- MIDR_REVISION(midr), COMPAT_ELF_PLATFORM);
|
||||
+ seq_printf(m, "model name\t: ARMv8 Processor rev %d (%s)\n",
|
||||
+ MIDR_REVISION(midr), COMPAT_ELF_PLATFORM);
|
||||
|
||||
seq_printf(m, "BogoMIPS\t: %lu.%02lu\n",
|
||||
loops_per_jiffy / (500000UL/HZ),
|
||||
--
|
||||
2.29.2
|
||||
|
11
core/linux-rpi-16k/60-linux.hook
Normal file
11
core/linux-rpi-16k/60-linux.hook
Normal file
|
@ -0,0 +1,11 @@
|
|||
[Trigger]
|
||||
Type = File
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/lib/modules/%KERNVER%/*
|
||||
|
||||
[Action]
|
||||
Description = Updating %PKGBASE% module dependencies...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/depmod %KERNVER%
|
13
core/linux-rpi-16k/90-linux.hook
Normal file
13
core/linux-rpi-16k/90-linux.hook
Normal file
|
@ -0,0 +1,13 @@
|
|||
[Trigger]
|
||||
Type = File
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Target = boot/kernel.img
|
||||
Target = boot/kernel7.img
|
||||
Target = boot/kernel8.img
|
||||
Target = usr/lib/initcpio/*
|
||||
|
||||
[Action]
|
||||
Description = Updating %PKGBASE% initcpios...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/mkinitcpio -p %PKGBASE%
|
259
core/linux-rpi-16k/PKGBUILD
Normal file
259
core/linux-rpi-16k/PKGBUILD
Normal file
|
@ -0,0 +1,259 @@
|
|||
# Maintainer: graysky <graysky@archlinux.us>
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# Maintainer: Oleg Rakhmanov <oleg@archlinuxarm.org>
|
||||
# Maintainer: Dave Higham <pepedog@archlinuxarm.org>
|
||||
# Contributer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
|
||||
pkgbase=linux-rpi-16k
|
||||
_commit=24ec6335f52e1fe3a895a1a2675200f452694923
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_regen=
|
||||
pkgver=6.6.5
|
||||
pkgrel=1
|
||||
pkgdesc='Linux'
|
||||
url="https://github.com/raspberrypi/linux"
|
||||
arch=(aarch64)
|
||||
license=(GPL2)
|
||||
makedepends=(
|
||||
bc
|
||||
kmod
|
||||
inetutils
|
||||
)
|
||||
options=('!strip')
|
||||
source=("linux-$pkgver-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
||||
cmdline.txt
|
||||
config.txt
|
||||
config8
|
||||
0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
|
||||
linux.preset
|
||||
60-linux.hook
|
||||
90-linux.hook
|
||||
archarm.diffconfig
|
||||
)
|
||||
md5sums=('b04201ec76e17e06a0a8cd45bb3bfaf0'
|
||||
'3bab7426d8c8818dda8353da3892a41f'
|
||||
'16c484af9f72b9275afcf83a6b8eab36'
|
||||
'4cbed2795359a053fce9098da15d4588'
|
||||
'f66a7ea3feb708d398ef57e4da4815e9'
|
||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||
'0a5f16bfec6ad982a2f6782724cca8ba'
|
||||
'441ec084c47cddc53e592fb0cbce4edf'
|
||||
'c8f84694321e249492c80149833671d7')
|
||||
|
||||
# setup vars
|
||||
_kernel=kernel8.img KARCH=arm64 _image=Image _config=config8
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# consistent behavior of lscpu on arm/arm64
|
||||
patch -p1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
|
||||
|
||||
echo "Setting version..."
|
||||
echo "-$pkgrel" > localversion.10-pkgrel
|
||||
echo "${pkgbase#linux}" > localversion.20-pkgname
|
||||
|
||||
if [[ $_regen -eq 1 ]]; then
|
||||
# useful on two point releases to keep shit straight
|
||||
echo "Applying custom shit to bcm2712_defconfig"
|
||||
make bcm2712_defconfig
|
||||
cat ../archarm.diffconfig >> .config
|
||||
make oldconfig
|
||||
sed '/^CONFIG_LOCALVERSION=/s,.*$,CONFIG_LOCALVERSION="-ARCH",' .config >$startdir/newconfig.$_config
|
||||
echo "verify that newconfig.$_config is fit for purpose then redefine $_config"
|
||||
exit
|
||||
else
|
||||
make bcm2712_defconfig
|
||||
make -s kernelrelease | sed 's/rpi-16k.*$/rpi-16k-ARCH/' > version
|
||||
make mrproper
|
||||
echo "Setting config..."
|
||||
cp ../"$_config" .config
|
||||
make olddefconfig
|
||||
diff -u ../"$_config" .config || :
|
||||
echo "Prepared $pkgbase version $(<version)"
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
export KCFLAGS=' -mcpu=cortex-a76'
|
||||
export KCPPFLAGS=' -mcpu=cortex-a76'
|
||||
|
||||
make "$_image" modules dtbs
|
||||
}
|
||||
|
||||
_package() {
|
||||
pkgdesc="RPi Foundation patched Linux kernel and modules with 16k pagesize for bcm2712/RPi5 ONLY"
|
||||
depends=(
|
||||
coreutils
|
||||
firmware-raspberrypi
|
||||
kmod
|
||||
linux-firmware
|
||||
'mkinitcpio>=0.7'
|
||||
)
|
||||
optdepends=(
|
||||
'wireless-regdb: to set the correct wireless channels of your country'
|
||||
)
|
||||
provides=(
|
||||
linux="${pkgver}"
|
||||
WIREGUARD-MODULE
|
||||
)
|
||||
conflicts=(
|
||||
linux
|
||||
linux-rpi
|
||||
uboot-raspberrypi
|
||||
)
|
||||
install=${pkgname}.install
|
||||
backup=(
|
||||
boot/config.txt
|
||||
boot/cmdline.txt
|
||||
)
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
|
||||
|
||||
# Used by mkinitcpio to name the kernel
|
||||
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
|
||||
|
||||
echo "Installing modules..."
|
||||
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
|
||||
DEPMOD=/doesnt/exist modules_install # Suppress depmod
|
||||
|
||||
# remove build link
|
||||
rm -f "$modulesdir"/build
|
||||
|
||||
echo "Installing Arch ARM specific stuff..."
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
make INSTALL_DTBS_PATH="${pkgdir}/boot" dtbs_install
|
||||
|
||||
if [[ $CARCH == "aarch64" ]]; then
|
||||
# drop hard-coded devicetree=foo.dtb in /boot/config.txt for
|
||||
# autodetected load of supported of models at boot
|
||||
find "${pkgdir}/boot/broadcom" -type f -print0 | xargs -0 mv -t "${pkgdir}/boot"
|
||||
rmdir "${pkgdir}/boot/broadcom"
|
||||
fi
|
||||
|
||||
# remove unneeded dtb files since this package is only for RPi5
|
||||
for i in bcm2837 bcm2711 bcm2710; do
|
||||
rm "${pkgdir}/boot/$i"*.dtb
|
||||
done
|
||||
|
||||
cp arch/$KARCH/boot/$_image "${pkgdir}/boot/$_kernel"
|
||||
cp arch/$KARCH/boot/dts/overlays/README "${pkgdir}/boot/overlays"
|
||||
install -m644 ../config.txt "${pkgdir}/boot/config.txt"
|
||||
install -m644 ../cmdline.txt "${pkgdir}/boot"
|
||||
|
||||
# sed expression for following substitutions
|
||||
local _subst="
|
||||
s|%PKGBASE%|${pkgbase}|g
|
||||
s|%KERNVER%|$(<version)|g
|
||||
"
|
||||
|
||||
# install mkinitcpio preset file
|
||||
sed "${_subst}" ../linux.preset |
|
||||
install -Dm644 /dev/stdin "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
|
||||
|
||||
# install pacman hooks
|
||||
sed "${_subst}" ../60-linux.hook |
|
||||
install -Dm644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/60-${pkgbase}.hook"
|
||||
sed "${_subst}" ../90-linux.hook |
|
||||
install -Dm644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/90-${pkgbase}.hook"
|
||||
}
|
||||
|
||||
_package-headers() {
|
||||
pkgdesc="RPi Foundation header and scripts for building modules for Linux kernel"
|
||||
provides=("linux-headers=${pkgver}")
|
||||
conflicts=('linux-headers' 'linux-rpi-headers')
|
||||
|
||||
cd ${_srcname}
|
||||
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
|
||||
|
||||
echo "Installing build files..."
|
||||
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
|
||||
localversion.* version
|
||||
install -Dt "$builddir/kernel" -m644 kernel/Makefile
|
||||
install -Dt "$builddir/arch/$KARCH" -m644 "arch/$KARCH/Makefile"
|
||||
cp -t "$builddir" -a scripts
|
||||
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p "$builddir"/{fs/xfs,mm}
|
||||
|
||||
echo "Installing headers..."
|
||||
cp -t "$builddir" -a include
|
||||
cp -t "$builddir/arch/$KARCH" -a "arch/$KARCH/include"
|
||||
install -Dt "$builddir/arch/$KARCH/kernel" -m644 "arch/$KARCH/kernel/asm-offsets.s"
|
||||
|
||||
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
|
||||
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
|
||||
|
||||
# https://bugs.archlinux.org/task/13146
|
||||
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
|
||||
|
||||
# https://bugs.archlinux.org/task/20402
|
||||
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
|
||||
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
|
||||
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
|
||||
|
||||
# https://bugs.archlinux.org/task/71392
|
||||
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
|
||||
|
||||
echo "Installing KConfig files..."
|
||||
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
|
||||
|
||||
echo "Removing unneeded architectures..."
|
||||
local _arch
|
||||
for _arch in "$builddir"/arch/*/; do
|
||||
if [[ $CARCH == "aarch64" ]]; then
|
||||
[[ $_arch = */"$KARCH"/ || $_arch == */arm/ ]] && continue
|
||||
else
|
||||
[[ $_arch = */"$KARCH"/ ]] && continue
|
||||
fi
|
||||
echo "Removing $(basename "$_arch")"
|
||||
rm -r "$_arch"
|
||||
done
|
||||
|
||||
echo "Symlinking common aliases..."
|
||||
# https://archlinuxarm.org/forum/viewtopic.php?f=60&t=16354
|
||||
ln -sr arm "$builddir/arch/armv7h"
|
||||
ln -sr arm "$builddir/arch/armv7l"
|
||||
ln -sr arm64 "$builddir/arch/aarch64"
|
||||
|
||||
echo "Removing documentation..."
|
||||
rm -r "$builddir/Documentation"
|
||||
|
||||
echo "Removing broken symlinks..."
|
||||
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
|
||||
|
||||
echo "Removing loose objects..."
|
||||
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
|
||||
|
||||
echo "Stripping build tools..."
|
||||
local file
|
||||
while read -rd '' file; do
|
||||
case "$(file -Sib "$file")" in
|
||||
application/x-sharedlib\;*) # Libraries (.so)
|
||||
strip -v $STRIP_SHARED "$file" ;;
|
||||
application/x-archive\;*) # Libraries (.a)
|
||||
strip -v $STRIP_STATIC "$file" ;;
|
||||
application/x-executable\;*) # Binaries
|
||||
strip -v $STRIP_BINARIES "$file" ;;
|
||||
application/x-pie-executable\;*) # Relocatable binaries
|
||||
strip -v $STRIP_SHARED "$file" ;;
|
||||
esac
|
||||
done < <(find "$builddir" -type f -perm -u+x -print0)
|
||||
|
||||
echo "Adding symlink..."
|
||||
mkdir -p "$pkgdir/usr/src"
|
||||
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
|
||||
}
|
||||
|
||||
pkgname=("${pkgbase}" "${pkgbase}-headers")
|
||||
for _p in ${pkgname[@]}; do
|
||||
eval "package_${_p}() {
|
||||
_package${_p#${pkgbase}}
|
||||
}"
|
||||
done
|
||||
|
||||
# vim:set ts=8 sts=2 sw=2 et:
|
173
core/linux-rpi-16k/archarm.diffconfig
Normal file
173
core/linux-rpi-16k/archarm.diffconfig
Normal file
|
@ -0,0 +1,173 @@
|
|||
CONFIG_TASK_DELAY_ACCT=y
|
||||
# CONFIG_PSI_DEFAULT_DISABLED is not set
|
||||
CONFIG_IKCONFIG=y
|
||||
CONFIG_CHECKPOINT_RESTORE=y
|
||||
CONFIG_MEMCG_SWAP=y
|
||||
CONFIG_NR_CPUS=4
|
||||
CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL=y
|
||||
# CONFIG_MODVERSIONS is not set
|
||||
# CONFIG_MODULE_SRCVERSION_ALL is not set
|
||||
CONFIG_ARCH_ENABLE_HUGEPAGE_MIGRATION=y
|
||||
CONFIG_PACKET_DIAG=m
|
||||
CONFIG_KSM=y
|
||||
CONFIG_ARCH_SUPPORTS_ACPI=y
|
||||
CONFIG_DMIID=y
|
||||
CONFIG_UNIX_DIAG=m
|
||||
CONFIG_INET_UDP_DIAG=m
|
||||
CONFIG_F2FS_FS_COMPRESSION=y
|
||||
CONFIG_F2FS_FS_LZO=y
|
||||
CONFIG_F2FS_FS_LZORLE=y
|
||||
CONFIG_F2FS_FS_LZ4=y
|
||||
CONFIG_F2FS_FS_LZ4HC=y
|
||||
CONFIG_F2FS_FS_ZSTD=y
|
||||
CONFIG_EXPORTFS_BLOCK_OPS=y
|
||||
CONFIG_FS_VERITY=y
|
||||
CONFIG_SQUASHFS_LZ4=y
|
||||
CONFIG_SQUASHFS_ZSTD=y
|
||||
CONFIG_MEMCG_SWAP=y
|
||||
CONFIG_BSD_DISKLABEL=y
|
||||
CONFIG_MINIX_SUBPARTITION=y
|
||||
CONFIG_SOLARIS_X86_PARTITION=y
|
||||
CONFIG_UNIXWARE_DISKLABEL=y
|
||||
CONFIG_PADATA=y
|
||||
CONFIG_KSM=y
|
||||
CONFIG_XFRM_MIGRATE=y
|
||||
CONFIG_NET_KEY_MIGRATE=y
|
||||
CONFIG_TCP_CONG_HSTCP=m
|
||||
CONFIG_TCP_CONG_HYBLA=m
|
||||
CONFIG_TCP_CONG_VEGAS=m
|
||||
CONFIG_TCP_CONG_NV=m
|
||||
CONFIG_TCP_CONG_SCALABLE=m
|
||||
CONFIG_TCP_CONG_LP=m
|
||||
CONFIG_TCP_CONG_VENO=m
|
||||
CONFIG_TCP_CONG_YEAH=m
|
||||
CONFIG_TCP_CONG_ILLINOIS=m
|
||||
CONFIG_TCP_CONG_DCTCP=m
|
||||
CONFIG_TCP_CONG_CDG=m
|
||||
CONFIG_TCP_MD5SIG=y
|
||||
CONFIG_IPV6_OPTIMISTIC_DAD=y
|
||||
CONFIG_NFT_BRIDGE_META=m
|
||||
CONFIG_BRIDGE_VLAN_FILTERING=y
|
||||
CONFIG_MRP=m
|
||||
CONFIG_HSR=m
|
||||
CONFIG_BPF_STREAM_PARSER=y
|
||||
CONFIG_NLMON=m
|
||||
CONFIG_IGC=m
|
||||
CONFIG_MVMDIO=m
|
||||
CONFIG_WIZNET_W5300=m
|
||||
CONFIG_BCM87XX_PHY=m
|
||||
CONFIG_CAN_8DEV_USB=m
|
||||
CONFIG_CAN_KVASER_USB=m
|
||||
CONFIG_DRM_PL111=m
|
||||
CONFIG_USB_SERIAL_SIMPLE=m
|
||||
CONFIG_USB_SERIAL_MXUPORT=m
|
||||
CONFIG_USB_CHAOSKEY=m
|
||||
CONFIG_USB_F_TCM=m
|
||||
CONFIG_USB_CONFIGFS_F_TCM=y
|
||||
CONFIG_RTC_DRV_RX6110=m
|
||||
|
||||
CONFIG_IOSCHED_BFQ=y
|
||||
CONFIG_CLEANCACHE=y
|
||||
CONFIG_ZSWAP=y
|
||||
CONFIG_ZSWAP_COMPRESSOR_DEFAULT_LZO=y
|
||||
CONFIG_ZSWAP_COMPRESSOR_DEFAULT="lzo"
|
||||
CONFIG_AT803X_PHY=m
|
||||
CONFIG_MICREL_KS8995MA=m
|
||||
CONFIG_USB_NET_CH9200=m
|
||||
CONFIG_WCN36XX=m
|
||||
CONFIG_ATH10K=m
|
||||
CONFIG_IWLWIFI=m
|
||||
CONFIG_JOYSTICK_ANALOG=m
|
||||
CONFIG_JOYSTICK_A3D=m
|
||||
CONFIG_JOYSTICK_ADI=m
|
||||
CONFIG_JOYSTICK_COBRA=m
|
||||
CONFIG_JOYSTICK_GF2K=m
|
||||
CONFIG_JOYSTICK_GRIP=m
|
||||
CONFIG_JOYSTICK_GRIP_MP=m
|
||||
CONFIG_JOYSTICK_GUILLEMOT=m
|
||||
CONFIG_JOYSTICK_INTERACT=m
|
||||
CONFIG_JOYSTICK_SIDEWINDER=m
|
||||
CONFIG_JOYSTICK_TMDC=m
|
||||
CONFIG_JOYSTICK_IFORCE_232=m
|
||||
CONFIG_JOYSTICK_WARRIOR=m
|
||||
CONFIG_JOYSTICK_MAGELLAN=m
|
||||
CONFIG_JOYSTICK_SPACEORB=m
|
||||
CONFIG_JOYSTICK_SPACEBALL=m
|
||||
CONFIG_JOYSTICK_STINGER=m
|
||||
CONFIG_JOYSTICK_TWIDJOY=m
|
||||
CONFIG_JOYSTICK_ZHENHUA=m
|
||||
CONFIG_JOYSTICK_AS5011=m
|
||||
CONFIG_JOYSTICK_JOYDUMP=m
|
||||
CONFIG_TOUCHSCREEN_AD7877=m
|
||||
CONFIG_TOUCHSCREEN_AD7879=m
|
||||
CONFIG_TOUCHSCREEN_AD7879_I2C=m
|
||||
CONFIG_TOUCHSCREEN_AD7879_SPI=m
|
||||
CONFIG_TOUCHSCREEN_AR1021_I2C=m
|
||||
CONFIG_TOUCHSCREEN_ATMEL_MXT=m
|
||||
CONFIG_TOUCHSCREEN_AUO_PIXCIR=m
|
||||
CONFIG_TOUCHSCREEN_BU21013=m
|
||||
CONFIG_TOUCHSCREEN_CHIPONE_ICN8318=m
|
||||
CONFIG_TOUCHSCREEN_CY8CTMG110=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP_CORE=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP_I2C=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP_SPI=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP4_CORE=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP4_I2C=m
|
||||
CONFIG_TOUCHSCREEN_CYTTSP4_SPI=m
|
||||
CONFIG_TOUCHSCREEN_DYNAPRO=m
|
||||
CONFIG_TOUCHSCREEN_HAMPSHIRE=m
|
||||
CONFIG_TOUCHSCREEN_EETI=m
|
||||
CONFIG_TOUCHSCREEN_EGALAX_SERIAL=m
|
||||
CONFIG_TOUCHSCREEN_FUJITSU=m
|
||||
CONFIG_TOUCHSCREEN_GUNZE=m
|
||||
CONFIG_TOUCHSCREEN_EKTF2127=m
|
||||
CONFIG_TOUCHSCREEN_ELAN=m
|
||||
CONFIG_TOUCHSCREEN_ELO=m
|
||||
CONFIG_TOUCHSCREEN_WACOM_W8001=m
|
||||
CONFIG_TOUCHSCREEN_WACOM_I2C=m
|
||||
CONFIG_TOUCHSCREEN_MAX11801=m
|
||||
CONFIG_TOUCHSCREEN_MCS5000=m
|
||||
CONFIG_TOUCHSCREEN_MMS114=m
|
||||
CONFIG_TOUCHSCREEN_MELFAS_MIP4=m
|
||||
CONFIG_TOUCHSCREEN_INEXIO=m
|
||||
CONFIG_TOUCHSCREEN_MK712=m
|
||||
CONFIG_TOUCHSCREEN_PENMOUNT=m
|
||||
CONFIG_TOUCHSCREEN_TOUCHRIGHT=m
|
||||
CONFIG_TOUCHSCREEN_TOUCHWIN=m
|
||||
CONFIG_TOUCHSCREEN_PIXCIR=m
|
||||
CONFIG_TOUCHSCREEN_WDT87XX_I2C=m
|
||||
CONFIG_TOUCHSCREEN_TOUCHIT213=m
|
||||
CONFIG_TOUCHSCREEN_TSC_SERIO=m
|
||||
CONFIG_TOUCHSCREEN_TSC200X_CORE=m
|
||||
CONFIG_TOUCHSCREEN_TSC2004=m
|
||||
CONFIG_TOUCHSCREEN_TSC2005=m
|
||||
CONFIG_TOUCHSCREEN_TSC2007=m
|
||||
CONFIG_TOUCHSCREEN_RM_TS=m
|
||||
CONFIG_TOUCHSCREEN_SILEAD=m
|
||||
CONFIG_TOUCHSCREEN_SIS_I2C=m
|
||||
CONFIG_TOUCHSCREEN_ST1232=m
|
||||
CONFIG_TOUCHSCREEN_SX8654=m
|
||||
CONFIG_TOUCHSCREEN_TPS6507X=m
|
||||
CONFIG_TOUCHSCREEN_ZFORCE=m
|
||||
CONFIG_TOUCHSCREEN_ROHM_BU21023=m
|
||||
CONFIG_SENSORS_DS620=m
|
||||
CONFIG_SENSORS_HIH6130=m
|
||||
CONFIG_SENSORS_LTC2945=m
|
||||
CONFIG_SENSORS_LTC4222=m
|
||||
CONFIG_USB_AIRSPY=m
|
||||
CONFIG_USB_HACKRF=m
|
||||
CONFIG_USB_MSI2500=m
|
||||
CONFIG_RADIO_ADAPTERS=y
|
||||
CONFIG_RADIO_TEA575X=m
|
||||
CONFIG_RADIO_SI470X=m
|
||||
CONFIG_USB_SI470X=m
|
||||
CONFIG_USB_MR800=m
|
||||
CONFIG_USB_DSBR=m
|
||||
CONFIG_USB_RAREMONO=m
|
||||
CONFIG_LCD_CLASS_DEVICE=m
|
||||
CONFIG_BTRFS_FS=y
|
||||
CONFIG_QUOTA_NETLINK_INTERFACE=y
|
||||
CONFIG_QUOTA_TREE=y
|
||||
CONFIG_QFMT_V1=y
|
||||
CONFIG_QFMT_V2=y
|
||||
CONFIG_BLK_DEV_RBD=m
|
1
core/linux-rpi-16k/cmdline.txt
Normal file
1
core/linux-rpi-16k/cmdline.txt
Normal file
|
@ -0,0 +1 @@
|
|||
root=/dev/mmcblk0p2 rw rootwait console=serial0,115200 console=tty1 fsck.repair=yes
|
44
core/linux-rpi-16k/config.txt
Normal file
44
core/linux-rpi-16k/config.txt
Normal file
|
@ -0,0 +1,44 @@
|
|||
# For more options and information see:
|
||||
# http://rptl.io/configtxt
|
||||
|
||||
initramfs initramfs-linux.img followkernel
|
||||
|
||||
# Uncomment some or all of these to enable the optional hardware interfaces
|
||||
#dtparam=i2c_arm=on
|
||||
#dtparam=i2s=on
|
||||
#dtparam=spi=on
|
||||
|
||||
# Additional overlays and parameters are documented
|
||||
# /boot/firmware/overlays/README
|
||||
|
||||
# Automatically load overlays for detected cameras
|
||||
camera_auto_detect=1
|
||||
|
||||
# Automatically load overlays for detected DSI displays
|
||||
display_auto_detect=1
|
||||
|
||||
# Enable DRM VC4 V3D driver
|
||||
dtoverlay=vc4-kms-v3d
|
||||
max_framebuffers=2
|
||||
|
||||
# Uncomment if hdmi display is not detected and composite is being output
|
||||
#hdmi_force_hotplug=1
|
||||
|
||||
# Uncomment if you want to disable wifi or bluetooth respectively
|
||||
#dtoverlay=disable-wifi
|
||||
#dtoverlay=disable-bt
|
||||
|
||||
# Uncomment this to enable infrared communication.
|
||||
#dtoverlay=gpio-ir,gpio_pin=17
|
||||
#dtoverlay=gpio-ir-tx,gpio_pin=18
|
||||
|
||||
# Run as fast as firmware / board allows
|
||||
arm_boost=1
|
||||
|
||||
[cm4]
|
||||
# Enable host mode on the 2711 built-in XHCI USB controller.
|
||||
# This line should be removed if the legacy DWC2 controller is required
|
||||
# (e.g. for USB device mode) or if USB support is not required.
|
||||
otg_mode=1
|
||||
|
||||
[all]
|
9152
core/linux-rpi-16k/config8
Normal file
9152
core/linux-rpi-16k/config8
Normal file
File diff suppressed because it is too large
Load diff
53
core/linux-rpi-16k/linux-rpi-16k.install
Normal file
53
core/linux-rpi-16k/linux-rpi-16k.install
Normal file
|
@ -0,0 +1,53 @@
|
|||
disable_cma() {
|
||||
if [[ -f /boot/config.txt && $(grep '^cma' /boot/config.txt) != '' ]]; then
|
||||
echo ">>> You appear to have dynamic memory (CMA) enabled, which is currently broken"
|
||||
echo ">>> in newer kernels and will cause many issues if left enabled."
|
||||
echo ">>> Disabling that for you now."
|
||||
sed -i 's/^cma_/#cma_/g' /boot/config.txt
|
||||
fi
|
||||
}
|
||||
|
||||
correct_fstab() {
|
||||
# starting with v5.10.y, fstab requires a padded zero in the path to /boot
|
||||
if [[ -f /etc/fstab ]]; then
|
||||
if grep -q mmcblk1p1 /etc/fstab; then
|
||||
sed -i 's/mmcblk1p1/mmcblk0p1/' /etc/fstab
|
||||
fi
|
||||
fi
|
||||
}
|
||||
|
||||
post_install () {
|
||||
disable_cma
|
||||
|
||||
# coming from linux-aarch64 also needs a padded zero in the path to /boot
|
||||
correct_fstab
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
|
||||
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
|
||||
echo "WARNING: /boot appears to be a separate partition but is not mounted."
|
||||
echo " You probably just broke your system. Congratulations."
|
||||
fi
|
||||
fi
|
||||
|
||||
disable_cma
|
||||
|
||||
if [ "$(vercmp $2 3.18.3)" -lt 0 ]; then
|
||||
echo "________________________________________________________________________________"
|
||||
echo ""
|
||||
echo "WARNING: This kernel provides updated config.txt and cmdline.txt files."
|
||||
echo " Check for pacnew files in /boot and merge or replace the existing files"
|
||||
echo " with the new versions."
|
||||
echo "________________________________________________________________________________"
|
||||
echo ""
|
||||
fi
|
||||
|
||||
if [ "$(vercmp $2 5.10.0)" -lt 0 ]; then
|
||||
correct_fstab
|
||||
fi
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
rm -f boot/initramfs-linux.img
|
||||
}
|
10
core/linux-rpi-16k/linux.preset
Normal file
10
core/linux-rpi-16k/linux.preset
Normal file
|
@ -0,0 +1,10 @@
|
|||
# mkinitcpio preset file for the '%PKGBASE%' package
|
||||
|
||||
ALL_config="/etc/mkinitcpio.conf"
|
||||
ALL_kver="%KERNVER%"
|
||||
|
||||
PRESETS=('default')
|
||||
|
||||
#default_config="/etc/mkinitcpio.conf"
|
||||
default_image="/boot/initramfs-linux.img"
|
||||
#default_options=""
|
Loading…
Reference in a new issue