mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
alarm/uboot-usbarmory to 2016.09-1
This commit is contained in:
parent
bd83e3a317
commit
3d749b1ad9
3 changed files with 25 additions and 12 deletions
|
@ -1,4 +1,4 @@
|
|||
From bc3a7ffa4219dd717b88cf2b38d7476bb9fa2efb Mon Sep 17 00:00:00 2001
|
||||
From d3e9ed9d66d16bd9beb17f9ab7970499ef039adb Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 27 Jun 2015 12:37:40 -0600
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
@ -8,18 +8,18 @@ Subject: [PATCH] arch linux arm modifications
|
|||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/include/configs/usbarmory.h b/include/configs/usbarmory.h
|
||||
index 8568663..8abae4b 100644
|
||||
index 23092db..995532a 100644
|
||||
--- a/include/configs/usbarmory.h
|
||||
+++ b/include/configs/usbarmory.h
|
||||
@@ -22,6 +22,8 @@
|
||||
@@ -23,6 +23,8 @@
|
||||
|
||||
#include <config_distro_defaults.h>
|
||||
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+
|
||||
/* U-Boot commands */
|
||||
|
||||
/* U-Boot environment */
|
||||
#define CONFIG_ENV_OFFSET (6 * 64 * 1024)
|
||||
#define CONFIG_ENV_SIZE (8 * 1024)
|
||||
--
|
||||
2.9.0
|
||||
2.10.0
|
||||
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-usbarmory
|
||||
pkgver=2016.07
|
||||
pkgver=2016.09
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for USB armory"
|
||||
arch=('armv7h')
|
||||
|
@ -18,9 +18,9 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
|||
'0001-arch-linux-arm-modifications.patch'
|
||||
'boot.txt'
|
||||
'mkscr')
|
||||
md5sums=('425a3fa610a7d972e5092a0e92276c70'
|
||||
'6929dfaf24a8f8516149e65e64d7ada4'
|
||||
'3e9799661eec04d1ce0f3fe20ed21838'
|
||||
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1'
|
||||
'99bdb7f9887216634e688888d878efcb'
|
||||
'45535e1c506ce5083bb916492b6d820f'
|
||||
'021623a04afd29ac3f368977140cfbfd')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,12 +1,25 @@
|
|||
# After modifying, run ./mkscr
|
||||
|
||||
# Uncomment to set the USB OTG port to host mode (default is peripheral)
|
||||
#setenv otg_host yes
|
||||
|
||||
part uuid ${devtype} ${devnum}:${bootpart} uuid
|
||||
setenv bootargs console=ttyGS0,115200 console=${console} root=PARTUUID=${uuid} rw rootwait
|
||||
|
||||
if load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /boot/zImage; then
|
||||
if load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /boot/dtbs/${fdtfile}; then
|
||||
if test -n ${otg_host}; then
|
||||
echo USB OTG: Host mode
|
||||
fdt addr ${fdt_addr_r}
|
||||
fdt get value usbotg /__symbols__ usbotg
|
||||
fdt set ${usbotg} dr_mode host
|
||||
else
|
||||
echo USB OTG: Peripheral mode
|
||||
fi
|
||||
if load ${devtype} ${devnum}:${bootpart} ${ramdisk_addr_r} /boot/initramfs-linux.img; then
|
||||
bootz ${kernel_addr_r} ${ramdisk_addr_r}:${filesize} ${fdt_addr_r};
|
||||
else
|
||||
bootz ${kernel_addr_r} - ${fdt_addr_r};
|
||||
fi;
|
||||
fi;
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue