mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
copy extra/firefox package from upstream Arch
This commit is contained in:
parent
5b902311c7
commit
3d8d57a973
6 changed files with 250 additions and 0 deletions
81
extra/firefox/PKGBUILD
Normal file
81
extra/firefox/PKGBUILD
Normal file
|
@ -0,0 +1,81 @@
|
|||
# $Id: PKGBUILD 161877 2012-06-16 01:15:20Z ibiru $
|
||||
# Maintainer : Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=13.0.1
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib'
|
||||
'libnotify' 'desktop-file-utils' 'hicolor-icon-theme'
|
||||
'libvpx' 'libevent' 'nss>=3.13.3' 'hunspell' 'sqlite')
|
||||
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'wireless_tools' 'yasm' 'mesa'
|
||||
'autoconf2.13' 'libidl2' 'xorg-server-xvfb' 'imake' 'gcc4.6')
|
||||
optdepends=('wireless_tools: Location detection via available WiFi networks')
|
||||
url="http://www.mozilla.org/projects/firefox"
|
||||
install=firefox.install
|
||||
options=(!emptydirs)
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
|
||||
mozconfig firefox.desktop firefox-install-dir.patch vendor.js)
|
||||
md5sums=('82deadb501c7fc0e9fa6b025f51f05a1'
|
||||
'5644c7b42f51013e2023787938fa955e'
|
||||
'bdeb0380c7fae30dd0ead6d2d3bc5873'
|
||||
'594523c536a9be951b52c90dd85aff18'
|
||||
'0d053487907de4376d67d8f499c5502b')
|
||||
|
||||
build() {
|
||||
cd mozilla-release
|
||||
|
||||
cp ../mozconfig .mozconfig
|
||||
patch -Np1 -i ../firefox-install-dir.patch
|
||||
|
||||
# Fix PRE_RELEASE_SUFFIX
|
||||
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
|
||||
browser/base/Makefile.in
|
||||
|
||||
export CC=gcc-4.6
|
||||
export CXX=g++-4.6
|
||||
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/firefox"
|
||||
export PYTHON="/usr/bin/python2"
|
||||
export MOZ_MAKE_FLAGS="$MAKEFLAGS"
|
||||
unset MAKEFLAGS
|
||||
|
||||
# Enable PGO
|
||||
export MOZ_PGO=1
|
||||
export DISPLAY=:99
|
||||
Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
|
||||
|
||||
make -f client.mk build
|
||||
|
||||
kill $! || true
|
||||
}
|
||||
|
||||
package() {
|
||||
cd mozilla-release
|
||||
make -j1 -f client.mk DESTDIR="$pkgdir" install
|
||||
|
||||
install -m644 ../vendor.js "$pkgdir/usr/lib/firefox/defaults/pref"
|
||||
|
||||
for i in 16 22 24 32 48 256; do
|
||||
install -Dm644 browser/branding/official/default$i.png \
|
||||
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
|
||||
done
|
||||
|
||||
install -Dm644 ../firefox.desktop \
|
||||
"$pkgdir/usr/share/applications/firefox.desktop"
|
||||
|
||||
# Use system-provided dictionaries
|
||||
rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
|
||||
ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
|
||||
ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
|
||||
|
||||
# We don't want the development stuff
|
||||
rm -r "$pkgdir"/usr/{include,lib/firefox-devel,share/idl}
|
||||
|
||||
#workaround for now
|
||||
#https://bugzilla.mozilla.org/show_bug.cgi?id=658850
|
||||
ln -sf firefox "$pkgdir/usr/lib/firefox/firefox-bin"
|
||||
}
|
28
extra/firefox/firefox-install-dir.patch
Normal file
28
extra/firefox/firefox-install-dir.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff -Nur mozilla-release.orig/config/autoconf.mk.in mozilla-release/config/autoconf.mk.in
|
||||
--- mozilla-release.orig/config/autoconf.mk.in 2011-11-06 14:06:44.462920048 +0000
|
||||
+++ mozilla-release/config/autoconf.mk.in 2011-11-06 14:20:45.124169469 +0000
|
||||
@@ -68,8 +68,8 @@
|
||||
mandir = @mandir@
|
||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
|
||||
DIST = $(DEPTH)/dist
|
||||
LIBXUL_SDK = @LIBXUL_SDK@
|
||||
diff -Nur mozilla-release.orig/js/src/config/autoconf.mk.in mozilla-release/js/src/config/autoconf.mk.in
|
||||
--- mozilla-release.orig/js/src/config/autoconf.mk.in 2011-11-06 14:06:45.586263727 +0000
|
||||
+++ mozilla-release/js/src/config/autoconf.mk.in 2011-11-06 14:21:01.770993669 +0000
|
||||
@@ -61,8 +61,8 @@
|
||||
datadir = @datadir@
|
||||
mandir = @mandir@
|
||||
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
|
||||
TOP_DIST = @TOP_DIST@
|
||||
ifneq (,$(filter /%,$(TOP_DIST)))
|
81
extra/firefox/firefox.desktop
Normal file
81
extra/firefox/firefox.desktop
Normal file
|
@ -0,0 +1,81 @@
|
|||
[Desktop Entry]
|
||||
Name=Firefox
|
||||
Name[bn]=ফায়ারফক্স
|
||||
Name[eo]=Fajrovulpo
|
||||
Name[fi]=Firefox
|
||||
Name[pa]=ਫਾਇਰਫੋਕਸ
|
||||
Name[tg]=Рӯбоҳи оташин
|
||||
GenericName=Web Browser
|
||||
GenericName[af]=Web Blaaier
|
||||
GenericName[ar]=متصفح ويب
|
||||
GenericName[az]=Veb Səyyahı
|
||||
GenericName[bg]=Браузър
|
||||
GenericName[bn]=ওয়েব ব্রাউজার
|
||||
GenericName[br]=Furcher ar Gwiad
|
||||
GenericName[bs]=WWW Preglednik
|
||||
GenericName[ca]=Fullejador web
|
||||
GenericName[cs]=WWW prohlížeč
|
||||
GenericName[cy]=Porydd Gwe
|
||||
GenericName[da]=Browser
|
||||
GenericName[de]=Web-Browser
|
||||
GenericName[el]=Περιηγητής Ιστού
|
||||
GenericName[eo]=TTT-legilo
|
||||
GenericName[es]=Navegador web
|
||||
GenericName[et]=Veebilehitseja
|
||||
GenericName[eu]=Web arakatzailea
|
||||
GenericName[fa]=مرورگر وب
|
||||
GenericName[fi]=WWW-selain
|
||||
GenericName[fo]=Alnótsfar
|
||||
GenericName[fr]=Navigateur web
|
||||
GenericName[gl]=Navegador Web
|
||||
GenericName[he]=דפדפן אינטרנט
|
||||
GenericName[hi]=वेब ब्राउज़र
|
||||
GenericName[hr]=Web preglednik
|
||||
GenericName[hu]=Webböngésző
|
||||
GenericName[is]=Vafri
|
||||
GenericName[it]=Browser Web
|
||||
GenericName[ja]=ウェブブラウザ
|
||||
GenericName[ko]=웹 브라우저
|
||||
GenericName[lo]=ເວັບບຣາວເຊີ
|
||||
GenericName[lt]=Žiniatinklio naršyklė
|
||||
GenericName[lv]=Web Pārlūks
|
||||
GenericName[mk]=Прелистувач на Интернет
|
||||
GenericName[mn]=Веб-Хөтөч
|
||||
GenericName[nb]=Nettleser
|
||||
GenericName[nds]=Nettkieker
|
||||
GenericName[nl]=Webbrowser
|
||||
GenericName[nn]=Nettlesar
|
||||
GenericName[nso]=Seinyakisi sa Web
|
||||
GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
|
||||
GenericName[pl]=Przeglądarka WWW
|
||||
GenericName[pt]=Navegador Web
|
||||
GenericName[pt_BR]=Navegador Web
|
||||
GenericName[ro]=Navigator de web
|
||||
GenericName[ru]=Веб-браузер
|
||||
GenericName[se]=Fierpmádatlogan
|
||||
GenericName[sk]=Webový prehliadač
|
||||
GenericName[sl]=Spletni brskalnik
|
||||
GenericName[sr]=Веб претраживач
|
||||
GenericName[sr@Latn]=Veb pretraživač
|
||||
GenericName[ss]=Ibrawuza yeWeb
|
||||
GenericName[sv]=Webbläsare
|
||||
GenericName[ta]=வலை உலாவி
|
||||
GenericName[tg]=Тафсиргари вэб
|
||||
GenericName[th]=เว็บบราวเซอร์
|
||||
GenericName[tr]=Web Tarayıcı
|
||||
GenericName[uk]=Навігатор Тенет
|
||||
GenericName[uz]=Веб-браузер
|
||||
GenericName[ven]=Buronza ya Webu
|
||||
GenericName[vi]=Trình duyệt Web
|
||||
GenericName[wa]=Betchteu waibe
|
||||
GenericName[xh]=Umkhangeli zincwadi we Web
|
||||
GenericName[zh_CN]=网页浏览器
|
||||
GenericName[zh_TW]=網頁瀏覽器
|
||||
GenericName[zu]=Umcingi we-Web
|
||||
Exec=firefox %u
|
||||
Icon=firefox
|
||||
Terminal=false
|
||||
Type=Application
|
||||
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
|
||||
StartupNotify=true
|
||||
Categories=Network;WebBrowser;
|
13
extra/firefox/firefox.install
Normal file
13
extra/firefox/firefox.install
Normal file
|
@ -0,0 +1,13 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
||||
|
38
extra/firefox/mozconfig
Normal file
38
extra/firefox/mozconfig
Normal file
|
@ -0,0 +1,38 @@
|
|||
. $topsrcdir/browser/config/mozconfig
|
||||
|
||||
ac_add_options --prefix=/usr
|
||||
ac_add_options --libdir=/usr/lib
|
||||
|
||||
# System libraries
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
ac_add_options --with-system-jpeg
|
||||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-system-png
|
||||
ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
#ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-pixman
|
||||
ac_add_options --with-pthreads
|
||||
|
||||
# Features
|
||||
ac_add_options --enable-official-branding
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-gio
|
||||
#ac_add_options --enable-gstreamer
|
||||
|
||||
ac_add_options --disable-gnomevfs
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --disable-tests
|
||||
ac_add_options --disable-installer
|
||||
|
||||
# PGO
|
||||
mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) $(MOZ_OBJDIR)/_profile/pgo/profileserver.py 10'
|
||||
|
||||
# Needed to enable breakpad in application.ini
|
||||
export MOZILLA_OFFICIAL=1
|
9
extra/firefox/vendor.js
Normal file
9
extra/firefox/vendor.js
Normal file
|
@ -0,0 +1,9 @@
|
|||
// Use LANG environment variable to choose locale
|
||||
pref("intl.locale.matchOS", true);
|
||||
|
||||
// Disable default browser checking.
|
||||
pref("browser.shell.checkDefaultBrowser", false);
|
||||
|
||||
// Don't disable our bundled extensions in the application directory
|
||||
pref("extensions.autoDisableScopes", 11);
|
||||
pref("extensions.shownSelectionUI", true);
|
Loading…
Reference in a new issue