mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qtwebkit to 2.3.3-2
This commit is contained in:
parent
182e532a0f
commit
3dbfe1b0b2
2 changed files with 72 additions and 4 deletions
|
@ -6,12 +6,12 @@
|
|||
|
||||
pkgname=qtwebkit
|
||||
pkgver=2.3.3
|
||||
pkgrel=1.1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://trac.webkit.org/wiki/QtWebKit'
|
||||
pkgdesc='An open source web browser engine (Qt port)'
|
||||
license=('LGPL2.1' 'GPL3')
|
||||
depends=('qt4' 'systemd' 'gstreamer0.10-base')
|
||||
depends=('qt4' 'systemd' 'gst-plugins-base-libs')
|
||||
makedepends=('gperf' 'python2' 'ruby' 'git' 'mesa')
|
||||
conflicts=('qt<4.8')
|
||||
_qtver=4.8.6
|
||||
|
@ -20,19 +20,22 @@ source=("ftp://ftp.archlinux.org/other/packages/${pkgname}/${pkgname}-${pkgver}.
|
|||
'use-python2.patch'
|
||||
'bison3.patch'
|
||||
'qwebview.patch'
|
||||
'https://gitorious.org/webkit/qtwebkit-23/commit/9fe66e8b769e6fe1c66b8d00b6c8e6403d9d6303.patch')
|
||||
'https://gitorious.org/webkit/qtwebkit-23/commit/9fe66e8b769e6fe1c66b8d00b6c8e6403d9d6303.patch'
|
||||
'gst-1.patch')
|
||||
sha1sums=('64f3ab7f8e53b5b971a3a6577fc61db0cc2ea31f'
|
||||
'ddf9c20ca8309a116e0466c42984238009525da6'
|
||||
'315b6ff603f35e5492a036f7082f6aa075dfb607'
|
||||
'd2c6182512e4bcbdf30a9e9d513c52fe4b16d9f2'
|
||||
'88ed73e6bd7ea9c6d227ceaed0ff2f1cf0200667'
|
||||
'7f075217201d9b50faafdba3bbe63e63ae06d8e7')
|
||||
'7f075217201d9b50faafdba3bbe63e63ae06d8e7'
|
||||
'4b4ce9465ea9b107de7a93ce57afce43a2a1877f')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p1 -i "${srcdir}"/use-python2.patch
|
||||
patch -p1 -i "${srcdir}"/bison3.patch
|
||||
patch -p1 -i "${srcdir}"/9fe66e8b769e6fe1c66b8d00b6c8e6403d9d6303.patch
|
||||
patch -p1 -i "${srcdir}"/gst-1.patch
|
||||
|
||||
cd ../qt-everywhere-opensource-src-${_qtver}
|
||||
patch -p1 -i "${srcdir}"/qwebview.patch
|
||||
|
|
65
extra/qtwebkit/gst-1.patch
Normal file
65
extra/qtwebkit/gst-1.patch
Normal file
|
@ -0,0 +1,65 @@
|
|||
diff -urNB webkit-qtwebkit-23/Source/WebCore/WebCore.pri new/Source/WebCore/WebCore.pri
|
||||
--- webkit-qtwebkit-23/Source/WebCore/WebCore.pri 2013-02-15 16:46:12.000000000 +0100
|
||||
+++ new/Source/WebCore/WebCore.pri 2013-02-21 15:46:00.298855975 +0100
|
||||
@@ -197,8 +197,10 @@
|
||||
|
||||
contains(DEFINES, WTF_USE_GSTREAMER=1) {
|
||||
DEFINES += ENABLE_GLIB_SUPPORT=1
|
||||
- PKGCONFIG += glib-2.0 gio-2.0 gstreamer-0.10 gstreamer-app-0.10 gstreamer-base-0.10 gstreamer-interfaces-0.10 gstreamer-pbutils-0.10 gstreamer-plugins-base-0.10 gstreamer-video-0.10
|
||||
-}
|
||||
+ DEFINES += GST_API_VERSION=1.0
|
||||
+ DEFINES += GST_API_VERSION_1
|
||||
+ PKGCONFIG += glib-2.0 gio-2.0 gstreamer-1.0 gstreamer-app-1.0 gstreamer-base-1.0 gstreamer-pbutils-1.0 gstreamer-plugins-base-1.0 gstreamer-video-1.0 gstreamer-audio-1.0
|
||||
+ }
|
||||
|
||||
contains(DEFINES, ENABLE_VIDEO=1) {
|
||||
contains(DEFINES, WTF_USE_QTKIT=1) {
|
||||
@@ -233,7 +235,7 @@
|
||||
contains(DEFINES, WTF_USE_GSTREAMER=1) {
|
||||
DEFINES += WTF_USE_WEBAUDIO_GSTREAMER=1
|
||||
INCLUDEPATH += $$SOURCE_DIR/platform/audio/gstreamer
|
||||
- PKGCONFIG += gstreamer-audio-0.10 gstreamer-fft-0.10
|
||||
+ PKGCONFIG += gstreamer-audio-1.0 gstreamer-fft-1.0
|
||||
}
|
||||
}
|
||||
|
||||
diff -urNB webkit-qtwebkit-23/Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h new/Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h
|
||||
--- webkit-qtwebkit-23/Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h 2013-02-15 16:46:12.000000000 +0100
|
||||
+++ new/Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h 2013-02-21 15:46:00.298855975 +0100
|
||||
@@ -157,7 +157,7 @@
|
||||
virtual void needTouchEvents(bool) { }
|
||||
#endif
|
||||
|
||||
-#if ENABLE(VIDEO) && (USE(GSTREAMER) || USE(QT_MULTIMEDIA) || USE(QTKIT))
|
||||
+#if ENABLE(VIDEO) && ((USE(GSTREAMER) && !defined(GST_API_VERSION_1)) || USE(QT_MULTIMEDIA) || USE(QTKIT))
|
||||
virtual bool supportsFullscreenForNode(const Node*);
|
||||
virtual void enterFullscreenForNode(Node*);
|
||||
virtual void exitFullscreenForNode(Node*);
|
||||
diff -urNB webkit-qtwebkit-23/Source/WebKit/qt/WebCoreSupport/FullScreenVideoQt.h new/Source/WebKit/qt/WebCoreSupport/FullScreenVideoQt.h
|
||||
--- webkit-qtwebkit-23/Source/WebKit/qt/WebCoreSupport/FullScreenVideoQt.h 2013-02-15 16:46:12.000000000 +0100
|
||||
+++ new/Source/WebKit/qt/WebCoreSupport/FullScreenVideoQt.h 2013-02-21 15:52:57.400847675 +0100
|
||||
@@ -106,10 +106,10 @@
|
||||
private:
|
||||
ChromeClientQt* m_chromeClient;
|
||||
HTMLVideoElement* m_videoElement;
|
||||
-#if USE(QT_MULTIMEDIA)
|
||||
+#if USE(QT_MULTIMEDIA) && !defined(GST_API_VERSION_1)
|
||||
QWebFullScreenVideoHandler* m_FullScreenVideoHandler;
|
||||
#endif
|
||||
-#if USE(GSTREAMER)
|
||||
+#if USE(GSTREAMER) && !defined(GST_API_VERSION_1)
|
||||
GStreamerFullScreenVideoHandler* m_FullScreenVideoHandlerGStreamer;
|
||||
#endif
|
||||
#if USE(QTKIT)
|
||||
diff -urNB webkit-qtwebkit-23/Tools/qmake/mkspecs/features/features.prf new/Tools/qmake/mkspecs/features/features.prf
|
||||
--- webkit-qtwebkit-23/Tools/qmake/mkspecs/features/features.prf 2013-02-15 16:46:12.000000000 +0100
|
||||
+++ new/Tools/qmake/mkspecs/features/features.prf 2013-02-21 15:46:00.297855972 +0100
|
||||
@@ -186,7 +186,7 @@
|
||||
DEFINES += WTF_USE_QTKIT=1
|
||||
}
|
||||
} else: linux-*:!contains(DEFINES, USE_QTMULTIMEDIA=1) {
|
||||
- !contains(QT_CONFIG, no-pkg-config):system(pkg-config --exists glib-2.0 gio-2.0 \'gstreamer-0.10 >= 0.10.30\' \'gstreamer-plugins-base-0.10 >= 0.10.30\'): {
|
||||
+ !contains(QT_CONFIG, no-pkg-config):packagesExist("glib-2.0 gio-2.0 gstreamer-1.0 gstreamer-plugins-base-1.0") {
|
||||
DEFINES += ENABLE_VIDEO=1
|
||||
DEFINES += WTF_USE_GSTREAMER=1
|
||||
} else {
|
Loading…
Reference in a new issue