core/linux-armv7 to 5.8.0-1

This commit is contained in:
Kevin Mihelich 2020-08-09 00:14:38 +00:00
parent f3be5b010b
commit 3dcaf1da2c
11 changed files with 313 additions and 198 deletions

View file

@ -1,4 +1,4 @@
From cff98a5e22c06d5d6c20879248c136e7c6e7c719 Mon Sep 17 00:00:00 2001
From 5feca98dfeac189b37efef4e9f0a9c6bf74cf1ac Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 25ceda63b284..83578c54975b 100644
};
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From 9e8c55d7b445c3a1d66fe95f6ecd2883cf28f571 Mon Sep 17 00:00:00 2001
From 054eae658707524b6b17a726d5ca59f38e436bea Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -17,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
index 64c49747f8a3..60cd5e5bac93 100644
index 8452753efebe..3393a10741bb 100644
--- a/arch/arm/boot/compressed/atags_to_fdt.c
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
@@ -203,6 +203,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
@@ -204,6 +204,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
hex_str(serno, atag->u.serialnr.high);
hex_str(serno+8, atag->u.serialnr.low);
setprop_string(fdt, "/", "serial-number", serno);
@ -34,5 +34,5 @@ index 64c49747f8a3..60cd5e5bac93 100644
}
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From 875b0c2cd03da835b7b8cbab16a056ca0b50d11d Mon Sep 17 00:00:00 2001
From 9a08f1ddf9ae7f099b7cf1428eaa9008a108fec5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/9] SMILE Plug device tree file
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index e8dd99201397..6107ad410109 100644
index e6a1cac0bfc7..42d24fced58b 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1265,6 +1265,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -1280,6 +1280,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From cf280071b198b744afaa9146a432ed59ac64b770 Mon Sep 17 00:00:00 2001
From a6a3d9439d168e6b442e9ec85207a0e5d36d7ded Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/9] fix mvsdio eMMC timing
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 203b61712601..c26211c76376 100644
index cc0752a9df6d..8f86e19eb074 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -90,7 +90,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
@ -34,5 +34,5 @@ index 203b61712601..c26211c76376 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From c285820634d24268a6ecc330fbcfe3fc325d481d Mon Sep 17 00:00:00 2001
From 1b51b2b354d2823d5b8f633aaf6490552f9a7d08 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 355be77f4241..c94a7193e0b9 100644
index bb4ccbda031a..84e40f5aea9f 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -48,6 +48,7 @@
@ -91,5 +91,5 @@ index 355be77f4241..c94a7193e0b9 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From 9bb44b8e32834dbe51768a3f3ccf2c12181d0c26 Mon Sep 17 00:00:00 2001
From d441b1498dd90eebc4b22c1ae45e09231b6ccb27 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/9] set default cubietruck led triggers
@ -29,5 +29,5 @@ index 8c8dee6ea461..4f52a11b913e 100644
};
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From 2cb39fc2eea2e1747d39d56b0b2b49697058c090 Mon Sep 17 00:00:00 2001
From 25f091fa0ad0e655074a5fa4c814dfcf8af45fc7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,18 +13,18 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 73d6a71da88d..aabf994ec07f 100644
index a5c1ce1e396c..daec49c04367 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -439,7 +439,7 @@ buck1_reg: BUCK1 {
buck2_reg: BUCK2 {
regulator-name = "vdd_arm";
regulator-name = "VDD_ARM";
- regulator-min-microvolt = <900000>;
+ regulator-min-microvolt = <1100000>;
regulator-max-microvolt = <1350000>;
regulator-always-on;
regulator-boot-on;
--
2.26.1
2.27.0

View file

@ -1,4 +1,4 @@
From 12d4e27d0e11a6fec43b89e7b6bb55debb094caa Mon Sep 17 00:00:00 2001
From 8e205e84920a82415285af954f04268c0984cc37 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 8/9] ARM: dove: enable ethernet on D3Plug
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.26.1
2.27.0

View file

@ -1,21 +1,21 @@
From b492240828db14302661adcdd3fd12396069ee4e Mon Sep 17 00:00:00 2001
From 41a51f04b4267cc0491c54c7ddf68d88d344b74b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 9/9] USB Armory MkII support
---
arch/arm/boot/dts/Makefile | 2 +
arch/arm/boot/dts/imx6ul-usbarmory.dts | 255 +++++++++++++++++++++++
arch/arm/boot/dts/imx6ull-usbarmory.dts | 256 ++++++++++++++++++++++++
3 files changed, 513 insertions(+)
arch/arm/boot/dts/imx6ul-usbarmory.dts | 256 +++++++++++++++++++++++
arch/arm/boot/dts/imx6ull-usbarmory.dts | 257 ++++++++++++++++++++++++
3 files changed, 515 insertions(+)
create mode 100644 arch/arm/boot/dts/imx6ul-usbarmory.dts
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 6107ad410109..fd8e1835deb7 100644
index 42d24fced58b..9f6833189962 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -609,10 +609,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
@@ -614,10 +614,12 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
@ -30,10 +30,10 @@ index 6107ad410109..fd8e1835deb7 100644
imx6ull-phytec-segin-lc-rdk-nand.dtb \
diff --git a/arch/arm/boot/dts/imx6ul-usbarmory.dts b/arch/arm/boot/dts/imx6ul-usbarmory.dts
new file mode 100644
index 000000000000..f26344965ae1
index 000000000000..1fdcd6f611d5
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ul-usbarmory.dts
@@ -0,0 +1,255 @@
@@ -0,0 +1,256 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
@ -93,6 +93,7 @@ index 000000000000..f26344965ae1
+ };
+
+ memory {
+ device_type = "memory";
+ reg = <0x80000000 0x20000000>;
+ };
+
@ -291,10 +292,10 @@ index 000000000000..f26344965ae1
+};
diff --git a/arch/arm/boot/dts/imx6ull-usbarmory.dts b/arch/arm/boot/dts/imx6ull-usbarmory.dts
new file mode 100644
index 000000000000..2d758a805264
index 000000000000..f74d0296d5f6
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ull-usbarmory.dts
@@ -0,0 +1,256 @@
@@ -0,0 +1,257 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
@ -354,6 +355,7 @@ index 000000000000..2d758a805264
+ };
+
+ memory {
+ device_type = "memory";
+ reg = <0x80000000 0x20000000>;
+ };
+
@ -552,5 +554,5 @@ index 000000000000..2d758a805264
+ status = "okay";
+};
--
2.26.1
2.27.0

View file

@ -4,21 +4,21 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-5.7
_srcname=linux-5.8
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=5.7.6
pkgrel=2
rcnver=5.7.6
rcnrel=armv7-x13
pkgver=5.8.0
pkgrel=1
rcnver=5.8.0
rcnrel=armv7-x8
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/sid-armhf/v${rcnver}-${rcnrel}/patch-${rcnver%.0}-${rcnrel}.diff.gz"
#"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/stretch-armhf/v${rcnver}-${rcnrel}/patch-${rcnver%.0}-${rcnrel}.diff.xz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
@ -35,19 +35,18 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('f63ed18935914e1ee3e04c2a0ce1ba3b'
'19d1ba16b138925dac175e1986cf1302'
'4ab936b43376531b51d5907fcb47aafb'
'c2c94f19d06e66948c8fa387824c57e9'
'9302b69053eef3e883af46b4849d1942'
'6ab1b96d995c3a765d9f8e0197ef0b7a'
'faf800395a2933b8018d3314ca10c998'
'88eca9370d9ea2529f0926f71b25ca48'
'b1b7a6c3a0d1d5ee87059a5e9dce84e4'
'9c573026a0648bf41a7fcc25b1319e71'
'e147d9e4122ec5b86c6016c074188077'
'ae296b53ab5cf799bc77a7c5ebc92af1'
'094e6e1093d511be13c907244c5a8120'
md5sums=('0e5c4c15266218ef26c50fac0016095b'
'aa79e9ebc719b3606d278b76cca9e657'
'b27d0901f7518ba184215166839ebef0'
'cd91c108378ab798d86eaac43f944205'
'a9e65315eee231c03ba91cbdcc20f6af'
'1cdaf6715c74dc8f0896755e30e19ace'
'4b38cbdcac655da8641026393c55dd9b'
'2d2db143bd26d5dcb3abfb845c534248'
'd6ab849ab09e24e684e49617ce8199d0'
'379ed0e2f315bd188da2c317d843acff'
'a4dba3e31ffdebc78a3fa3a22a9b5752'
'f2152bbb6471d3d1582ca3e3f83b4f8c'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -59,7 +58,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# RCN patch
git apply ../patch-${rcnver%.0}-${rcnrel}.diff
@ -119,7 +118,7 @@ _package() {
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
provides=('kernel26' "linux=${pkgver}" "WIREGUARD-MODULE")
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
conflicts=('linux')
replaces=('linux-mvebu' 'linux-udoo' 'linux-sun4i' 'linux-sun5i' 'linux-sun7i' 'linux-usbarmory' 'linux-wandboard' 'linux-clearfog')
install=${pkgname}.install

File diff suppressed because it is too large Load diff