mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/ecl to 15.3.7-1
This commit is contained in:
parent
68663f40d8
commit
3dd74621fb
2 changed files with 4 additions and 19 deletions
|
@ -7,8 +7,8 @@
|
|||
# - specify libffi include path in CPPFLAGS
|
||||
|
||||
pkgname=ecl
|
||||
pkgver=13.5.1
|
||||
pkgrel=2
|
||||
pkgver=15.3.7
|
||||
pkgrel=1
|
||||
pkgdesc="Embeddable Common Lisp"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://sourceforge.net/projects/ecls/"
|
||||
|
@ -17,15 +17,12 @@ depends=('bash' 'gmp' 'libffi')
|
|||
makedepends=('texinfo')
|
||||
provides=('common-lisp' 'cl-asdf')
|
||||
options=('!makeflags')
|
||||
source=(http://downloads.sourceforge.net/project/ecls/ecls/13.5/ecl-${pkgver}.tgz
|
||||
add_cas_emulation_for_armel.patch)
|
||||
md5sums=('f6bb59d9383c51fc94e1c7ca5cf1c586'
|
||||
'16a7c651f2f06fb6718e8704a42f8049')
|
||||
source=(http://downloads.sourceforge.net/project/ecls/ecls/15.3/ecl-${pkgver}.tgz)
|
||||
md5sums=('39f4fb924c88e47ce31e6d57ac2a6de8')
|
||||
|
||||
prepare() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
[[ $CARCH == 'arm' ]] && patch -p1 -i ../add_cas_emulation_for_armel.patch
|
||||
sed -i 's|-Wl,--rpath,~A|-Wl,--rpath,/usr/lib/ecl|' src/configure
|
||||
}
|
||||
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff --git a/src/h/internal.h b/src/h/internal.h
|
||||
index 50fb8a9..595d0a2 100755
|
||||
--- a/src/h/internal.h
|
||||
+++ b/src/h/internal.h
|
||||
@@ -422,6 +422,7 @@ extern void cl_write_object(cl_object x, cl_object stream);
|
||||
#endif /* ECL_THREADS */
|
||||
|
||||
#ifdef ECL_THREADS
|
||||
+# define AO_REQUIRE_CAS
|
||||
# ifdef ECL_LIBATOMIC_OPS_H
|
||||
# include <ecl/atomic_ops.h>
|
||||
# else
|
Loading…
Reference in a new issue