mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-am33x to 4.14.3-2 (#1546)
Add mcp23s08 and tps65217 backlight drivers, which are required to get use of chiliboard LCD shield. mcp23s08 is a I2C GPIO expander needed to enable LCD. Add I2C GPIO expander needed to put LCD_EN pin high. Note, than previously that was not needed, because initial batch of LCD shields had pull-up resistors instead of pull-down. Update checksums and bump up pkgrel.
This commit is contained in:
parent
86a093c972
commit
3e0cec6cd8
3 changed files with 38 additions and 22 deletions
|
@ -1,19 +1,19 @@
|
|||
From cbb5fd0363c51b204ae2bf570aefdd6925a1f1aa Mon Sep 17 00:00:00 2001
|
||||
From e92c1ac1adb612ed061fd8d7e7fb1f85de18ad83 Mon Sep 17 00:00:00 2001
|
||||
From: Mateusz Salamon <m.salamon@grinn-global.com>
|
||||
Date: Fri, 20 May 2016 14:31:51 +0200
|
||||
Subject: [PATCH] add lcd cape for chiliboard
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/am335x-chiliboard-lcd.dts | 143 ++++++++++++++++++++++++++++
|
||||
2 files changed, 144 insertions(+)
|
||||
arch/arm/boot/dts/am335x-chiliboard-lcd.dts | 159 ++++++++++++++++++++++++++++
|
||||
2 files changed, 160 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/am335x-chiliboard-lcd.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 31c53b8b1884..5b58f95dfe8e 100644
|
||||
index eff87a344566..905b65a31465 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -602,6 +602,7 @@ dtb-$(CONFIG_SOC_AM33XX) += \
|
||||
@@ -620,6 +620,7 @@ dtb-$(CONFIG_SOC_AM33XX) += \
|
||||
am335x-bonegreen.dtb \
|
||||
am335x-bonegreen-wireless.dtb \
|
||||
am335x-chiliboard.dtb \
|
||||
|
@ -23,10 +23,10 @@ index 31c53b8b1884..5b58f95dfe8e 100644
|
|||
am335x-evmsk.dtb \
|
||||
diff --git a/arch/arm/boot/dts/am335x-chiliboard-lcd.dts b/arch/arm/boot/dts/am335x-chiliboard-lcd.dts
|
||||
new file mode 100644
|
||||
index 000000000000..bee7d42a08e6
|
||||
index 000000000000..bea28f9e6163
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/am335x-chiliboard-lcd.dts
|
||||
@@ -0,0 +1,143 @@
|
||||
@@ -0,0 +1,159 @@
|
||||
+/*
|
||||
+ * Copyright (C) 2016 Grinn Sp. z o.o.
|
||||
+ * Author: Mateusz Salamon <m.salamon@grinn-global.com>
|
||||
|
@ -42,15 +42,15 @@ index 000000000000..bee7d42a08e6
|
|||
+ compatible = "ti,tilcdc,panel";
|
||||
+ status = "okay";
|
||||
+ panel-info {
|
||||
+ ac-bias = <255>;
|
||||
+ ac-bias-intrpt = <0>;
|
||||
+ dma-burst-sz = <16>;
|
||||
+ bpp = <32>;
|
||||
+ fdd = <0x80>;
|
||||
+ sync-edge = <0>;
|
||||
+ sync-ctrl = <1>;
|
||||
+ raster-order = <0>;
|
||||
+ fifo-th = <0>;
|
||||
+ ac-bias = <255>;
|
||||
+ ac-bias-intrpt = <0>;
|
||||
+ dma-burst-sz = <16>;
|
||||
+ bpp = <32>;
|
||||
+ fdd = <0x80>;
|
||||
+ sync-edge = <0>;
|
||||
+ sync-ctrl = <1>;
|
||||
+ raster-order = <0>;
|
||||
+ fifo-th = <0>;
|
||||
+ };
|
||||
+
|
||||
+ display-timings {
|
||||
|
@ -170,6 +170,22 @@ index 000000000000..bee7d42a08e6
|
|||
+ default-brightness = <50>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&i2c0 {
|
||||
+ mcp23008: mcp23008@20 {
|
||||
+ compatible = "microchip,mcp23008";
|
||||
+ gpio-controller;
|
||||
+ #gpio-cells = <2>;
|
||||
+ reg = <0x20>;
|
||||
+
|
||||
+ lcd_en {
|
||||
+ gpio-hog;
|
||||
+ gpios = <7 0>; /* TODO: ACTIVE_HIGH? */
|
||||
+ output-high;
|
||||
+ line-name = "lcd-en";
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.12.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -8,7 +8,7 @@ _srcname=linux-4.14
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="TI AM335x Beaglebone (Black)"
|
||||
pkgver=4.14.3
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
rcnrel=bone5
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -28,9 +28,9 @@ md5sums=('bacdb9ffdcd922aa069a5e1520160e24'
|
|||
'0732df415000b9def639a69996df6497'
|
||||
'44aa2e3b7b1ef8638571a306b019639e'
|
||||
'SKIP'
|
||||
'dc780fbf3d4d1175a94232d7ba1e3cb3'
|
||||
'ee16bcdbbf978e714455933ecd6dd8fe'
|
||||
'5698870a716fed205215d258cc71e296'
|
||||
'0ce9d5b958d64ec493df5949ed9b74c2'
|
||||
'195c6f64de4a239acb148b3a7095a574'
|
||||
'78ccc998f27eec49a9d5490218b1b1ab'
|
||||
'79fa396e3f9a09a85156d6d7c2d34b58')
|
||||
|
||||
|
|
|
@ -2912,7 +2912,7 @@ CONFIG_PINCONF=y
|
|||
CONFIG_GENERIC_PINCONF=y
|
||||
# CONFIG_DEBUG_PINCTRL is not set
|
||||
# CONFIG_PINCTRL_AMD is not set
|
||||
# CONFIG_PINCTRL_MCP23S08 is not set
|
||||
CONFIG_PINCTRL_MCP23S08=m
|
||||
CONFIG_PINCTRL_SINGLE=y
|
||||
# CONFIG_PINCTRL_SX150X is not set
|
||||
CONFIG_ARCH_HAVE_CUSTOM_GPIO_H=y
|
||||
|
@ -4090,7 +4090,7 @@ CONFIG_BACKLIGHT_PWM=y
|
|||
# CONFIG_BACKLIGHT_LM3630A is not set
|
||||
# CONFIG_BACKLIGHT_LM3639 is not set
|
||||
# CONFIG_BACKLIGHT_LP855X is not set
|
||||
# CONFIG_BACKLIGHT_TPS65217 is not set
|
||||
CONFIG_BACKLIGHT_TPS65217=m
|
||||
CONFIG_BACKLIGHT_GPIO=y
|
||||
# CONFIG_BACKLIGHT_LV5207LP is not set
|
||||
# CONFIG_BACKLIGHT_BD6107 is not set
|
||||
|
|
Loading…
Reference in a new issue