diff --git a/community/botan/PKGBUILD b/community/botan/PKGBUILD
index 13a2cebfd..54b5c1406 100644
--- a/community/botan/PKGBUILD
+++ b/community/botan/PKGBUILD
@@ -1,9 +1,10 @@
-# $Id: PKGBUILD 87983 2013-04-09 20:48:46Z arodseth $
+# $Id$
 # Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
 # Contributor: Angel Velasquez <angvp@archlinux.org>
 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
 # Contributor: d'Ronin <daronin@2600.com>
 # Contributor: Hexchain Tong <richard0053@gmail.com>
+# Contributor: Jack Lloyd <jack@randombit.net>
 
 # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
 #  - compiler flags adjustment to build correctly
@@ -11,29 +12,33 @@
 #  - AArch64 patch
 
 pkgname=botan
-pkgver=2.4.0
-pkgrel=1
+pkgver=2.5.0
+pkgrel=4
 pkgdesc='Crypto library written in C++'
 arch=('x86_64')
 url='https://botan.randombit.net/'
 license=('BSD')
-depends=('gcc-libs' 'sh')
-makedepends=('python')
-validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
-source=("https://botan.randombit.net/releases/Botan-${pkgver}.tgz"{,.asc}
+makedepends=('git' 'python')
+# Using a specific commit instead of the .tgz because botan issue #1524
+source=('git+https://github.com/randombit/botan#commit=6c5d9ef3c49658cbf4096e04905e3c0debb9d096'
         '0001-aarch64-support.patch')
-sha256sums=('ed9464e2a5cfee4cd3d9bd7a8f80673b45c8a0718db2181a73f5465a606608a5'
-            'SKIP'
-            '0e279e3b16e115e26f5dc1edf02a4082f063134513aaf6ad1fbd10a1d2624e37')
+md5sums=('SKIP'
+         '37165d2a365dd2e9d779b89fa55ba77b')
+#validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
+#source=("https://botan.randombit.net/releases/Botan-${pkgver}.tgz"{,.asc})
+#sha256sums=('b8a31fe03e7f048a5bd3967ecd04b6a48966215e78792df06e333b0eede4fb1b'
+#            'SKIP')
 
 prepare() {
-  cd "${pkgname^}-$pkgver"
+  cd "$pkgname"
+  #cd "${pkgname^}-$pkgver"
 
   patch -p1 -i ../0001-aarch64-support.patch
 }
 
 build() {
-  cd "${pkgname^}-$pkgver"
+  cd "$pkgname"
+  #cd "${pkgname^}-$pkgver"
 
   if [[ $CARCH == 'aarch64' ]]; then
     CPU='aarch64'
@@ -49,18 +54,19 @@ build() {
 
   [[ $CARCH != "aarch64" ]] && CONFIG="--disable-neon"
 
-  ./configure.py --prefix=/usr --cpu=$CPU $CONFIG
+  # botan benefits from -O3, and the developers runs tests with it
+  CXXFLAGS="$CXXFLAGS -O3" ./configure.py --prefix=/usr --with-bzip --with-zlib --with-lzma --cpu=$CPU $CONFIG
   make
 }
 
 check() {
-  cd "${pkgname^}-$pkgver"
+  cd "$pkgname"
 
   ./botan-test
 }
 
 package() {
-  cd "${pkgname^}-$pkgver"
+  cd "$pkgname"
 
   make DESTDIR="$pkgdir" install
   install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"