alarm/kodi-rbp to 17.3-4 (#1501)

This commit is contained in:
graysky 2017-07-16 13:02:40 -04:00 committed by Kevin Mihelich
parent 57ca87d965
commit 3e3356c7c6
2 changed files with 76 additions and 1 deletions

View file

@ -13,7 +13,7 @@ pkgbase=kodi-rbp
pkgname=('kodi-rbp' 'kodi-rbp-eventclients' 'kodi-rbp-tools-texturepacker' 'kodi-rbp-dev')
_codename=Krypton
pkgver=17.3
pkgrel=3
pkgrel=4
arch=('armv6h' 'armv7h')
url="http://kodi.tv"
license=('GPL2')
@ -30,6 +30,7 @@ source=("https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
'https://github.com/popcornmix/xbmc/commit/0c320b6cdd4fb409be45008e6b9042463d54b742.patch'
'https://github.com/popcornmix/xbmc/commit/4d983105d7fd65b1d92f2ae2602e6e1cdcaddbe0.patch'
'polkit.rules'
'fix-ftpparse.patch'
'hifiberry_digi.patch'
'fix-python-lib-path.patch')
@ -39,6 +40,7 @@ sha256sums=('1de8653a3729cefd1baaf09ecde5ace01a1e3a58fbf29d48c1363f2503d331a1'
'6f23df9cf214502f0a446edf07b18ce1855e549cabb1cd94ac9180770ba48ee4'
'82057eccc4cadbd568dda76103dcc667754194e926ede78e43d70b3a17bbb5e5'
'9ea592205023ba861603d74b63cdb73126c56372a366dc4cb7beb379073cbb96'
'1665f33f608f85b786393fc52667ed4f151dacbaf2a195df4ed9ab9f09a517f7'
'0b9d951911a8576c26dec8a31f394282677e48afff49b9579448121d27b8509e'
'1c07c9fdd8e2958262cf917e4266c4933fcd06529c111e3cb0cbaaa05c934033')
prepare() {
@ -52,6 +54,8 @@ prepare() {
patch -Np1 -i "$srcdir/hifiberry_digi.patch"
#
patch -p1 -i "$srcdir/fix-python-lib-path.patch"
#
patch -p1 -i "$srcdir/fix-ftpparse.patch"
[[ -d kodi-build ]] && rm -rf kodi-build
mkdir $srcdir/kodi-build

View file

@ -0,0 +1,71 @@
--- a/xbmc/filesystem/FTPParse.cpp 2017-05-24 22:49:32.000000000 +0200
+++ b/xbmc/filesystem/FTPParse.cpp 2017-07-15 14:15:54.908823456 +0200
@@ -34,7 +34,7 @@
m_time = 0;
}
-string CFTPParse::getName()
+std::string CFTPParse::getName()
{
return m_name;
}
@@ -59,16 +59,16 @@
return m_time;
}
-void CFTPParse::setTime(string str)
+void CFTPParse::setTime(std::string str)
{
/* Variables used to capture patterns via the regexes */
- string month;
- string day;
- string year;
- string hour;
- string minute;
- string second;
- string am_or_pm;
+ std::string month;
+ std::string day;
+ std::string year;
+ std::string hour;
+ std::string minute;
+ std::string second;
+ std::string am_or_pm;
/* time struct used to set the time_t variable */
struct tm time_struct = {};
@@ -338,21 +338,21 @@
return day_of_week;
}
-int CFTPParse::FTPParse(string str)
+int CFTPParse::FTPParse(std::string str)
{
/* Various variable to capture patterns via the regexes */
- string permissions;
- string link_count;
- string owner;
- string group;
- string size;
- string date;
- string name;
- string type;
- string stuff;
- string facts;
- string version;
- string file_id;
+ std::string permissions;
+ std::string link_count;
+ std::string owner;
+ std::string group;
+ std::string size;
+ std::string date;
+ std::string name;
+ std::string type;
+ std::string stuff;
+ std::string facts;
+ std::string version;
+ std::string file_id;
/* Regex for standard Unix listing formats */
pcrecpp::RE unix_re("^([-bcdlps])" // type