mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/xf86-video-armsoc-git to 258.8bbdb2a-4
This commit is contained in:
parent
42a6594b0b
commit
3e400d4b46
2 changed files with 46 additions and 3 deletions
|
@ -0,0 +1,36 @@
|
|||
From dc0ed09cc89a281605aaf22b714cc5d780160dbb Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 14 Jun 2018 11:59:02 -0600
|
||||
Subject: [PATCH] Initialize XRandR before EnterVT
|
||||
|
||||
---
|
||||
src/armsoc_driver.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
|
||||
index 83e74a7..a52646c 100644
|
||||
--- a/src/armsoc_driver.c
|
||||
+++ b/src/armsoc_driver.c
|
||||
@@ -1130,6 +1130,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||
*/
|
||||
pScrn->vtSema = TRUE;
|
||||
|
||||
+ /* Do some XRandR initialization. Return value is not useful */
|
||||
+ (void)xf86CrtcScreenInit(pScreen);
|
||||
+
|
||||
/* Take over the virtual terminal from the console, set the
|
||||
* desired mode, etc.:
|
||||
*/
|
||||
@@ -1138,9 +1141,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||
goto fail6;
|
||||
}
|
||||
|
||||
- /* Do some XRandR initialization. Return value is not useful */
|
||||
- (void)xf86CrtcScreenInit(pScreen);
|
||||
-
|
||||
if (!miCreateDefColormap(pScreen)) {
|
||||
ERROR_MSG("Cannot create colormap!");
|
||||
goto fail7;
|
||||
--
|
||||
2.17.1
|
||||
|
|
@ -6,7 +6,7 @@ buildarch=4
|
|||
|
||||
pkgname=xf86-video-armsoc-git
|
||||
pkgver=258.8bbdb2a
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
epoch=1
|
||||
pkgdesc='X.org graphics driver for ARM graphics'
|
||||
arch=('armv7h')
|
||||
|
@ -15,14 +15,21 @@ license=('GPL2')
|
|||
makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0' 'git')
|
||||
conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25' 'xf86-video-armsoc')
|
||||
provides=(xf86-video-armsoc)
|
||||
source=("$pkgname::git://anongit.freedesktop.org/xorg/driver/xf86-video-armsoc")
|
||||
md5sums=('SKIP')
|
||||
source=("$pkgname::git://anongit.freedesktop.org/xorg/driver/xf86-video-armsoc"
|
||||
'0001-Initialize-XRandR-before-EnterVT.patch')
|
||||
md5sums=('SKIP'
|
||||
'07cf643ee2dad206d0a33c14db985a06')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
git apply ../0001-Initialize-XRandR-before-EnterVT.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
|
||||
|
|
Loading…
Reference in a new issue