From 3e4675a76286933f91d514746ac911c7a244dc4d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 3 Feb 2015 12:46:05 +0000
Subject: [PATCH] removed community/apcupsd

---
 community/apcupsd/PKGBUILD              | 75 -------------------------
 community/apcupsd/apcupsd-tmpfiles.conf |  3 -
 community/apcupsd/apcupsd.service       |  8 ---
 community/apcupsd/arm.patch             | 11 ----
 4 files changed, 97 deletions(-)
 delete mode 100644 community/apcupsd/PKGBUILD
 delete mode 100644 community/apcupsd/apcupsd-tmpfiles.conf
 delete mode 100644 community/apcupsd/apcupsd.service
 delete mode 100644 community/apcupsd/arm.patch

diff --git a/community/apcupsd/PKGBUILD b/community/apcupsd/PKGBUILD
deleted file mode 100644
index 482befffe..000000000
--- a/community/apcupsd/PKGBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
-# $Id$
-# Maintainer: Florian Pritz <bluewind@xinu.at>
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: Todd Musall <tmusall@comcast.net>
-# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-
-# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
-#  - patch to fix ARMism, should be included in the next release
-
-pkgname=apcupsd
-pkgver=3.14.12
-pkgrel=3
-pkgdesc="Power mangement and controlling most of APC's UPS models"
-arch=(i686 x86_64)
-url="http://www.apcupsd.org"
-license=('GPL')
-depends=('gcc-libs' 'systemd-sysvcompat')
-optdepends=('gd: for CGI'
-            'gconf: for frontend'
-            'gtk2: for frontend')
-makedepends=('pkgconfig' 'gd' 'gconf' 'gtk2')
-backup=(etc/apcupsd/apcupsd.conf
-        etc/apcupsd/hosts.conf
-        etc/apcupsd/multimon.conf
-        etc/apcupsd/apcupsd.css
-        etc/apcupsd/changeme
-        etc/apcupsd/commfailure
-        etc/apcupsd/commok
-        etc/apcupsd/offbattery
-        etc/apcupsd/onbattery
-        etc/apcupsd/apccontrol)
-source=(http://downloads.sourceforge.net/apcupsd/$pkgname-$pkgver.tar.gz{,.sig}
-        apcupsd.service
-        apcupsd-tmpfiles.conf
-        arm.patch)
-sha256sums=('1b4f703cb19cfdf44daf173dc8394cafd30fee0b30a0c75a7d19db622454a440'
-            'SKIP'
-            '145e88863335f077fc354b4d263b15f64af67b45a10ed37c68ebd468181e23f7'
-            'b00cd1a31de70a172698d486583aa79113b99c1bb4b882ab906d0e37504d7f55'
-            'a4474cfcd607c5e9b64e27eec7cbc2b0bcf08c8ea37fd1f0f28e98ac2883fd4f')
-validpgpkeys=(635B9D943945DCA05BE9AB0A24E84804A57B2D90)
-
-prepare() {
-	cd "$srcdir/$pkgname-$pkgver"
-	patch -p3 -i ../arm.patch
-}
-
-build() {
-	cd "$srcdir/$pkgname-$pkgver"
-	./configure --prefix=/usr  --libexecdir=/usr/lib/$pkgname \
-		--sbindir=/usr/bin \
-		--enable-cgi --enable-usb --enable-net \
-		--with-upstype=usb --with-upscable=usb \
-		--with-serial-dev=/dev/usb/hid/hiddev[0-9] \
-		--enable-pthreads --enable-gapcmon
-	make
-}
-
-package() {
-	cd "$srcdir/$pkgname-$pkgver"
-
-	make DESTDIR="$pkgdir" install
-
-	sed -i 's#^LOCKFILE .*$#LOCKFILE /run/apcupsd#' "$pkgdir/etc/apcupsd/apcupsd.conf"
-
-	install -Dm644 "$srcdir/apcupsd.service" "$pkgdir/usr/lib/systemd/system/apcupsd.service"
-	install -Dm644 "$srcdir/apcupsd-tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/apcupsd.conf"
-
-	chmod 755 "$pkgdir"/usr/bin/*
-
-	install -dm755 "$pkgdir/usr/lib/$pkgname/cgi-bin"
-	mv "$pkgdir"/etc/apcupsd/*.cgi "$pkgdir/usr/lib/$pkgname/cgi-bin"
-
-	rm -rf "$pkgdir/usr/share/hal"
-}
diff --git a/community/apcupsd/apcupsd-tmpfiles.conf b/community/apcupsd/apcupsd-tmpfiles.conf
deleted file mode 100644
index 60f831683..000000000
--- a/community/apcupsd/apcupsd-tmpfiles.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-r /etc/apcupsd/powerfail
-r /etc/nologin
-d /run/apcupsd 0755 root root
diff --git a/community/apcupsd/apcupsd.service b/community/apcupsd/apcupsd.service
deleted file mode 100644
index b8dfb9b4a..000000000
--- a/community/apcupsd/apcupsd.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=APC UPS Monitor
-
-[Service]
-ExecStart=/usr/bin/apcupsd -b
-
-[Install]
-WantedBy=multi-user.target
diff --git a/community/apcupsd/arm.patch b/community/apcupsd/arm.patch
deleted file mode 100644
index bcd776ae2..000000000
--- a/community/apcupsd/arm.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/branches/Branch-3_14/src/apcaccess.c
-+++ b/branches/Branch-3_14/src/apcaccess.c
-@@ -146,7 +146,7 @@
- #endif
- 
-    // Process standard options
--   char ch;
-+   int ch;
-    while ((ch = getopt(argc, argv, "f:h:p:u")) != -1)
-    {
-       switch (ch)