mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
Removed old zlib package
This commit is contained in:
parent
e31d743ac0
commit
3e70c4b16f
2 changed files with 0 additions and 51 deletions
|
@ -1,38 +0,0 @@
|
||||||
# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
|
|
||||||
|
|
||||||
# Plugbox changes: Removed the GCC patch (CFLAGS="${CFLAGS/-O2/-O3} -f...)
|
|
||||||
Added --shared to the end of ./configure
|
|
||||||
|
|
||||||
pkgname=zlib
|
|
||||||
pkgver=1.2.5
|
|
||||||
pkgrel=3
|
|
||||||
plugrel=1
|
|
||||||
pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
|
|
||||||
arch=('arm')
|
|
||||||
license=('custom')
|
|
||||||
url="http://www.zlib.net/"
|
|
||||||
depends=('glibc')
|
|
||||||
options=('!makeflags')
|
|
||||||
source=("http://zlib.net/zlib-${pkgver}.tar.gz"
|
|
||||||
'zlib-1.2.5-lfs-decls.patch')
|
|
||||||
md5sums=('c735eab2d659a96e5a594c9e8541ad63'
|
|
||||||
'4cb279ea3beab621f3526bf7b7ab99e5')
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd ${srcdir}/zlib-$pkgver
|
|
||||||
|
|
||||||
# see http://bugs.archlinux.org/task/19280
|
|
||||||
patch -p1 -i ${srcdir}/zlib-1.2.5-lfs-decls.patch || return 1
|
|
||||||
|
|
||||||
./configure --prefix=/usr --shared
|
|
||||||
|
|
||||||
make || return 1
|
|
||||||
|
|
||||||
grep -A 24 '^ Copyright' zlib.h > LICENSE
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd ${srcdir}/zlib-$pkgver
|
|
||||||
make install DESTDIR=${pkgdir} || return 1
|
|
||||||
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/zlib/LICENSE
|
|
||||||
}
|
|
|
@ -1,13 +0,0 @@
|
||||||
Index: zlib-1.2.5/zlib.h
|
|
||||||
===================================================================
|
|
||||||
--- zlib-1.2.5.orig/zlib.h
|
|
||||||
+++ zlib-1.2.5/zlib.h
|
|
||||||
@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
|
|
||||||
# define gzoffset gzoffset64
|
|
||||||
# define adler32_combine adler32_combine64
|
|
||||||
# define crc32_combine crc32_combine64
|
|
||||||
-# ifdef _LARGEFILE64_SOURCE
|
|
||||||
+# ifndef _LARGEFILE64_SOURCE
|
|
||||||
ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
|
|
||||||
ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
|
|
||||||
ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
|
|
Loading…
Reference in a new issue