mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/xf86-video-armsoc-chromium to r242.0c8aa45-1
This commit is contained in:
parent
90b5dc157b
commit
3eace5c548
2 changed files with 34 additions and 8 deletions
|
@ -1,15 +1,29 @@
|
|||
From afce5d5689b0548767c146dfe3b21bf5f603010f Mon Sep 17 00:00:00 2001
|
||||
From a55a580a886eaf7bb108e407f412031a444d26d1 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 23 May 2014 21:01:56 -0600
|
||||
Subject: [PATCH] compat for newer xorg
|
||||
|
||||
---
|
||||
src/bo_exynos.c | 1 +
|
||||
src/compat-api.h | 2 +-
|
||||
src/drmmode_display.c | 5 -----
|
||||
src/omap_driver.c | 1 -
|
||||
src/omap_driver.h | 1 -
|
||||
4 files changed, 1 insertion(+), 8 deletions(-)
|
||||
src/omap_dumb.c | 1 +
|
||||
6 files changed, 3 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/bo_exynos.c b/src/bo_exynos.c
|
||||
index 93604fe..e961d1e 100644
|
||||
--- a/src/bo_exynos.c
|
||||
+++ b/src/bo_exynos.c
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <sys/mman.h>
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
+#include <xorg-server.h>
|
||||
#include <xf86.h>
|
||||
#include <xf86drm.h>
|
||||
#include <xf86drmMode.h>
|
||||
diff --git a/src/compat-api.h b/src/compat-api.h
|
||||
index fa0f352..b74a582 100644
|
||||
--- a/src/compat-api.h
|
||||
|
@ -24,7 +38,7 @@ index fa0f352..b74a582 100644
|
|||
#define BLOCKHANDLER_ARGS_DECL int arg, pointer blockData, pointer pTimeout, pointer pReadmask
|
||||
#define BLOCKHANDLER_ARGS arg, blockData, pTimeout, pReadmask
|
||||
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
||||
index 810f694..093fd2e 100644
|
||||
index d318d51..cf8fa9a 100644
|
||||
--- a/src/drmmode_display.c
|
||||
+++ b/src/drmmode_display.c
|
||||
@@ -58,9 +58,6 @@
|
||||
|
@ -37,7 +51,7 @@ index 810f694..093fd2e 100644
|
|||
#include "micmap.h"
|
||||
|
||||
#include "xf86DDC.h"
|
||||
@@ -1732,8 +1729,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd)
|
||||
@@ -1687,8 +1684,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd)
|
||||
|
||||
TRACE_ENTER();
|
||||
|
||||
|
@ -59,7 +73,7 @@ index 65fff85..5223d97 100644
|
|||
|
||||
/* Cause the cursor position to be updated by the mouse signal handler: */
|
||||
diff --git a/src/omap_driver.h b/src/omap_driver.h
|
||||
index a62255f..a0dcbd6 100644
|
||||
index 9862651..b974f13 100644
|
||||
--- a/src/omap_driver.h
|
||||
+++ b/src/omap_driver.h
|
||||
@@ -40,7 +40,6 @@
|
||||
|
@ -70,6 +84,18 @@ index a62255f..a0dcbd6 100644
|
|||
#include "micmap.h"
|
||||
#include "colormapst.h"
|
||||
#include "xf86cmap.h"
|
||||
diff --git a/src/omap_dumb.c b/src/omap_dumb.c
|
||||
index a3b5152..7acf169 100644
|
||||
--- a/src/omap_dumb.c
|
||||
+++ b/src/omap_dumb.c
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
|
||||
+#include <xorg-server.h>
|
||||
#include <xf86.h>
|
||||
#include <xf86drm.h>
|
||||
#include <xf86drmMode.h>
|
||||
--
|
||||
1.9.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=xf86-video-armsoc-chromium
|
||||
pkgver=r233.4712450
|
||||
pkgver=r242.0c8aa45
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
arch=('armv7h')
|
||||
|
@ -19,7 +19,7 @@ provides=(xf86-video-armsoc)
|
|||
source=("$pkgname::git+https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
||||
'0001-compat-for-newer-xorg.patch')
|
||||
md5sums=('SKIP'
|
||||
'429bc16ad0c7fe308d90c701c1aa97d1')
|
||||
'06e739dc692095b1b50ad431f30e7f0b')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
|
|
Loading…
Reference in a new issue