mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/mesa to 12.0.2-1
This commit is contained in:
parent
5248842a6d
commit
3ec21863af
5 changed files with 5 additions and 219 deletions
|
@ -1,17 +0,0 @@
|
|||
diff --git a/src/mesa/state_tracker/st_glsl_to_tgsi.cpp b/src/mesa/state_tracker/st_glsl_to_tgsi.cpp
|
||||
index 7564119..38e2c4a 100644
|
||||
--- a/src/mesa/state_tracker/st_glsl_to_tgsi.cpp
|
||||
+++ b/src/mesa/state_tracker/st_glsl_to_tgsi.cpp
|
||||
@@ -6058,7 +6058,11 @@ st_translate_program(
|
||||
inputSemanticName[i], inputSemanticIndex[i],
|
||||
interpMode[i], 0, interpLocation[i],
|
||||
array_id, array_size);
|
||||
- i += array_size - 1;
|
||||
+
|
||||
+ GLuint base_attr = inputSlotToAttr[i];
|
||||
+ while (i + 1 < numInputs &&
|
||||
+ inputSlotToAttr[i + 1] < base_attr + array_size)
|
||||
+ ++i;
|
||||
}
|
||||
else {
|
||||
t->inputs[i] = ureg_DECL_fs_input_cyl_centroid(ureg,
|
|
@ -1,66 +0,0 @@
|
|||
From e180e9e3c830d3611a6cf7d32e988b4c28d20942 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Peres <martin.peres@linux.intel.com>
|
||||
Date: Wed, 3 Aug 2016 12:58:23 +0300
|
||||
Subject: [PATCH] i965: import prime buffers in the current context, not screen
|
||||
|
||||
This mirrors the codepath taken by DRI2 in IntelSetTexBuffer2() and
|
||||
fixes many applications when using DRI3:
|
||||
- Totem with libva on hw-accelerated decoding
|
||||
- obs-studio, using Window Capture (Xcomposite) as a Source
|
||||
- gstreamer with VAAPI
|
||||
|
||||
Cc: mesa-stable@lists.freedesktop.org
|
||||
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=71759
|
||||
Signed-off-by: Martin Peres <martin.peres@linux.intel.com>
|
||||
---
|
||||
src/mesa/drivers/dri/i965/intel_screen.c | 25 +++++++++++++++++++++++--
|
||||
1 file changed, 23 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/i965/intel_screen.c b/src/mesa/drivers/dri/i965/intel_screen.c
|
||||
index ae51c40..169d578 100644
|
||||
--- a/src/mesa/drivers/dri/i965/intel_screen.c
|
||||
+++ b/src/mesa/drivers/dri/i965/intel_screen.c
|
||||
@@ -702,8 +702,11 @@ intel_create_image_from_fds(__DRIscreen *screen,
|
||||
int *fds, int num_fds, int *strides, int *offsets,
|
||||
void *loaderPrivate)
|
||||
{
|
||||
+ GET_CURRENT_CONTEXT(ctx);
|
||||
struct intel_screen *intelScreen = screen->driverPrivate;
|
||||
+ struct brw_context *brw = brw_context(ctx);
|
||||
struct intel_image_format *f;
|
||||
+ dri_bufmgr *bufmgr;
|
||||
__DRIimage *image;
|
||||
int i, index;
|
||||
|
||||
@@ -744,8 +747,26 @@ intel_create_image_from_fds(__DRIscreen *screen,
|
||||
size = end;
|
||||
}
|
||||
|
||||
- image->bo = drm_intel_bo_gem_create_from_prime(intelScreen->bufmgr,
|
||||
- fds[0], size);
|
||||
+ /* Let's import the buffer into the current context instead of the current
|
||||
+ * screen as some applications like gstreamer, totem, or obs create multiple
|
||||
+ * X connections which end up creating multiple screens and thus multiple
|
||||
+ * buffer managers. They then proceed to use a different X connection than
|
||||
+ * the one used by the currently-bound context to call GLXBindTexImageExt()
|
||||
+ * which should then import the buffer in the current bound context and not
|
||||
+ * the current screen. This is done properly upstairs for texture management
|
||||
+ * so we need to mirror this behaviour if we don't want the kernel rejecting
|
||||
+ * our pushbuffers as the buffer would not have been imported by the same
|
||||
+ * buffer manager that sent the pushbuffer referencing it.
|
||||
+ *
|
||||
+ * If there is no context currently bound, then revert to using the screen's
|
||||
+ * buffer manager and hope for the best...
|
||||
+ */
|
||||
+ if (brw)
|
||||
+ bufmgr = brw->bufmgr;
|
||||
+ else
|
||||
+ bufmgr = intelScreen->bufmgr;
|
||||
+
|
||||
+ image->bo = drm_intel_bo_gem_create_from_prime(bufmgr, fds[0], size);
|
||||
if (image->bo == NULL) {
|
||||
free(image);
|
||||
return NULL;
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -1,76 +0,0 @@
|
|||
From 9ce52baf7f479d506bcea17a371dcf2fad92f139 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Christian=20K=C3=B6nig?= <christian.koenig@amd.com>
|
||||
Date: Wed, 13 Jul 2016 14:54:31 +0200
|
||||
Subject: [PATCH] st/mesa: fix reference counting bug in st_vdpau
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Otherwise we leak the resources created for the DMA-buf descriptors.
|
||||
|
||||
Signed-off-by: Christian König <christian.koenig@amd.com>
|
||||
Cc: 12.0 <mesa-stable@lists.freedesktop.org>
|
||||
Tested-and-Reviewed by: Leo Liu <leo.liu@amd.com>
|
||||
Ack-by: Tom St Denis <tom.stdenis@amd.com>
|
||||
---
|
||||
src/mesa/state_tracker/st_vdpau.c | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/state_tracker/st_vdpau.c b/src/mesa/state_tracker/st_vdpau.c
|
||||
index dffa52f..4f599dd 100644
|
||||
--- a/src/mesa/state_tracker/st_vdpau.c
|
||||
+++ b/src/mesa/state_tracker/st_vdpau.c
|
||||
@@ -65,6 +65,7 @@ st_vdpau_video_surface_gallium(struct gl_context *ctx, const void *vdpSurface,
|
||||
|
||||
struct pipe_video_buffer *buffer;
|
||||
struct pipe_sampler_view **samplers;
|
||||
+ struct pipe_resource *res = NULL;
|
||||
|
||||
getProcAddr = (void *)ctx->vdpGetProcAddress;
|
||||
if (getProcAddr(device, VDP_FUNC_ID_VIDEO_SURFACE_GALLIUM, (void**)&f))
|
||||
@@ -82,7 +83,8 @@ st_vdpau_video_surface_gallium(struct gl_context *ctx, const void *vdpSurface,
|
||||
if (!sv)
|
||||
return NULL;
|
||||
|
||||
- return sv->texture;
|
||||
+ pipe_resource_reference(&res, sv->texture);
|
||||
+ return res;
|
||||
}
|
||||
|
||||
static struct pipe_resource *
|
||||
@@ -90,13 +92,15 @@ st_vdpau_output_surface_gallium(struct gl_context *ctx, const void *vdpSurface)
|
||||
{
|
||||
int (*getProcAddr)(uint32_t device, uint32_t id, void **ptr);
|
||||
uint32_t device = (uintptr_t)ctx->vdpDevice;
|
||||
+ struct pipe_resource *res = NULL;
|
||||
VdpOutputSurfaceGallium *f;
|
||||
|
||||
getProcAddr = (void *)ctx->vdpGetProcAddress;
|
||||
if (getProcAddr(device, VDP_FUNC_ID_OUTPUT_SURFACE_GALLIUM, (void**)&f))
|
||||
return NULL;
|
||||
|
||||
- return f((uintptr_t)vdpSurface);
|
||||
+ pipe_resource_reference(&res, f((uintptr_t)vdpSurface));
|
||||
+ return res;
|
||||
}
|
||||
|
||||
static struct pipe_resource *
|
||||
@@ -208,6 +212,7 @@ st_vdpau_map_surface(struct gl_context *ctx, GLenum target, GLenum access,
|
||||
/* do we have different screen objects ? */
|
||||
if (res->screen != st->pipe->screen) {
|
||||
_mesa_error(ctx, GL_INVALID_OPERATION, "VDPAUMapSurfacesNV");
|
||||
+ pipe_resource_reference(&res, NULL);
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -241,6 +246,7 @@ st_vdpau_map_surface(struct gl_context *ctx, GLenum target, GLenum access,
|
||||
stObj->surface_format = res->format;
|
||||
|
||||
_mesa_dirty_texobj(ctx, texObj);
|
||||
+ pipe_resource_reference(&res, NULL);
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -1,38 +0,0 @@
|
|||
From 134d6e4e4f980d738361bfcae1daedb8cc58b5df Mon Sep 17 00:00:00 2001
|
||||
From: Leo Liu <leo.liu@amd.com>
|
||||
Date: Thu, 14 Jul 2016 09:19:59 -0400
|
||||
Subject: [PATCH] vl/dri3: fix a memory leak from front buffer
|
||||
|
||||
Inspired by fix for mem leak of vdpau interop, resource_from_handle
|
||||
set texture reference count, that need to be decreased and released,
|
||||
recall there is a similar case for DRI3, that is with VA-API glx
|
||||
extension, there is temporary TFP(texture from pixmap), we target it
|
||||
through dma-buf. leak happens when without count down the reference.
|
||||
|
||||
Checked and found with mpv vo=opengl case, there only one static TFP,
|
||||
the leak happens once, but for totem player using gstreamer VA-API glx,
|
||||
the dynamic TFP for each frame, so leak quite a bit.
|
||||
|
||||
This fixes mem leak for mpv and totem.
|
||||
|
||||
Signed-off-by: Leo Liu <leo.liu@amd.com>
|
||||
Cc: "12.0" <mesa-stable@lists.freedesktop.org>
|
||||
---
|
||||
src/gallium/auxiliary/vl/vl_winsys_dri3.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/gallium/auxiliary/vl/vl_winsys_dri3.c b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
index f7f572e..493e645 100644
|
||||
--- a/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
+++ b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
@@ -89,6 +89,7 @@ dri3_free_front_buffer(struct vl_dri3_screen *scrn,
|
||||
{
|
||||
xcb_sync_destroy_fence(scrn->conn, buffer->sync_fence);
|
||||
xshmfence_unmap_shm(buffer->shm_fence);
|
||||
+ pipe_resource_reference(&buffer->texture, NULL);
|
||||
FREE(buffer);
|
||||
}
|
||||
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -10,8 +10,8 @@
|
|||
|
||||
pkgbase=mesa
|
||||
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
|
||||
pkgver=12.0.1
|
||||
pkgrel=7
|
||||
pkgver=12.0.2
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'elfutils' 'llvm'
|
||||
|
@ -21,19 +21,11 @@ license=('custom')
|
|||
options=('!libtool')
|
||||
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
|
||||
LICENSE
|
||||
remove-libpthread-stubs.patch
|
||||
0001-st-mesa-fix-reference-counting-bug-in-st_vdpau.patch
|
||||
0002-vl-dri3-fix-a-memory-leak-from-front-buffer.patch
|
||||
0001-Mesa-dev-st_glsl_to_tgsi-overlord-fix.patch
|
||||
0001-i965-import-prime-buffers-in-the-current-context-not.patch)
|
||||
sha256sums=('bab24fb79f78c876073527f515ed871fc9c81d816f66c8a0b051d8d653896389'
|
||||
remove-libpthread-stubs.patch)
|
||||
sha256sums=('d957a5cc371dcd7ff2aa0d87492f263aece46f79352f4520039b58b1f32552cb'
|
||||
'SKIP'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||
'd82c329e89754266eb1538df29b94d33692a66e3b6882b2cee78f4d5aab4a39c'
|
||||
'ccc8ea7f4e38f2dc26fd29150929e943aac5bc9b56bd3eddec882c6ccd1d64a5'
|
||||
'f6c17257e96182ce51b85ef75cef4f6c205b00dfbf8fc1089cd77c4a3eda6981'
|
||||
'c1b650d2b3512d5f8f463f1974a28ed6b88e7e1936c5cfe1034ab97696d1de14'
|
||||
'6d6159b9080d75f653dbd43284b5138264612a7f4b895c37859f984d1ea2246d')
|
||||
'd82c329e89754266eb1538df29b94d33692a66e3b6882b2cee78f4d5aab4a39c')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
|
||||
prepare() {
|
||||
|
@ -42,15 +34,6 @@ prepare() {
|
|||
# Now mesa checks for libpthread-stubs - so remove the check
|
||||
patch -Np1 -i ../remove-libpthread-stubs.patch
|
||||
|
||||
# fix memory leaks - merged upstream
|
||||
patch -Np1 -i ../0001-st-mesa-fix-reference-counting-bug-in-st_vdpau.patch
|
||||
patch -Np1 -i ../0002-vl-dri3-fix-a-memory-leak-from-front-buffer.patch
|
||||
# fix rendering in overlord series games - merged upstream
|
||||
patch -Np1 -i ../0001-Mesa-dev-st_glsl_to_tgsi-overlord-fix.patch
|
||||
# fix https://bugs.freedesktop.org/show_bug.cgi?id=71759 / FS#50240
|
||||
# reverted because of it segfault X with modesetting/intel
|
||||
#patch -Np1 -i ../0001-i965-import-prime-buffers-in-the-current-context-not.patch
|
||||
|
||||
autoreconf -fiv
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue