community/grpc to 1.41.0-1

This commit is contained in:
David Beauchamp 2021-09-27 20:13:43 -04:00
parent b5f988b5bf
commit 3ef927a41c
4 changed files with 27 additions and 34 deletions

View file

@ -7,7 +7,7 @@
pkgbase='grpc'
pkgname=('grpc' 'python-grpcio' 'php-grpc' 'php7-grpc' 'grpc-cli')
pkgver=1.39.1
pkgver=1.41.0
_gtestver=c9ccac7cb7345901884aabf5d1a786cfa6e2f397
pkgrel=1
pkgdesc="High performance, open source, general RPC framework that puts mobile and HTTP/2 first."
@ -18,14 +18,16 @@ makedepends=('re2' 're2c' 'protobuf' 'php' 'php7' 'c-ares' 'openssl' 'chrpath' '
'cmake' 'benchmark' 'python-setuptools' 'abseil-cpp' 'ninja')
source=("https://github.com/grpc/grpc/archive/v$pkgver/$pkgbase-$pkgver.tar.gz"
"https://github.com/google/googletest/archive/$_gtestver/googletest-$_gtestver.tar.gz"
"grpc-assert.patch"
"python-grpcio-use-system-abseil.patch")
sha256sums=('024118069912358e60722a2b7e507e9c3b51eeaeee06e2dd9d95d9c16f6639ec'
sha256sums=('e5fb30aae1fa1cffa4ce00aa0bbfab908c0b899fcf0bbc30e268367d660d8656'
'443d383db648ebb8e391382c0ab63263b7091d03197f304390baac10f178a468'
'f8b9cf84e16ac66d9cb74c954362b037e69ae98a61d16fc1889ad15831bee588')
'ec0fc6af1b191da8660d1fd807da0f38f1dca1e6ee3bc7abbe69d5bc2049116f'
'3cfb289266f9d2697b917e4400f18a6592f95a99e658e401c1332870b219358b')
prepare() {
cd "$srcdir/$pkgbase-$pkgver"
patch -Np1 -i ../grpc-assert.patch
patch -Np1 -i ../python-grpcio-use-system-abseil.patch
ln -sf "$srcdir/googletest-$_gtestver/"{googlemock,googletest} \

View file

@ -0,0 +1,12 @@
diff --git a/src/core/lib/promise/detail/basic_seq.h b/src/core/lib/promise/detail/basic_seq.h
index 72b91f9..a7be768 100644
--- a/src/core/lib/promise/detail/basic_seq.h
+++ b/src/core/lib/promise/detail/basic_seq.h
@@ -16,6 +16,7 @@
#define GRPC_CORE_LIB_PROMISE_DETAIL_BASIC_SEQ_H
#include <grpc/impl/codegen/port_platform.h>
+#include <assert.h>
#include "absl/types/variant.h"
#include "absl/utility/utility.h"

View file

@ -1,22 +0,0 @@
From d30b04ed7b53f36fded3f94c32ebaed88cfa1232 Mon Sep 17 00:00:00 2001
From: Esun Kim <veblush@google.com>
Date: Wed, 17 Mar 2021 10:00:44 -0700
Subject: [PATCH] Fix status error (#25731)
---
test/cpp/qps/parse_json.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/cpp/qps/parse_json.cc b/test/cpp/qps/parse_json.cc
index 8777f171420d..f3ac1052d4d5 100644
--- a/test/cpp/qps/parse_json.cc
+++ b/test/cpp/qps/parse_json.cc
@@ -34,7 +34,7 @@ void ParseJson(const std::string& json, const std::string& type,
auto status = JsonToBinaryString(
type_resolver.get(), "type.googleapis.com/" + type, json, &binary);
if (!status.ok()) {
- std::string errmsg(status.error_message());
+ std::string errmsg(status.message());
gpr_log(GPR_ERROR, "Failed to convert json to binary: errcode=%d msg=%s",
status.code(), errmsg.c_str());
gpr_log(GPR_ERROR, "JSON: %s", json.c_str());

View file

@ -1,15 +1,16 @@
diff -Naur grpc-1.37.0-original/setup.py grpc-1.37.0/setup.py
--- grpc-1.37.0-original/setup.py 2021-04-06 18:48:56.000000000 -0400
+++ grpc-1.37.0/setup.py 2021-04-08 15:34:35.182802019 -0400
@@ -28,6 +28,7 @@
diff --git a/setup.py b/setup.py
index 4d34c43..5826663 100644
--- a/setup.py
+++ b/setup.py
@@ -29,6 +29,7 @@ from distutils import extension as _extension
from distutils import util
import os
import os.path
+import pathlib
import pkg_resources
import platform
import re
@@ -154,6 +155,11 @@
import shlex
@@ -155,6 +156,11 @@ BUILD_WITH_SYSTEM_CARES = _env_bool_value('GRPC_PYTHON_BUILD_SYSTEM_CARES',
# runtime, the shared library must be installed
BUILD_WITH_SYSTEM_RE2 = _env_bool_value('GRPC_PYTHON_BUILD_SYSTEM_RE2', 'False')
@ -21,7 +22,7 @@ diff -Naur grpc-1.37.0-original/setup.py grpc-1.37.0/setup.py
# Export this variable to force building the python extension with a statically linked libstdc++.
# At least on linux, this is normally not needed as we can build manylinux-compatible wheels on linux just fine
# without statically linking libstdc++ (which leads to a slight increase in the wheel size).
@@ -296,6 +302,10 @@
@@ -297,6 +303,10 @@ if BUILD_WITH_SYSTEM_RE2:
CORE_C_FILES = filter(lambda x: 'third_party/re2' not in x, CORE_C_FILES)
RE2_INCLUDE = (os.path.join('/usr', 'include', 're2'),)
@ -32,7 +33,7 @@ diff -Naur grpc-1.37.0-original/setup.py grpc-1.37.0/setup.py
EXTENSION_INCLUDE_DIRECTORIES = ((PYTHON_STEM,) + CORE_INCLUDE + ABSL_INCLUDE +
ADDRESS_SORTING_INCLUDE + CARES_INCLUDE +
RE2_INCLUDE + SSL_INCLUDE + UPB_INCLUDE +
@@ -325,6 +335,10 @@
@@ -326,6 +336,10 @@ if BUILD_WITH_SYSTEM_CARES:
EXTENSION_LIBRARIES += ('cares',)
if BUILD_WITH_SYSTEM_RE2:
EXTENSION_LIBRARIES += ('re2',)