mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libvpx to 1.6.0-2
This commit is contained in:
parent
b2e5a958dd
commit
3f0277923b
2 changed files with 41 additions and 61 deletions
|
@ -1,14 +1,15 @@
|
|||
# $Id: PKGBUILD 149273 2012-02-06 17:33:27Z ibiru $
|
||||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
||||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# $Id$
|
||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix building
|
||||
# - disable neon and neon-asm
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.5.0
|
||||
pkgrel=4
|
||||
pkgver=1.6.0
|
||||
pkgrel=2
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.webmproject.org/'
|
||||
|
@ -16,42 +17,44 @@ license=('BSD')
|
|||
depends=('glibc' 'gcc-libs')
|
||||
makedepends=('yasm' 'git')
|
||||
provides=('libvpx.so')
|
||||
source=($pkgname-$pkgver.tar.gz::https://github.com/webmproject/libvpx/archive/v$pkgver.tar.gz
|
||||
0001-Fix-for-issue-1114-compile-error.patch
|
||||
source=("libvpx-${pkgver}.tar.gz::https://github.com/webmproject/libvpx/archive/v${pkgver}.tar.gz"
|
||||
fix-armhf-link.patch)
|
||||
md5sums=('0c662bc7525afe281badb3175140d35c'
|
||||
'a03e318d5d92270ed826b55d6d9dc828'
|
||||
'a2d92d01ecc336fe81682daa8a7fdafa')
|
||||
sha256sums=('e2fc00c9f60c76f91a1cde16a2356e33a45b76a5a5a1370df65fd57052a4994a'
|
||||
'66cbce8fc6a00e418fdc6d08b196861b699f45b1db115b2c707b9a70d1081348')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# https://bugs.chromium.org/p/webm/issues/detail?id=1114
|
||||
patch -Np1 -i ../0001-Fix-for-issue-1114-compile-error.patch
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
patch -p1 -i ../fix-armhf-link.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--enable-vp8 \
|
||||
--enable-vp9 \
|
||||
--enable-vp9-highbitdepth \
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
--enable-runtime-cpu-detect \
|
||||
--enable-shared \
|
||||
--enable-postproc \
|
||||
--enable-pic \
|
||||
--enable-experimental --enable-spatial-svc \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs \
|
||||
--enable-vp8 \
|
||||
--enable-postproc \
|
||||
--enable-vp9 \
|
||||
--enable-vp9-highbitdepth \
|
||||
--enable-experimental \
|
||||
--enable-spatial-svc \
|
||||
--disable-neon --disable-neon-asm
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DIST_DIR="$pkgdir/usr" install
|
||||
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
cd libvpx-${pkgver}
|
||||
|
||||
make DIST_DIR="${pkgdir}"/usr install
|
||||
|
||||
install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libvpx/
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 25c9f80..1675044 100644
|
||||
index 4f0071b..56abe0e 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -623,10 +623,14 @@ process_common_toolchain() {
|
||||
|
||||
# detect tgt_isa
|
||||
case "$gcctarget" in
|
||||
@@ -680,6 +680,10 @@ process_common_toolchain() {
|
||||
aarch64*)
|
||||
tgt_isa=arm64
|
||||
;;
|
||||
+ armv6*-gnueabihf)
|
||||
+ tgt_isa=armv6
|
||||
+ float_abi=hard
|
||||
|
@ -13,12 +13,7 @@ index 25c9f80..1675044 100644
|
|||
armv6*)
|
||||
tgt_isa=armv6
|
||||
;;
|
||||
- armv7*-hardfloat*)
|
||||
+ armv7*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
;;
|
||||
@@ -634,6 +638,10 @@ process_common_toolchain() {
|
||||
@@ -691,6 +695,10 @@ process_common_toolchain() {
|
||||
tgt_isa=armv7
|
||||
float_abi=softfp
|
||||
;;
|
||||
|
@ -29,7 +24,7 @@ index 25c9f80..1675044 100644
|
|||
*x86_64*|*amd64*)
|
||||
tgt_isa=x86_64
|
||||
;;
|
||||
@@ -811,7 +819,7 @@ process_common_toolchain() {
|
||||
@@ -876,7 +884,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
|
@ -38,25 +33,7 @@ index 25c9f80..1675044 100644
|
|||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -825,13 +833,16 @@ process_common_toolchain() {
|
||||
soft_enable media
|
||||
soft_enable fast_unaligned
|
||||
;;
|
||||
+ armv5)
|
||||
+ soft_enable media
|
||||
+ soft_enable fast_unaligned
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
asm_conversion_cmd="cat"
|
||||
|
||||
case ${tgt_cc} in
|
||||
gcc)
|
||||
- CROSS=${CROSS:-arm-none-linux-gnueabi-}
|
||||
link_with_cc=gcc
|
||||
setup_gnu_toolchain
|
||||
arch_int=${tgt_isa##armv}
|
||||
@@ -839,13 +850,6 @@ process_common_toolchain() {
|
||||
@@ -927,13 +935,6 @@ process_common_toolchain() {
|
||||
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
|
@ -70,9 +47,9 @@ index 25c9f80..1675044 100644
|
|||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -854,8 +858,8 @@ EOF
|
||||
check_add_asflags -mfpu=neon
|
||||
fi
|
||||
@@ -945,8 +946,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
- check_add_cflags -march=${tgt_isa}
|
||||
- check_add_asflags -march=${tgt_isa}
|
||||
|
@ -82,7 +59,7 @@ index 25c9f80..1675044 100644
|
|||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index f3708f9..7fb89ca 100755
|
||||
index f82ee04..911733f 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -97,6 +97,7 @@ EOF
|
||||
|
@ -90,6 +67,6 @@ index f3708f9..7fb89ca 100755
|
|||
# all_platforms is a list of all supported target platforms. Maintain
|
||||
# alphabetically by architecture, generic-gnu last.
|
||||
+all_platforms="${all_platforms} armv5te-linux-gcc"
|
||||
all_platforms="${all_platforms} armv6-darwin-gcc"
|
||||
all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
all_platforms="${all_platforms} arm64-linux-gcc"
|
||||
all_platforms="${all_platforms} armv6-linux-rvct"
|
||||
all_platforms="${all_platforms} armv6-linux-gcc"
|
||||
|
|
Loading…
Reference in a new issue