mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java8-openjdk: fix
This commit is contained in:
parent
a0c86939f0
commit
3f3464da09
3 changed files with 6 additions and 63 deletions
|
@ -1,55 +0,0 @@
|
|||
# HG changeset patch
|
||||
# User coleenp
|
||||
# Date 1525713256 -3600
|
||||
# Mon May 07 18:14:16 2018 +0100
|
||||
# Node ID bcbc64dfb629c5f188bbf59b8f986ad95963ed60
|
||||
# Parent 07a1135a327362f157955d470fad5df07cc35164
|
||||
8141570, PR3548: Fix Zero interpreter build for --disable-precompiled-headers
|
||||
Summary: change to include atomic.inline.hpp and allocation.inline.hpp only in .cpp files and some build fixes from Kim to build on ubuntu without devkits
|
||||
Reviewed-by: kbarrett, sgehwolf, erikj
|
||||
|
||||
diff --git openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make openjdk/hotspot/make/linux/makefiles/zeroshark.make
|
||||
--- openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make
|
||||
+++ openjdk/hotspot/make/linux/makefiles/zeroshark.make
|
||||
@@ -1,5 +1,5 @@
|
||||
#
|
||||
-# Copyright (c) 2003, 2005, Oracle and/or its affiliates. All rights reserved.
|
||||
+# Copyright (c) 2003, 2015, Oracle and/or its affiliates. All rights reserved.
|
||||
# Copyright 2007, 2008 Red Hat, Inc.
|
||||
# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
#
|
||||
@@ -25,8 +25,15 @@
|
||||
|
||||
# Setup common to Zero (non-Shark) and Shark versions of VM
|
||||
|
||||
-# override this from the main file because some version of llvm do not like -Wundef
|
||||
-WARNING_FLAGS = -Wpointer-arith -Wsign-compare -Wunused-function -Wunused-value
|
||||
+# Some versions of llvm do not like -Wundef
|
||||
+ifeq ($(USE_CLANG), true)
|
||||
+ WARNING_FLAGS += -Wno-undef
|
||||
+endif
|
||||
+# Suppress some warning flags that are normally turned on for hotspot,
|
||||
+# because some of the zero code has not been updated accordingly.
|
||||
+WARNING_FLAGS += -Wno-return-type \
|
||||
+ -Wno-format-nonliteral -Wno-format-security \
|
||||
+ -Wno-maybe-uninitialized
|
||||
|
||||
# The copied fdlibm routines in sharedRuntimeTrig.o must not be optimized
|
||||
OPT_CFLAGS/sharedRuntimeTrig.o = $(OPT_CFLAGS/NOOPT)
|
||||
@@ -42,5 +49,3 @@
|
||||
ifeq ($(ARCH_DATA_MODEL), 64)
|
||||
CFLAGS += -D_LP64=1
|
||||
endif
|
||||
-
|
||||
-OPT_CFLAGS/compactingPermGenGen.o = -O1
|
||||
diff --git openjdk.orig/hotspot/src/share/vm/runtime/java.cpp openjdk/hotspot/src/share/vm/runtime/java.cpp
|
||||
--- openjdk.orig/hotspot/src/share/vm/runtime/java.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/runtime/java.cpp
|
||||
@@ -45,6 +45,7 @@
|
||||
#include "runtime/arguments.hpp"
|
||||
#include "runtime/biasedLocking.hpp"
|
||||
#include "runtime/compilationPolicy.hpp"
|
||||
+#include "runtime/deoptimization.hpp"
|
||||
#include "runtime/fprofiler.hpp"
|
||||
#include "runtime/init.hpp"
|
||||
#include "runtime/interfaceSupport.hpp"
|
|
@ -17,8 +17,8 @@ diff --git openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make openjdk/hots
|
|||
# Copyright 2007, 2008 Red Hat, Inc.
|
||||
# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
#
|
||||
@@ -29,11 +29,6 @@
|
||||
ifeq ($(USE_CLANG), true)
|
||||
@@ -29,12 +29,6 @@
|
||||
ifeq ($(JVM_VARIANT_ZEROSHARK), true)
|
||||
WARNING_FLAGS += -Wno-undef
|
||||
endif
|
||||
-# Suppress some warning flags that are normally turned on for hotspot,
|
||||
|
@ -26,9 +26,10 @@ diff --git openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make openjdk/hots
|
|||
-WARNING_FLAGS += -Wno-return-type \
|
||||
- -Wno-format-nonliteral -Wno-format-security \
|
||||
- -Wno-maybe-uninitialized
|
||||
-
|
||||
|
||||
# The copied fdlibm routines in sharedRuntimeTrig.o must not be optimized
|
||||
OPT_CFLAGS/sharedRuntimeTrig.o = $(OPT_CFLAGS/NOOPT)
|
||||
# If FDLIBM_CFLAGS is non-empty it holds CFLAGS needed to be passed to
|
||||
# the compiler so as to be able to produce optimized objects
|
||||
diff --git openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
+++ openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
|
|
|
@ -34,7 +34,6 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
8141570-pr3548.patch
|
||||
8143245-pr3548.patch
|
||||
8197981-pr3548.patch)
|
||||
|
||||
|
@ -46,8 +45,7 @@ sha256sums=('7956f23558c639c9cba3c6b5c6eb88026c4818b99e565131bf753c32cf002b7f'
|
|||
'13c2cd4cd1c3d6e6b38204589a9799668e9e76a1ba0794b85024a600ca4edea7'
|
||||
'1fedb675c31698b18abfe0d86b14cf63beb95ecfad1b48ea65d27ebb5f7f0c94'
|
||||
'c04ecd3e6ed6d376da63c0cf6037d2877295e84283333070324d4a718be2b1f3'
|
||||
'f3def2ef78d96f136d9d0a103c84028789ae9e0de961a11240091b6ae60d8212'
|
||||
'84db3cb182a998ba184c90f56636e5398b839b3dc7128eaeba966d78c0b6fc56'
|
||||
'305c779ab087853a0eba3532355225be52a779c38b5652fc7485794533d8cf8d'
|
||||
'c0bb1ae19f08c221156df15d7d8c5a4168c55179a186f3054dd4ac0591ec8501')
|
||||
|
||||
case "${CARCH}" in
|
||||
|
@ -73,7 +71,6 @@ prepare() {
|
|||
|
||||
# Fix zero with up to date GCC and glibc
|
||||
cd ../hotspot-${_repo_ver}
|
||||
patch -p2 -i ../8141570-pr3548.patch
|
||||
patch -p2 -i ../8143245-pr3548.patch
|
||||
patch -p2 -i ../8197981-pr3548.patch
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue