mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/ffmpeg to 3.4-1
This commit is contained in:
parent
693ab9420d
commit
3f7abf10c4
2 changed files with 8 additions and 112 deletions
|
@ -9,7 +9,7 @@
|
|||
# - use -fPIC in host cflags for armv7 to fix print_options.c compile
|
||||
|
||||
pkgname=ffmpeg
|
||||
pkgver=3.3.4
|
||||
pkgver=3.4
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc='Complete solution to record, convert and stream audio and video'
|
||||
|
@ -19,28 +19,20 @@ license=('GPL3')
|
|||
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
|
||||
'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
|
||||
'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau'
|
||||
'libwebp' 'libx11' 'libxcb' 'opencore-amr' 'openjpeg2' 'opus'
|
||||
'schroedinger' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
|
||||
'libwebp' 'libx11' 'libxcb' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
|
||||
'speex' 'v4l-utils' 'xz' 'zlib'
|
||||
'libass.so' 'libbluray.so' 'libfreetype.so' 'libvidstab.so'
|
||||
'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
|
||||
'libx264.so' 'libx265.so' 'libxvidcore.so')
|
||||
'libvorbisenc.so' 'libvorbis.so' 'libvpx.so' 'libx264.so' 'libx265.so'
|
||||
'libxvidcore.so')
|
||||
makedepends=('ladspa' 'libvdpau' 'yasm')
|
||||
optdepends=('ladspa: LADSPA filters')
|
||||
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
|
||||
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
|
||||
'libswscale.so')
|
||||
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
|
||||
'ffmpeg-openjpeg2.2.patch')
|
||||
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc})
|
||||
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
|
||||
sha256sums=('98b97e1b908dfeb6aeb6d407e5a5eacdfc253a40c2d195f5867ed2d1d46ea957'
|
||||
'SKIP'
|
||||
'490598f78d7879af8ef5b8d7f92ada83d0ee64f9609f6c7b989eb331c2539f68')
|
||||
|
||||
prepare() {
|
||||
cd ffmpeg-${pkgver}
|
||||
|
||||
patch -Np1 -i ../ffmpeg-openjpeg2.2.patch
|
||||
}
|
||||
sha256sums=('aeee06e4d8b18d852c61ebbfe5e1bb7014b1e118e8728c1c2115f91e51bffbef'
|
||||
'SKIP')
|
||||
|
||||
build() {
|
||||
cd ffmpeg-${pkgver}
|
||||
|
@ -72,7 +64,6 @@ build() {
|
|||
--enable-libopenjpeg \
|
||||
--enable-libopus \
|
||||
--enable-libpulse \
|
||||
--enable-libschroedinger \
|
||||
--enable-libsoxr \
|
||||
--enable-libspeex \
|
||||
--enable-libssh \
|
||||
|
|
|
@ -1,95 +0,0 @@
|
|||
diff -rupN ffmpeg-3.3.3.orig/configure ffmpeg-3.3.3/configure
|
||||
--- ffmpeg-3.3.3.orig/configure 2017-07-29 19:49:29.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/configure 2017-08-15 13:21:28.782566614 +0200
|
||||
@@ -1875,6 +1875,7 @@ HEADERS_LIST="
|
||||
machine_ioctl_meteor_h
|
||||
malloc_h
|
||||
opencv2_core_core_c_h
|
||||
+ openjpeg_2_2_openjpeg_h
|
||||
openjpeg_2_1_openjpeg_h
|
||||
openjpeg_2_0_openjpeg_h
|
||||
openjpeg_1_5_openjpeg_h
|
||||
@@ -5805,7 +5806,9 @@ enabled libopencv && { check_hea
|
||||
require opencv opencv2/core/core_c.h cvCreateImageHeader -lopencv_core -lopencv_imgproc; } ||
|
||||
require_pkg_config opencv opencv/cxcore.h cvCreateImageHeader; }
|
||||
enabled libopenh264 && require_pkg_config openh264 wels/codec_api.h WelsGetCodecVersion
|
||||
-enabled libopenjpeg && { { check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
+enabled libopenjpeg && { { check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
+ check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 ||
|
||||
+ { check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 ||
|
||||
{ check_lib openjpeg-2.0/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
{ check_lib openjpeg-1.5/openjpeg.h opj_version -lopenjpeg -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
diff -rupN ffmpeg-3.3.3.orig/libavcodec/libopenjpegdec.c ffmpeg-3.3.3/libavcodec/libopenjpegdec.c
|
||||
--- ffmpeg-3.3.3.orig/libavcodec/libopenjpegdec.c 2017-07-29 19:49:30.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/libavcodec/libopenjpegdec.c 2017-08-15 13:21:28.869233484 +0200
|
||||
@@ -34,7 +34,9 @@
|
||||
#include "internal.h"
|
||||
#include "thread.h"
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H
|
||||
+# include <openjpeg-2.2/openjpeg.h>
|
||||
+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
# include <openjpeg-2.1/openjpeg.h>
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# include <openjpeg-2.0/openjpeg.h>
|
||||
@@ -44,7 +46,7 @@
|
||||
# include <openjpeg.h>
|
||||
#endif
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# define OPENJPEG_MAJOR_VERSION 2
|
||||
# define OPJ(x) OPJ_##x
|
||||
#else
|
||||
@@ -429,7 +431,7 @@ static int libopenjpeg_decode_frame(AVCo
|
||||
opj_stream_set_read_function(stream, stream_read);
|
||||
opj_stream_set_skip_function(stream, stream_skip);
|
||||
opj_stream_set_seek_function(stream, stream_seek);
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &reader, NULL);
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &reader);
|
||||
diff -rupN ffmpeg-3.3.3.orig/libavcodec/libopenjpegenc.c ffmpeg-3.3.3/libavcodec/libopenjpegenc.c
|
||||
--- ffmpeg-3.3.3.orig/libavcodec/libopenjpegenc.c 2017-07-29 19:49:30.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/libavcodec/libopenjpegenc.c 2017-08-15 13:21:28.869233484 +0200
|
||||
@@ -32,7 +32,9 @@
|
||||
#include "avcodec.h"
|
||||
#include "internal.h"
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H
|
||||
+# include <openjpeg-2.2/openjpeg.h>
|
||||
+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
# include <openjpeg-2.1/openjpeg.h>
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# include <openjpeg-2.0/openjpeg.h>
|
||||
@@ -42,7 +44,7 @@
|
||||
# include <openjpeg.h>
|
||||
#endif
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# define OPENJPEG_MAJOR_VERSION 2
|
||||
# define OPJ(x) OPJ_##x
|
||||
#else
|
||||
@@ -305,7 +307,7 @@ static av_cold int libopenjpeg_encode_in
|
||||
|
||||
opj_set_default_encoder_parameters(&ctx->enc_params);
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
switch (ctx->cinema_mode) {
|
||||
case OPJ_CINEMA2K_24:
|
||||
ctx->enc_params.rsiz = OPJ_PROFILE_CINEMA_2K;
|
||||
@@ -769,7 +771,7 @@ static int libopenjpeg_encode_frame(AVCo
|
||||
opj_stream_set_write_function(stream, stream_write);
|
||||
opj_stream_set_skip_function(stream, stream_skip);
|
||||
opj_stream_set_seek_function(stream, stream_seek);
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &writer, NULL);
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &writer);
|
Loading…
Reference in a new issue