mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/linux-armv7 to 3.19.1-2
This commit is contained in:
parent
007d908267
commit
3f81ed4783
7 changed files with 253 additions and 21 deletions
|
@ -1,7 +1,7 @@
|
|||
From 7ba704a48c49367dda65d1297a4c06a1eb4e8c9c Mon Sep 17 00:00:00 2001
|
||||
From 452aada034637ea0829eab5b1bb1a00ea477c9ce Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/5] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 1/6] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.3.0
|
||||
2.3.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From efad5852f3be8cc444662c3a1ecf22edd38427d4 Mon Sep 17 00:00:00 2001
|
||||
From 66194a57f0a746b701c019b3a232e01eccf1044a Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/5] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
Subject: [PATCH 2/6] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.3.0
|
||||
2.3.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 9a1d31f61b309e8a4ebc6a4c85154f20b94af3e2 Mon Sep 17 00:00:00 2001
|
||||
From 376956621e1e1dcb506e88120b5dc660a20c1731 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/5] SMILE Plug device tree file
|
||||
Subject: [PATCH 3/6] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.0
|
||||
2.3.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 29195baa48fe67ae6c0731edc5c64dee9aaf4851 Mon Sep 17 00:00:00 2001
|
||||
From 4842967cb917e86247f9e8e356aa6ed31eb936fe Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/5] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 4/6] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -34,5 +34,5 @@ index 4f8618f..ab95bb7 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.3.0
|
||||
2.3.1
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 5d0fb467e28aeff79590ddcbe69219f4fc2b8fdf Mon Sep 17 00:00:00 2001
|
||||
From b713e58287bab6af8420ab25da220f416f6c998e Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/5] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 5/6] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
|
|||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
||||
dev->net->dev_addr) == 0) {
|
||||
--
|
||||
2.3.0
|
||||
2.3.1
|
||||
|
||||
|
|
229
core/linux-armv7/0006-USB-armory-support.patch
Normal file
229
core/linux-armv7/0006-USB-armory-support.patch
Normal file
|
@ -0,0 +1,229 @@
|
|||
From f44751f3a56d34d317e15d400527c8e92329b24f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Mar 2015 16:51:15 -0700
|
||||
Subject: [PATCH 6/6] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 197 ++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 198 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 22618d7..06e9de7 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -213,6 +213,7 @@ dtb-$(CONFIG_ARCH_MXC) += \
|
||||
imx53-smd.dtb \
|
||||
imx53-tx53-x03x.dtb \
|
||||
imx53-tx53-x13x.dtb \
|
||||
+ imx53-usbarmory.dtb \
|
||||
imx53-voipac-bsb.dtb \
|
||||
imx6dl-aristainetos_4.dtb \
|
||||
imx6dl-aristainetos_7.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
new file mode 100644
|
||||
index 0000000..ff411be
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,197 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include "imx53.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Inverse Path USB armory";
|
||||
+ compatible = "inversepath,imx53-usbarmory", "fsl,imx53";
|
||||
+};
|
||||
+
|
||||
+/ {
|
||||
+ chosen {
|
||||
+ stdout-path = &uart1;
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x70000000 0x20000000>;
|
||||
+ };
|
||||
+
|
||||
+ leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&led_pin_gpio4_27>;
|
||||
+
|
||||
+ user {
|
||||
+ label = "LED";
|
||||
+ gpios = <&gpio4 27 0>;
|
||||
+ linux,default-trigger = "heartbeat";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ aips@60000000 {
|
||||
+ sahara: crypto@63ff8000 {
|
||||
+ compatible = "fsl,imx53-sahara";
|
||||
+ reg = <0x63ff8000 0x4000>;
|
||||
+ interrupts = <19 20>;
|
||||
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
|
||||
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
|
||||
+ clock-names = "ipg", "ahb";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&esdhc1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_esdhc1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&iomuxc {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_hog>;
|
||||
+
|
||||
+ imx53-usbarmory {
|
||||
+ pinctrl_hog: hoggrp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_GPIO_0__CCM_SSI_EXT1_CLK 0x80000000
|
||||
+ MX53_PAD_GPIO_8__GPIO1_8 0x80000000
|
||||
+ MX53_PAD_PATA_DATA14__GPIO2_14 0x80000000
|
||||
+ MX53_PAD_PATA_DATA15__GPIO2_15 0x80000000
|
||||
+ MX53_PAD_EIM_DA11__GPIO3_11 0x80000000
|
||||
+ MX53_PAD_EIM_DA12__GPIO3_12 0x80000000
|
||||
+ MX53_PAD_PATA_DA_0__GPIO7_6 0x80000000
|
||||
+ MX53_PAD_PATA_DA_2__GPIO7_8 0x80000000
|
||||
+ MX53_PAD_GPIO_16__GPIO7_11 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ led_pin_gpio4_27: led_gpio4_27@0 {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_esdhc1: esdhc1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_SD1_DATA0__ESDHC1_DAT0 0x1d5
|
||||
+ MX53_PAD_SD1_DATA1__ESDHC1_DAT1 0x1d5
|
||||
+ MX53_PAD_SD1_DATA2__ESDHC1_DAT2 0x1d5
|
||||
+ MX53_PAD_SD1_DATA3__ESDHC1_DAT3 0x1d5
|
||||
+ MX53_PAD_SD1_CMD__ESDHC1_CMD 0x1d5
|
||||
+ MX53_PAD_SD1_CLK__ESDHC1_CLK 0x1d5
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_i2c1: i2c1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
|
||||
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_uart1: uart1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT10__UART1_TXD_MUX 0x1e4
|
||||
+ MX53_PAD_CSI0_DAT11__UART1_RXD_MUX 0x1e4
|
||||
+ >;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_uart1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&vpu {
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "peripheral";
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&i2c1 {
|
||||
+ ltc3589: pmic@34 {
|
||||
+ compatible = "lltc,ltc3589-2";
|
||||
+ reg = <0x34>;
|
||||
+
|
||||
+ regulators {
|
||||
+ sw1_reg: sw1 {
|
||||
+ regulator-min-microvolt = <591930>;
|
||||
+ regulator-max-microvolt = <1224671>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw2_reg: sw2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456803>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw3_reg: sw3 {
|
||||
+ regulator-min-microvolt = <1341250>;
|
||||
+ regulator-max-microvolt = <2775000>;
|
||||
+ lltc,fb-voltage-divider = <270000 100000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ bb_out_reg: bb-out {
|
||||
+ regulator-min-microvolt = <3387341>;
|
||||
+ regulator-max-microvolt = <3387341>;
|
||||
+ lltc,fb-voltage-divider = <511000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+ ldo1_reg: ldo1 {
|
||||
+ regulator-min-microvolt = <1306329>;
|
||||
+ regulator-max-microvolt = <1306329>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo2_reg: ldo2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456806>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo3_reg: ldo3 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo4_reg: ldo4 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <3200000>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.1
|
||||
|
|
@ -8,7 +8,7 @@ _srcname=linux-3.19
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=3.19.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
rcnrel=armv7-x3
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -25,15 +25,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
|||
'0003-SMILE-Plug-device-tree-file.patch'
|
||||
'0004-fix-mvsdio-eMMC-timing.patch'
|
||||
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0006-USB-armory-support.patch'
|
||||
'config')
|
||||
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
|
||||
'0f085618a0d85d406320e8bbba7fbec1'
|
||||
'SKIP'
|
||||
'98931609e0e5c0beb3dbaabfb669b872'
|
||||
'b7aa41223a0eff197ab905d9791e4ec4'
|
||||
'd71cd90ee737afc07708fae7e449d651'
|
||||
'950087add736d74afacd54bcfe8908d9'
|
||||
'd6ef79617d7e59e841f4f3d65501a6d8'
|
||||
'4e3bed0d1833836968ebf0d7947980a2'
|
||||
'b9a9593d6724ff6a1aed7e0536939b26'
|
||||
'fe82fa383a4295182182e9247f1298aa'
|
||||
'2d1065176c31853f2238718f97bf2b80'
|
||||
'377debc0c9f280d10e4c4f092b9c9bfc'
|
||||
'8497959df9de7032e46fe68d207feaac'
|
||||
'ae3dc19260a86e04658a5b6c2a71d76a')
|
||||
|
||||
prepare() {
|
||||
|
@ -51,6 +53,7 @@ prepare() {
|
|||
git apply ../0003-SMILE-Plug-device-tree-file.patch
|
||||
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
||||
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0006-USB-armory-support.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
|
|
Loading…
Reference in a new issue