mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/texlive-bin to 2012.0-2
This commit is contained in:
parent
aa66a78266
commit
3f9c21cd17
4 changed files with 97 additions and 169 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 148935 2012-02-05 11:56:42Z ibiru $
|
||||
# $Id: PKGBUILD 163857 2012-07-21 11:53:06Z remy $
|
||||
# Maintainer: Rémy Oudompheng <remy@archlinux.org>
|
||||
# Contributor: francois <francois.archlinux.org>
|
||||
|
||||
|
@ -7,16 +7,13 @@
|
|||
# - Use -fPIC with armv7
|
||||
# - --disable-cxx-runtime-hack in configure
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=texlive-bin
|
||||
pkgver=2011.3
|
||||
_luatex_ver=0.70.1
|
||||
pkgrel=8
|
||||
pkgver=2012.0
|
||||
pkgrel=2
|
||||
pkgdesc="TeX Live binaries"
|
||||
license=('GPL')
|
||||
arch=('i686' 'x86_64')
|
||||
depends=('t1lib' 'gd' 'poppler' 'libsigsegv' 'zziplib')
|
||||
depends=('t1lib' 'gd' 'poppler' 'libsigsegv' 'zziplib' 'libpng' 'libjpeg' 'freetype2')
|
||||
makedepends=('perl' 'ffcall')
|
||||
optdepends=('ed: for texconfig')
|
||||
provides=('lcdf-typetools' 'kpathsea' 'pdfjam')
|
||||
|
@ -27,33 +24,31 @@ install="texlive.install"
|
|||
source=('texmf.cnf'
|
||||
'fix-fontforge-encoding.patch'
|
||||
'09-texlive-fonts.conf'
|
||||
'luatex-poppler-0.20.patch'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20111210.tar.xz'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20111210.tar.xz'
|
||||
# "http://foundry.supelec.fr/gf/download/frsrelease/392/1730/luatex-beta-${_luatex_ver}.tar.bz2"
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/luatex-svn4356.tar.xz'
|
||||
'poppler-0.20.patch'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20120623.tar.xz'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20120623.tar.xz'
|
||||
'luatex-r4449-radical-rule-thickness.patch'
|
||||
)
|
||||
backup=(etc/texmf/web2c/texmf.cnf \
|
||||
etc/texmf/chktex/chktexrc \
|
||||
etc/texmf/web2c/mktex.cnf \
|
||||
etc/texmf/web2c/updmap.cfg \
|
||||
etc/texmf/web2c/fmtutil.cnf \
|
||||
etc/texmf/chktex/chktexrc \
|
||||
etc/texmf/dvipdfm/config/config \
|
||||
etc/texmf/dvipdfmx/dvipdfmx.cfg \
|
||||
etc/texmf/dvips/config/config.ps \
|
||||
etc/texmf/tex/generic/config/language.dat \
|
||||
etc/texmf/tex/generic/config/language.def \
|
||||
etc/texmf/tex/generic/config/pdftexconfig.tex \
|
||||
etc/texmf/ttf2pk/ttf2pk.cfg \
|
||||
etc/texmf/dvips/config/config.ps \
|
||||
etc/texmf/dvipdfmx/dvipdfmx.cfg \
|
||||
etc/texmf/dvipdfm/config/config \
|
||||
etc/texmf/web2c/fmtutil.cnf \
|
||||
etc/texmf/web2c/mktex.cnf \
|
||||
etc/texmf/xdvi/XDvi)
|
||||
|
||||
md5sums=('220a4f4cc0d915bf8fcbcb553dcee1ae'
|
||||
'bfb9716aa00c86c08cd31e5b32edeb98'
|
||||
'393a4bf67adc7ca5df2b386759d1a637'
|
||||
'52ce57c02e30a25036b6a3175c566b78'
|
||||
'c7bb38c0ab30c2b64cf4cf83a736b35c'
|
||||
'5d8f06a3683ce88a3c33e15f5ba6a858'
|
||||
'e7f0197559ef865d8c01683dab3b8526')
|
||||
'e3a664d5a7f0923f35060fe9d25d2573'
|
||||
'ac2c3c3aa765581f8504e21a5edbfb9f'
|
||||
'f315a860158cfc952c82a6d759961024'
|
||||
'5190f3295eb9a604c5f17f5bd607299b')
|
||||
|
||||
build() {
|
||||
if [ "${CARCH}" = "armv7h" ]; then
|
||||
|
@ -61,50 +56,14 @@ build() {
|
|||
export CXXFLAGS="${CXXFLAGS} -fPIC"
|
||||
fi
|
||||
|
||||
cd "$srcdir"
|
||||
# Building LuaTeX
|
||||
# cd luatex-beta-${_luatex_ver}
|
||||
cd luatex
|
||||
patch -p0 -i ../fix-fontforge-encoding.patch
|
||||
patch -Np0 -i ../luatex-poppler-0.20.patch
|
||||
(cd source && ./texk/web2c/luatexdir/getluatexsvnversion.sh)
|
||||
mkdir build
|
||||
cd build
|
||||
../source/configure --prefix=/usr -C \
|
||||
--disable-native-texlive-build \
|
||||
--with-banner-add="/Arch Linux" \
|
||||
--disable-cxx-runtime-hack \
|
||||
--disable-all-pkgs \
|
||||
--disable-dump-share \
|
||||
--disable-ptex \
|
||||
--enable-luatex \
|
||||
--without-system-ptexenc \
|
||||
--without-system-graphite \
|
||||
--without-system-icu \
|
||||
--without-system-kpathsea \
|
||||
--with-system-freetype2 \
|
||||
--with-system-poppler \
|
||||
--with-freetype2-libdir=/usr/lib \
|
||||
--with-freetype2-include=/usr/include/freetype2 \
|
||||
--with-system-gd \
|
||||
--with-system-libpng \
|
||||
--without-system-teckit \
|
||||
--with-system-zlib \
|
||||
--with-system-zziplib \
|
||||
--with-system-t1lib \
|
||||
--disable-shared \
|
||||
--disable-largefile \
|
||||
--disable-ipc \
|
||||
--without-mf-x-toolkit \
|
||||
--without-x
|
||||
make
|
||||
make -C libs/obsdcompat
|
||||
make -C texk/kpathsea
|
||||
make -C texk/web2c luatex
|
||||
|
||||
cd "$srcdir"
|
||||
cd "$srcdir"
|
||||
# this patch removes spurious error message with locale "xx_YY.utf8"
|
||||
patch -p0 -i fix-fontforge-encoding.patch
|
||||
patch -Np0 -i fix-fontforge-encoding.patch
|
||||
# fix build with poppler >= 0.20
|
||||
patch -Np0 -i poppler-0.20.patch
|
||||
# fix radical rule thickness regression in Luatex
|
||||
# http://tex.stackexchange.com/q/61952/729
|
||||
patch -Np0 -i luatex-r4449-radical-rule-thickness.patch
|
||||
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
|
||||
sed -i s/SELFAUTOPARENT/TEXMFROOT/ source/texk/tex4htk/t4ht.c
|
||||
#############################################################
|
||||
|
@ -125,28 +84,29 @@ build() {
|
|||
--mandir=/usr/share/man \
|
||||
--disable-native-texlive-build \
|
||||
--with-banner-add="/Arch Linux" \
|
||||
--disable-cxx-runtime-hack \
|
||||
--disable-multiplatform \
|
||||
--disable-dialog \
|
||||
--disable-psutils \
|
||||
--disable-t1utils \
|
||||
--disable-bibtexu \
|
||||
--disable-xz \
|
||||
--without-system-zlib \
|
||||
--without-system-zziplib \
|
||||
--without-system-pnglib \
|
||||
--with-system-zlib \
|
||||
--with-system-zziplib \
|
||||
--with-system-pnglib \
|
||||
--with-system-ncurses \
|
||||
--with-system-t1lib \
|
||||
--without-system-gd \
|
||||
--without-system-poppler \
|
||||
--without-system-xpdf \
|
||||
--without-system-freetype2 \
|
||||
--with-system-gd \
|
||||
--with-system-poppler \
|
||||
--with-system-xpdf \
|
||||
--with-system-freetype2 \
|
||||
--without-system-graphite \
|
||||
--with-freetype2-libdir=/usr/lib \
|
||||
--with-freetype2-include=/usr/include/freetype2 \
|
||||
--with-xdvi-x-toolkit=xaw \
|
||||
--disable-dump-share \
|
||||
--disable-aleph \
|
||||
--disable-luatex
|
||||
--enable-luatex
|
||||
#############################################################
|
||||
### make
|
||||
echo "-------------------------------------------------------"
|
||||
|
@ -236,13 +196,6 @@ package() {
|
|||
## remove aleph from fmtutil.cnf
|
||||
sed -i -e '/aleph/d' "$pkgdir"/usr/share/texmf/web2c/fmtutil.cnf
|
||||
|
||||
## install luatex binary
|
||||
#install -m755 "$srcdir"/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex "$pkgdir"/usr/bin/
|
||||
install -m755 "$srcdir"/luatex/build/texk/web2c/luatex "$pkgdir"/usr/bin/
|
||||
cd "$pkgdir"/usr/bin
|
||||
/bin/ln -s luatex texlua
|
||||
/bin/ln -s luatex texluac
|
||||
|
||||
## install Perl libraries
|
||||
mkdir -p "$pkgdir"/usr/share/tlpkg/TeXLive
|
||||
install -m644 "${srcdir}"/source/utils/biber/TeXLive/*.pm "$pkgdir"/usr/share/tlpkg/TeXLive
|
||||
|
@ -254,6 +207,7 @@ package() {
|
|||
# remove dangling symlinks
|
||||
_bibtexextra_scripts="
|
||||
bibexport
|
||||
listbib
|
||||
urlbst
|
||||
"
|
||||
_core_scripts="
|
||||
|
@ -261,6 +215,7 @@ afm2afm
|
|||
arlatex
|
||||
autoinst
|
||||
bundledoc
|
||||
checkcites
|
||||
cmap2enc
|
||||
ctanify
|
||||
ctanupload
|
||||
|
@ -275,6 +230,7 @@ installfont-tl
|
|||
latex2man
|
||||
latexdiff
|
||||
latexdiff-vc
|
||||
latexfileversion
|
||||
latexmk
|
||||
latexrevise
|
||||
listings-ext.sh
|
||||
|
@ -313,31 +269,35 @@ texdiff
|
|||
texdirflatten
|
||||
texliveonfly
|
||||
texloganalyser
|
||||
typeoutfileinfo
|
||||
thumbpdf
|
||||
vpl2ovp
|
||||
vpl2vpl
|
||||
"
|
||||
_htmlxml_scripts="ht htcontext htlatex htmex httex httexi htxelatex htxetex mk4ht"
|
||||
_langcjk_scripts="convbkmk updmap-setup-kanji"
|
||||
_langextra_scripts="ebong"
|
||||
_langgreek_scripts="mkgrkindex"
|
||||
_latexextra_scripts="authorindex \
|
||||
makeglossaries \
|
||||
pdfannotextractor \
|
||||
pdfthumb \
|
||||
perltex \
|
||||
ppower4 \
|
||||
ps4pdf \
|
||||
splitindex \
|
||||
svn-multi \
|
||||
_latexextra_scripts="
|
||||
authorindex
|
||||
exceltex
|
||||
makeglossaries
|
||||
pdfannotextractor
|
||||
perltex
|
||||
ppower4
|
||||
ps4pdf
|
||||
splitindex
|
||||
svn-multi
|
||||
vpe"
|
||||
_music_scripts="musixtex musixflx"
|
||||
_music_scripts="m-tx musixtex musixflx pmx2pdf"
|
||||
_pictures_scripts="cachepic epspdf epspdftk fig4latex mathspic"
|
||||
_pstricks_scripts="pst2pdf"
|
||||
_pstricks_scripts="pedigree pst2pdf"
|
||||
_science_scripts="ulqda"
|
||||
for s in \
|
||||
${_bibtexextra_scripts} \
|
||||
${_core_scripts} \
|
||||
${_htmlxml_scripts} \
|
||||
${_langcjk_scripts} \
|
||||
${_langextra_scripts} \
|
||||
${_langgreek_scripts} \
|
||||
${_latexextra_scripts} \
|
||||
|
|
|
@ -1,77 +0,0 @@
|
|||
--- source/texk/web2c/luatexdir/lua/lepdflib.cc.orig 2011-10-06 06:14:20.000000000 +0000
|
||||
+++ source/texk/web2c/luatexdir/lua/lepdflib.cc 2012-05-17 11:30:26.327236883 +0000
|
||||
@@ -157,7 +157,7 @@
|
||||
pdfdoc_changed_error(L);
|
||||
uout = new_Annot_userdata(L);
|
||||
uout->d =
|
||||
- new Annot((XRef *) uxref->d, (Dict *) udict->d, (Catalog *) ucatalog->d,
|
||||
+ new Annot((PDFDoc *) uxref->pd, (Dict *) udict->d,
|
||||
(Object *) uref->d);
|
||||
uout->atype = ALLOC_LEPDF;
|
||||
uout->pc = uxref->pc;
|
||||
@@ -179,7 +179,7 @@
|
||||
pdfdoc_changed_error(L);
|
||||
uout = new_Annots_userdata(L);
|
||||
uout->d =
|
||||
- new Annots((XRef *) uxref->d, (Catalog *) ucatalog->d,
|
||||
+ new Annots((PDFDoc *) uxref->pd,
|
||||
(Object *) uannotsobj->d);
|
||||
uout->atype = ALLOC_LEPDF;
|
||||
uout->pc = uxref->pc;
|
||||
@@ -369,7 +369,7 @@
|
||||
// Annot
|
||||
|
||||
m_poppler_get_BOOL(Annot, isOk);
|
||||
-m_poppler_get_OBJECT(Annot, getAppearance);
|
||||
+m_poppler_get_OBJECT(Annot, getAppearanceResDict);
|
||||
m_poppler_get_poppler(Annot, AnnotBorder, getBorder);
|
||||
|
||||
static int m_Annot_match(lua_State * L)
|
||||
@@ -408,7 +408,7 @@
|
||||
|
||||
static const struct luaL_Reg Annot_m[] = {
|
||||
{"isOk", m_Annot_isOk},
|
||||
- {"getAppearance", m_Annot_getAppearance},
|
||||
+ {"getAppearance", m_Annot_getAppearanceResDict},
|
||||
{"getBorder", m_Annot_getBorder},
|
||||
{"match", m_Annot_match},
|
||||
{"__tostring", m_Annot__tostring},
|
||||
@@ -1433,7 +1433,7 @@
|
||||
|
||||
static int m_Object_getTypeName(lua_State * L)
|
||||
{
|
||||
- char *s;
|
||||
+ const char *s;
|
||||
udstruct *uin;
|
||||
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
|
||||
if (uin->pd != NULL && uin->pd->pc != uin->pc)
|
||||
@@ -2120,7 +2120,7 @@
|
||||
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|
||||
|| (ucat->pd != NULL && ucat->pd->pc != ucat->pd->pc))
|
||||
pdfdoc_changed_error(L);
|
||||
- links = ((Page *) uin->d)->getLinks((Catalog *) ucat->d);
|
||||
+ links = ((Page *) uin->d)->getLinks();
|
||||
if (links != NULL) {
|
||||
uout = new_Links_userdata(L);
|
||||
uout->d = links;
|
||||
@@ -2738,7 +2738,10 @@
|
||||
return 1;
|
||||
}
|
||||
|
||||
-m_poppler_get_INT(XRef, getSize);
|
||||
+static int m_XRef_getSize(lua_State * L)
|
||||
+{
|
||||
+ return m_XRef_getNumObjects(L);
|
||||
+}
|
||||
|
||||
static int m_XRef_getEntry(lua_State * L)
|
||||
{
|
||||
@@ -2748,7 +2751,7 @@
|
||||
if (uin->pd != NULL && uin->pd->pc != uin->pc)
|
||||
pdfdoc_changed_error(L);
|
||||
i = luaL_checkint(L, 2);
|
||||
- size = ((XRef *) uin->d)->getSize();
|
||||
+ size = ((XRef *) uin->d)->getNumObjects();
|
||||
if (i > 0 && i <= size) {
|
||||
uout = new_XRefEntry_userdata(L);
|
||||
uout->d = ((XRef *) uin->d)->getEntry(i);
|
23
extra/texlive-bin/luatex-r4449-radical-rule-thickness.patch
Normal file
23
extra/texlive-bin/luatex-r4449-radical-rule-thickness.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
Index: source/texk/web2c/luatexdir/tex/mlist.w
|
||||
===================================================================
|
||||
--- source/texk/web2c/luatexdir/tex/mlist.w (revision 4448)
|
||||
+++ source/texk/web2c/luatexdir/tex/mlist.w (revision 4449)
|
||||
@@ -1798,7 +1798,17 @@
|
||||
theta = fraction_rule(cur_style);
|
||||
y = var_delimiter(left_delimiter(q), cur_size,
|
||||
height(x) + depth(x) + clr + theta, NULL, cur_style);
|
||||
- theta = height(y);
|
||||
+ /* If |y| is a composite then set |theta| to the height of its top
|
||||
+ character, else set it to the height of |y|. */
|
||||
+ if (list_ptr(y) != null
|
||||
+ && type(list_ptr(y)) == hlist_node
|
||||
+ && list_ptr(list_ptr(y)) != null
|
||||
+ && type(list_ptr(list_ptr(y))) == glyph_node) { /* and it should be */
|
||||
+ theta = char_height(font(list_ptr(list_ptr(y))),
|
||||
+ character(list_ptr(list_ptr(y))));
|
||||
+ } else {
|
||||
+ theta = height(y);
|
||||
+ }
|
||||
} else {
|
||||
y = var_delimiter(left_delimiter(q), cur_size,
|
||||
height(x) + depth(x) + clr + theta, NULL, cur_style);
|
22
extra/texlive-bin/poppler-0.20.patch
Normal file
22
extra/texlive-bin/poppler-0.20.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- source/texk/web2c/luatexdir/lua/lepdflib.cc.orig 2011-10-06 06:14:20.000000000 +0000
|
||||
+++ source/texk/web2c/luatexdir/lua/lepdflib.cc 2012-05-17 11:30:26.327236883 +0000
|
||||
@@ -1433,7 +1433,7 @@
|
||||
|
||||
static int m_Object_getTypeName(lua_State * L)
|
||||
{
|
||||
- char *s;
|
||||
+ const char *s;
|
||||
udstruct *uin;
|
||||
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
|
||||
if (uin->pd != NULL && uin->pd->pc != uin->pc)
|
||||
--- source/texk/web2c/pdftexdir/pdftosrc.cc.orig 2012-06-24 17:12:34.376329435 +0200
|
||||
+++ source/texk/web2c/pdftexdir/pdftosrc.cc 2012-06-24 17:12:25.490003152 +0200
|
||||
@@ -134,7 +134,7 @@
|
||||
exit(1);
|
||||
}
|
||||
if (extract_xref_table) {
|
||||
- int size = xref->getSize();
|
||||
+ int size = xref->getNumObjects();
|
||||
int i;
|
||||
for (i = 0; i < size; i++) {
|
||||
if (xref->getEntry(i)->offset == 0xffffffff)
|
Loading…
Reference in a new issue