mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-espressobin to 4.18.5-1
This commit is contained in:
parent
deea04daed
commit
3fbfda9e3d
5 changed files with 209 additions and 232 deletions
|
@ -1,4 +1,4 @@
|
|||
From 6fa1b7f42dee531615600a3f0c98402683b19ffe Mon Sep 17 00:00:00 2001
|
||||
From 8247aa8a19752cc18dcbc812b193a654b1ac01fe Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 19:25:28 -0600
|
||||
Subject: [PATCH 1/3] arm64: dts: marvell: armada37xx: Add eth0 alias
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
index 97207a61bc79..0d4dd9a4f976 100644
|
||||
index 3353252d78a0..5177c581a936 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
@@ -18,6 +18,7 @@
|
||||
|
@ -21,5 +21,5 @@ index 97207a61bc79..0d4dd9a4f976 100644
|
|||
serial1 = &uart1;
|
||||
};
|
||||
--
|
||||
2.17.0
|
||||
2.18.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 9865599cadcbaca9e297cce5987f5baef9bb625d Mon Sep 17 00:00:00 2001
|
||||
From 6a733df1f509dcbdb64325032cf54e02e2424729 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:44 +0200
|
||||
Subject: [PATCH 2/3] PCI: aardvark: set host and device to the same MAX
|
||||
|
@ -21,14 +21,14 @@ Reviewed-by: Nadav Haklai <nadavh@marvell.com>
|
|||
[Thomas: tweak commit log.]
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
drivers/pci/host/pci-aardvark.c | 60 ++++++++++++++++++++++++++++++++-
|
||||
drivers/pci/controller/pci-aardvark.c | 60 ++++++++++++++++++++++++++-
|
||||
1 file changed, 59 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/pci/host/pci-aardvark.c b/drivers/pci/host/pci-aardvark.c
|
||||
index 9abf549631b4..a818390852be 100644
|
||||
--- a/drivers/pci/host/pci-aardvark.c
|
||||
+++ b/drivers/pci/host/pci-aardvark.c
|
||||
@@ -27,9 +27,11 @@
|
||||
diff --git a/drivers/pci/controller/pci-aardvark.c b/drivers/pci/controller/pci-aardvark.c
|
||||
index 0fae816fba39..3815027e92b5 100644
|
||||
--- a/drivers/pci/controller/pci-aardvark.c
|
||||
+++ b/drivers/pci/controller/pci-aardvark.c
|
||||
@@ -29,9 +29,11 @@
|
||||
#define PCIE_CORE_DEV_CTRL_STATS_REG 0xc8
|
||||
#define PCIE_CORE_DEV_CTRL_STATS_RELAX_ORDER_DISABLE (0 << 4)
|
||||
#define PCIE_CORE_DEV_CTRL_STATS_MAX_PAYLOAD_SZ_SHIFT 5
|
||||
|
@ -40,7 +40,7 @@ index 9abf549631b4..a818390852be 100644
|
|||
#define PCIE_CORE_LINK_CTRL_STAT_REG 0xd0
|
||||
#define PCIE_CORE_LINK_L0S_ENTRY BIT(0)
|
||||
#define PCIE_CORE_LINK_TRAINING BIT(5)
|
||||
@@ -294,7 +296,8 @@ static void advk_pcie_setup_hw(struct advk_pcie *pcie)
|
||||
@@ -296,7 +298,8 @@ static void advk_pcie_setup_hw(struct advk_pcie *pcie)
|
||||
|
||||
/* Set PCIe Device Control and Status 1 PF0 register */
|
||||
reg = PCIE_CORE_DEV_CTRL_STATS_RELAX_ORDER_DISABLE |
|
||||
|
@ -50,7 +50,7 @@ index 9abf549631b4..a818390852be 100644
|
|||
PCIE_CORE_DEV_CTRL_STATS_SNOOP_DISABLE |
|
||||
(PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SZ <<
|
||||
PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SIZE_SHIFT);
|
||||
@@ -883,6 +886,58 @@ static int advk_pcie_parse_request_of_pci_ranges(struct advk_pcie *pcie)
|
||||
@@ -884,6 +887,58 @@ static int advk_pcie_parse_request_of_pci_ranges(struct advk_pcie *pcie)
|
||||
return err;
|
||||
}
|
||||
|
||||
|
@ -109,7 +109,7 @@ index 9abf549631b4..a818390852be 100644
|
|||
static int advk_pcie_probe(struct platform_device *pdev)
|
||||
{
|
||||
struct device *dev = &pdev->dev;
|
||||
@@ -956,6 +1011,9 @@ static int advk_pcie_probe(struct platform_device *pdev)
|
||||
@@ -957,6 +1012,9 @@ static int advk_pcie_probe(struct platform_device *pdev)
|
||||
list_for_each_entry(child, &bus->children, node)
|
||||
pcie_bus_configure_settings(child);
|
||||
|
||||
|
@ -120,5 +120,5 @@ index 9abf549631b4..a818390852be 100644
|
|||
return 0;
|
||||
}
|
||||
--
|
||||
2.17.0
|
||||
2.18.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 2bec069bf7b0e95bbde47b3f36b362b9c3429fc1 Mon Sep 17 00:00:00 2001
|
||||
From cf2b549fdf3a08ce69f93839250efe694b888c9d Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:46 +0200
|
||||
Subject: [PATCH 3/3] PCI: aardvark: disable LOS state by default
|
||||
|
@ -19,14 +19,14 @@ Reviewed-by: Nadav Haklai <nadavh@marvell.com>
|
|||
[Thomas: tweak commit log.]
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
drivers/pci/host/pci-aardvark.c | 3 +--
|
||||
drivers/pci/controller/pci-aardvark.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/pci/host/pci-aardvark.c b/drivers/pci/host/pci-aardvark.c
|
||||
index a818390852be..2632c3379349 100644
|
||||
--- a/drivers/pci/host/pci-aardvark.c
|
||||
+++ b/drivers/pci/host/pci-aardvark.c
|
||||
@@ -365,8 +365,7 @@ static void advk_pcie_setup_hw(struct advk_pcie *pcie)
|
||||
diff --git a/drivers/pci/controller/pci-aardvark.c b/drivers/pci/controller/pci-aardvark.c
|
||||
index 3815027e92b5..331f15a57123 100644
|
||||
--- a/drivers/pci/controller/pci-aardvark.c
|
||||
+++ b/drivers/pci/controller/pci-aardvark.c
|
||||
@@ -367,8 +367,7 @@ static void advk_pcie_setup_hw(struct advk_pcie *pcie)
|
||||
|
||||
advk_pcie_wait_for_link(pcie);
|
||||
|
||||
|
@ -37,5 +37,5 @@ index a818390852be..2632c3379349 100644
|
|||
|
||||
reg = advk_readl(pcie, PCIE_CORE_CMD_STATUS_REG);
|
||||
--
|
||||
2.17.0
|
||||
2.18.0
|
||||
|
||||
|
|
|
@ -4,10 +4,10 @@
|
|||
buildarch=8
|
||||
|
||||
pkgbase=linux-espressobin
|
||||
_srcname=linux-4.17
|
||||
_srcname=linux-4.18
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Globalscale ESPRESSOBin"
|
||||
pkgver=4.17.14
|
||||
pkgver=4.18.5
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -24,12 +24,12 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'60-linux.hook'
|
||||
'90-linux.hook'
|
||||
'91-linux.hook')
|
||||
md5sums=('5bb13a03274b66b56c85b26682e407d7'
|
||||
'ad9acd78874e9ad9a5a0cd3c28d9d941'
|
||||
'087a1417d83fa72c2e1cb69ec68ed94d'
|
||||
'960e91f38b59e9d1ce47ec3b4cef3195'
|
||||
'810cc7029cca0741c170209eba2f9dad'
|
||||
'99bd4dd22dd48d1be7f105a1bc4dfa08'
|
||||
md5sums=('bee5fe53ee1c3142b8f0c12c0d3348f9'
|
||||
'c49635fe383e69a7a134d633912d646a'
|
||||
'b8377bc890bcf9d5455b70bf3204701e'
|
||||
'330c550e2ca5b117ef10d7683d25f7df'
|
||||
'582ffed746b5a9f4da1255d3fb121daf'
|
||||
'b03da88afa5835e7fa1955f428c683a3'
|
||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||
'ce6c81ad1ad1f8b333fd6077d47abdaf'
|
||||
'3dc88030a8f2f5a5f97266d99b149f77'
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue