diff --git a/extra/texlive-bin/PKGBUILD b/extra/texlive-bin/PKGBUILD
index 84906bdc8..56fd16185 100644
--- a/extra/texlive-bin/PKGBUILD
+++ b/extra/texlive-bin/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: francois <francois.archlinux.org>
+# Maintainer: Rémy Oudompheng <remy@archlinux.org>
+# Contributor: francois <francois.archlinux.org>
 
 # ALARM: Kevin Mihelich <kevin@plugapps.com>
 #  - Removed clisp makedepend, removed xindy from build and packaging (only thing that used clisp)
-#  - Added arm.patch to fix broken ARM assembly, will be fixed in texlive 1.5.1
 #  - Use -fPIC with armv7
 
 plugrel=1
 
 pkgname=texlive-bin
-pkgver=2010.1
-_luatex_ver=0.66.0
-pkgrel=8
+pkgver=2011.1
+_luatex_ver=0.70.1
+pkgrel=1
 pkgdesc="TeX Live binaries"
 license=('GPL')
 arch=('i686' 'x86_64')
@@ -21,15 +21,15 @@ provides=('lcdf-typetools' 'kpathsea' 'pdfjam')
 conflicts=('pdfjam')
 options=('!libtool')
 url='http://tug.org/texlive/'
+install="texlive.install"
 source=('texmf.cnf'
         'fix-fontforge-encoding.patch'
         '09-texlive-fonts.conf'
-        'dvipng-fix-options.patch'
-        'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20100926.tar.xz'
-        'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20101105.tar.xz'
-        #"http://foundry.supelec.fr/gf/download/frsrelease/387/1715/luatex-beta-${_luatex_ver}-source.tar.bz2"
-        "ftp://ftp.archlinux.org/other/texlive/luatex-svn4193.tar.xz"
-        "arm.patch")
+        'archlinux-build.patch'
+        'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20110724.tar.xz'
+        'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20110724.tar.xz'
+        "http://foundry.supelec.fr/gf/download/frsrelease/392/1730/luatex-beta-${_luatex_ver}.tar.bz2"
+)
 backup=(etc/texmf/web2c/texmf.cnf \
   etc/texmf/chktex/chktexrc \
 	etc/texmf/web2c/mktex.cnf \
@@ -44,14 +44,13 @@ backup=(etc/texmf/web2c/texmf.cnf \
 	etc/texmf/dvipdfm/config/config \
 	etc/texmf/xdvi/XDvi)
 
-md5sums=('626f900fb59f036d6fea95f08c74b00b'
+md5sums=('ff30d6813babd2e41c414365eea9c147'
          'bfb9716aa00c86c08cd31e5b32edeb98'
          '393a4bf67adc7ca5df2b386759d1a637'
-         '60e405158f53519348d9783e8d420670'
-         '0b2c3a4a1b1e4befb90d7fbb5f08a6e9'
-         '7ae1400dafdb079dcd08d233de83ec44'
-         '523802a23bc174374403415d9cc87946'
-         '86c78e48013492e6b1c41373741d19fd')
+         '94ef5571a54262790ab64d6d044dd10c'
+         '58e8ab64188eaf15897b7acf472dca9f'
+         '9f7ae1aa24afd9e34289ac10a8f9e87b'
+         'c9348d4381170204b1a1b0440d8b6918')
 
 build() {
    if [ "${CARCH}" = "armv7h" ]; then
@@ -60,11 +59,10 @@ build() {
    fi
 
    cd $srcdir
-   patch -p0 -i arm.patch
    # Building LuaTeX
-   #cd luatex-beta-${_luatex_ver}
-   cd luatex
+   cd luatex-beta-${_luatex_ver}
    patch -p0 -i ../fix-fontforge-encoding.patch
+  (cd source && ./texk/web2c/luatexdir/getluatexsvnversion.sh)
    mkdir build
    cd build
    ../source/configure --prefix=/usr -C \
@@ -102,14 +100,14 @@ build() {
    cd "$srcdir"
    # this patch removes spurious error message with locale "xx_YY.utf8"
    patch -p0 -i fix-fontforge-encoding.patch
-   ## fix dvipng (bug #20157)
-   pushd "source/texk/dvipng/dvipng-1.13"
-   patch -p0 -i "$srcdir/dvipng-fix-options.patch"
-   popd
-
    #############################################################
    ### configure
    cd source
+   patch -Np1 -i ${srcdir}/archlinux-build.patch
+   for _dir in texk/tetex texk/texlive texk/tex4htk \
+       utils/ps2eps utils/chktex utils/psutils; do
+       (cd ${_dir} && automake) || true
+   done
    ## prevent compiling Xdvi with libXp
    sed -i~ 's|-lXp ||' texk/xdvik/configure
    test ! -d Work && mkdir Work
@@ -117,9 +115,9 @@ build() {
    echo "--> Initial configuration..."
    # we use temporary prefix to avoid messing the existing $pkgdir/usr/share/texmf tree
    ../configure --prefix=/usr -C \
-     --datarootdir=$srcdir/inst/usr/share \
-     --datadir=$srcdir/inst/usr/share \
-     --mandir=$srcdir/inst/usr/share/man \
+     --datarootdir=/usr/share \
+     --datadir=/usr/share \
+     --mandir=/usr/share/man \
      --disable-native-texlive-build \
      --with-banner-add="/Arch Linux" \
      --disable-multiplatform \
@@ -129,10 +127,12 @@ build() {
      --disable-bibtexu \
      --disable-xz \
      --with-system-zlib \
+     --with-system-zziplib \
      --with-system-pnglib \
      --with-system-ncurses \
      --with-system-t1lib \
      --with-system-gd \
+     --with-system-poppler \
      --with-system-xpdf \
      --with-system-freetype2 \
      --with-system-graphite \
@@ -142,8 +142,6 @@ build() {
      --disable-dump-share \
      --disable-aleph \
      --disable-luatex
-#     --with-clisp-runtime=default \
-#     --enable-xindy --disable-xindy-rules --disable-xindy-docs
    #############################################################
    ### make
    echo "-------------------------------------------------------"
@@ -224,45 +222,23 @@ package() {
    #############################################################
    ### install
    cd source
-   # fixes for xindy
-#   find utils/xindy -name Makefile -exec sed -i -e "s|^prefix =.\+$|prefix = $pkgdir/usr|" -e "s|^mandir =.\+$|mandir = \${prefix}/share/man|" -e "s|^datadir =.\+$|datadir = \${datarootdir}/texmf|" -e "s|^docdir =.\+$|docdir = \${datadir}/doc/xindy|" '{}' \;
 
    echo "-------------------------------------------------------"
    echo "--> Proceeding with make install ..."
    echo "-------------------------------------------------------"
    cd Work
-   make prefix=$srcdir/inst/usr texmf=$pkgdir/usr/share/texmf install
-
-   # restore install location of bin/lib/include
-   mv -f $srcdir/inst/usr/bin $pkgdir/usr/bin
-   mv -f $srcdir/inst/usr/lib $pkgdir/usr/lib
-   mv -f $srcdir/inst/usr/include $pkgdir/usr/include
-   # add symlinks to manpages since they are not included in the original texmf tree
-   for m in $srcdir/inst/usr/share/man/man1/*; do
-     bm=$(basename $m)
-     test -f $pkgdir/usr/share/man/man1/$bm || mv -f $m $pkgdir/usr/share/man/man1/
-   done
+   make DESTDIR=${pkgdir} texmf=$pkgdir/usr/share/texmf install
+   rm -rf ${pkgdir}/usr/{texmf,texmf-dist}
 
    ## install luatex binary
-   #install -m755 $srcdir/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex $pkgdir/usr/bin/
-   install -m755 $srcdir/luatex/build/texk/web2c/luatex $pkgdir/usr/bin/
+   install -m755 $srcdir/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex $pkgdir/usr/bin/
    cd $pkgdir/usr/bin
    /bin/ln -s luatex texlua
    /bin/ln -s luatex texluac
 
-   # symlinks in $pkgdir/usr/bin are incorrect
-   echo "--> Fixing symlinks for scripts ..."
-   for f in $pkgdir/usr/bin/* ; do
-	   if [ -L $f ]; then
-		   target=`ls -l "$f" | sed 's/^.\+ -> //'`
-		   if [[ "$target" == ..* ]]; then
-			   newtarget=`echo $target | sed -e 's#../#/usr/share/#'`
-			   rm -f $f
-			   ln -s $newtarget $f
-			   test -f $pkgdir/$newtarget && chmod a+x $pkgdir/$newtarget
-		   fi
-	   fi
-   done
+   ## install Perl libraries
+   mkdir -p $pkgdir/usr/share/tlpkg/TeXLive
+   install -m644 ${srcdir}/source/utils/biber/TeXLive/*.pm $pkgdir/usr/share/tlpkg/TeXLive
 
    # create symlinks for formats 
    echo "--> Create symlinks for TeX formats ..."
@@ -315,7 +291,9 @@ purifyeps
 repstopdf
 rpdfcrop
 showglyphs
+sty2dtx
 texcount
+texdef
 texdiff
 texdirflatten
 texloganalyser
@@ -336,16 +314,18 @@ ps4pdf \
 splitindex \
 svn-multi \
 vpe"
+   _music_scripts="musixtex musixflx"
    _pictures_scripts="cachepic epspdf epspdftk fig4latex mathspic"
    _pstricks_scripts="pst2pdf"
    _science_scripts="ulqda"
    for s in \
         ${_bibtexextra_scripts} \
-        ${_core_scripts} \
+        ${_core_scripts}       \
         ${_htmlxml_scripts}    \
         ${_langextra_scripts}  \
         ${_langgreek_scripts}  \
         ${_latexextra_scripts} \
+        ${_music_scripts}      \
         ${_pictures_scripts}   \
         ${_pstricks_scripts}   \
         ${_science_scripts}    \
diff --git a/extra/texlive-bin/archlinux-build.patch b/extra/texlive-bin/archlinux-build.patch
new file mode 100644
index 000000000..accb97a7a
--- /dev/null
+++ b/extra/texlive-bin/archlinux-build.patch
@@ -0,0 +1,40 @@
+diff -ur source.old/texk/am/script_links.am source/texk/am/script_links.am
+--- source.old/texk/am/script_links.am	2011-05-02 13:54:33.000000000 +0200
++++ source/texk/am/script_links.am	2011-06-05 11:22:53.118216353 +0200
+@@ -51,8 +51,8 @@
+ # We support both multiplatform and non-multiplatform builds.
+ install-links:
+ 	case "$(bindir)" in \
+-	  */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. TYPE=$(TYPE) EXT=$(EXT) make-links;; \
+-	  */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. TYPE=$(TYPE) EXT=$(EXT) make-links;; \
++	  */bin) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) TYPE=$(TYPE) EXT=$(EXT) make-links;; \
++	  */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) TYPE=$(TYPE) EXT=$(EXT) make-links;; \
+ 	  *) echo "strange directory '$(bindir)' for linked $(TYPE) scripts" >&2; \
+ 	     exit 1;; \
+ 	esac
+diff -ur source.old/texk/tetex/Makefile.am source/texk/tetex/Makefile.am
+--- source.old/texk/tetex/Makefile.am	2011-05-31 11:47:04.000000000 +0200
++++ source/texk/tetex/Makefile.am	2011-06-05 10:28:40.287025375 +0200
+@@ -35,7 +35,7 @@
+ 
+ include $(srcdir)/../am/script_links.am
+ 
+-texmfdir = ${prefix}/$(scriptsdir)
++texmfdir = $(datadir)/$(scriptsdir)
+ dist_texmf_SCRIPTS = $(perl_scripts:=.pl) $(shell_scripts:=.sh)
+ 
+ if !WIN32
+diff -ur source.old/texk/texlive/linked_scripts/Makefile.am source/texk/texlive/linked_scripts/Makefile.am
+--- source.old/texk/texlive/linked_scripts/Makefile.am	2011-05-31 11:47:04.000000000 +0200
++++ source/texk/texlive/linked_scripts/Makefile.am	2011-06-05 09:41:50.997250443 +0200
+@@ -165,8 +165,8 @@
+ 	done
+ else !WIN32
+ 	case "$(bindir)" in \
+-	  */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. install-links;; \
+-	  */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. install-links;; \
++	  */bin) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) install-links;; \
++	  */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) install-links;; \
+ 	  *) echo "strange directory '$(bindir)' for linked scripts" >&2; \
+ 	     exit 1;; \
+ 	esac
diff --git a/extra/texlive-bin/arm.patch b/extra/texlive-bin/arm.patch
deleted file mode 100644
index 191765794..000000000
--- a/extra/texlive-bin/arm.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=329439
-https://bugs.icu-project.org/trac/ticket/7664
-https://bugs.icu-project.org/trac/changeset/28107
-
---- source/libs/icu/icu-4.4/tools/toolutil/pkg_genc.c
-+++ source/libs/icu/icu-4.4/tools/toolutil/pkg_genc.c
-@@ -1,5 +1,5 @@
- /******************************************************************************
-- *   Copyright (C) 2009, International Business Machines
-+ *   Copyright (C) 2009-2010, International Business Machines
-  *   Corporation and others.  All Rights Reserved.
-  *******************************************************************************
-  */
-@@ -118,10 +118,10 @@
- } assemblyHeader[] = {
-     {"gcc",
-         ".globl %s\n"
--        "\t.section .note.GNU-stack,\"\",@progbits\n"
-+        "\t.section .note.GNU-stack,\"\",%%progbits\n"
-         "\t.section .rodata\n"
-         "\t.align 8\n" /* Either align 8 bytes or 2^8 (256) bytes. 8 bytes is needed. */
--        "\t.type %s,@object\n"
-+        "\t.type %s,%%object\n"
-         "%s:\n\n",
- 
-         ".long ","",HEX_0X
diff --git a/extra/texlive-bin/dvipng-fix-options.patch b/extra/texlive-bin/dvipng-fix-options.patch
deleted file mode 100644
index c0eda1d90..000000000
--- a/extra/texlive-bin/dvipng-fix-options.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- papersiz.c	2010/03/17 21:40:00	1.16
-+++ papersiz.c	2010/09/29 21:14:40	1.17
-@@ -52,6 +52,7 @@
-   while (*q != ',' && *q !='\0')
-     q++;
-   tmp = tmp*lengthsp[i]*dpi/4736286L; /*   sp * dots/in / (sp/in), convert sp to pixels   */
-+  *p=q;
-   return((int32_t) tmp);
- }
- 
diff --git a/extra/texlive-bin/texlive.install b/extra/texlive-bin/texlive.install
new file mode 100644
index 000000000..9307c536b
--- /dev/null
+++ b/extra/texlive-bin/texlive.install
@@ -0,0 +1,18 @@
+post_install() {
+  echo    ">>> texlive: updating the filename database..."
+  usr/bin/mktexlsr
+  echo -n   "creating all formats..."
+  usr/bin/fmtutil-sys --all 1>/dev/null
+  echo      " done." 
+  echo      " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
+}
+
+post_upgrade() {
+  echo    ">>> texlive: updating the filename database..."
+  usr/bin/mktexlsr
+  echo -n   "recreating all formats..."
+  usr/bin/fmtutil-sys --all 1>/dev/null
+  echo      " done." 
+  echo      " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
+}
+
diff --git a/extra/texlive-bin/texmf.cnf b/extra/texlive-bin/texmf.cnf
index b9d51682a..423d93e09 100644
--- a/extra/texlive-bin/texmf.cnf
+++ b/extra/texlive-bin/texmf.cnf
@@ -1,6 +1,12 @@
 % texmf.cnf for TeXLive/Arch Linux -- runtime path configuration file for kpathsea.
 % Public domain.
 % 
+% If you modify this original file, YOUR CHANGES WILL BE LOST when it is
+% updated.  Instead, put your changes -- and only your changes, not an
+% entire copy of the full texmf.cnf! -- in ../../texmf.cnf.  That is, if
+% this file is installed in /some/path/to/texlive/2011/texmf/web2c/texmf.cnf,
+% add your custom settings to /some/path/to/texlive/2011/texmf.cnf.
+% 
 % What follows is a super-summary of what this .cnf file can
 % contain. Please read the Kpathsea manual for more information.
 %
@@ -29,68 +35,63 @@
 % A leading/trailing/doubled path separator in the paths will be
 %   expanded into the compile-time default. Probably not what you want.
 %
-
 % Brace notation is supported, for example: /usr/local/{mytex,othertex}
-% expands to /usr/local/mytex:/usr/local/othertex.  You can use the path
-% separator as well as the comma for this: /usr/local/{mytex:othertex}
-% also expands to /usr/local/mytex:/usr/local/othertex.  We make
-% extensive use of this.
+% expands to /usr/local/mytex:/usr/local/othertex.  We make extensive
+% use of this.
+
 
 %  Part 1: Search paths and directories.
 
-% You can set an environment variable to override TEXMF if you're testing
-% a new TeX tree, without changing anything else.
+% This is the parent directory of our several trees, i.e.,
+% /usr/local/texlive/YYYY in the original TeX Live distribution.
 %
-% You may wish to use one of the $SELFAUTO... variables here so TeX will
-% find where to look dynamically.  See the manual and the definition
-% below of TEXMFCNF.
+% All trees must be organized according to the TeX Directory Structure
+% (http://tug.org/tds), or files may not be found.
+%
+% Redistributors will probably want $SELFAUTODIR/share, i.e., /usr/share.
+TEXMFROOT = $SELFAUTODIR/share
 
-% The tree containing the runtime files closely related to the specific
-% program version used:
-TEXMFMAIN = /usr/share/texmf
+% The tree containing runtime files related to the specific
+% distribution and version.
+TEXMFMAIN = $TEXMFROOT/texmf
 
-% The main distribution tree:
-TEXMFDIST = /usr/share/texmf-dist
+% The main tree of packages, distribution-agnostic:
+TEXMFDIST = $TEXMFROOT/texmf-dist
 
-% Our documentation-only tree, arranged by language:
-TEXMFDOC = /usr/share/texmf-doc
-
-% A place for local additions to a "standard" texmf tree.
-% This tree is not used for local configuration maintained by
-% texconfig, it uses TEXMFCONFIG below.
+% Local additions to the distribution trees.
 TEXMFLOCAL = /usr/local/share/texmf
 
-% TEXMFSYSVAR, where texconfig-sys stores variable runtime data.
+% TEXMFSYSVAR, where *-sys store cached runtime data.
 TEXMFSYSVAR = /var/lib/texmf
 
-% TEXMFSYSCONFIG, where texconfig-sys stores configuration data.
+% TEXMFSYSCONFIG, where *-sys store configuration data.
 TEXMFSYSCONFIG = /etc/texmf
 
-% User texmf trees are allowed as follows.
+% Per-user texmf tree(s) -- organized per the TDS, as usual.  To define
+% more than one per-user tree, set this to a list of directories in
+% braces, as described above.  (This used to be HOMETEXMF.)  ~ expands
+% to %USERPROFILE% on Windows, $HOME otherwise.
 TEXMFHOME = ~/texmf
 
-% TEXMFVAR, where texconfig stores variable runtime data.
+% TEXMFVAR, where texconfig/updmap/fmtutil store cached runtime data.
 TEXMFVAR = ~/.texlive/texmf-var
 
-% TEXMFCONFIG, where texconfig stores configuration data.
+% TEXMFCONFIG, where texconfig/updmap/fmtutil store configuration data.
 TEXMFCONFIG = ~/.texlive/texmf-config
 
-% Now, list all the texmf trees. If you have multiple trees you can
-% use shell brace notation, like this:
-%   TEXMF = {$TEXMFHOME,!!$TEXMFLOCAL,!!$TEXMFMAIN}
-% The braces are necessary.
+% List all the texmf trees.
 %
 % For texconfig to work properly, TEXMFCONFIG and TEXMFVAR should be named
 % explicitly and before all other trees.
 % 
 % TEXMFLOCAL follows TEXMFMAIN (and precedes TEXMFDIST) because the
 % files in TEXMFMAIN are tightly coupled with the particular version of
-% the distribution, such as format files.  Overriding them would be more
-% likely to cause trouble than help.  On the other hand, all the
-% standard packages and fonts are in TEXMFDIST, and locally-installed
-% versions should take precedence over those (although it is generally a
-% source of confusion to have different versions of a package installed,
-% whatever the trees, so try to avoid it).
+% the distribution, such as configuration files.  Overriding them would
+% be more likely to cause trouble than help.  On the other hand, the
+% bulk of packages and fonts are in TEXMFDIST, and locally-installed
+% versions should take precedence over those -- although it is generally
+% a source of confusion to have different versions of a package
+% installed, whatever the trees, so try to avoid it.
 TEXMF = {$TEXMFCONFIG,$TEXMFVAR,$TEXMFHOME,!!$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$TEXMFMAIN,!!$TEXMFLOCAL,!!$TEXMFDIST}
 
 % Where to look for ls-R files.  There need not be an ls-R in the
@@ -101,7 +102,7 @@ TEXMF = {$TEXMFCONFIG,$TEXMFVAR,$TEXMFHOME,!!$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$T
 % This is arguably a bug in kpathsea.
 TEXMFDBS = {!!$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$TEXMFMAIN,!!$TEXMFLOCAL,!!$TEXMFDIST}
 
-% The system trees.  These are the trees that are shared by all the users.
+% The system trees.  These are the trees that are shared by all users.
 % If a tree appears in this list, the mktex* scripts will use
 % VARTEXFONTS for generated files, if the original tree isn't writable;
 % otherwise the current working directory is used.
@@ -116,7 +117,7 @@ VARTEXFONTS = $TEXMFVAR/fonts
 % files that may be created as well as the formats.  For example
 %   TEXMFVAR = /var/lib/texmf
 % is used in many distros.  In this case, set VARTEXFONTS like this
-% VARTEXFONTS = $TEXMFVAR/fonts
+%VARTEXFONTS = $TEXMFVAR/fonts
 % and do not mention it in TEXMFDBS (but _do_ mention TEXMFVAR).
 %
 % Remove $VARTEXFONTS from TEXMFDBS if the VARTEXFONTS directory is below
@@ -203,7 +204,7 @@ TEXINPUTS.xetex         = .;$TEXMF/tex/{xetex,plain,generic,}//
 % ConTeXt.
 TEXINPUTS.context       = .;$TEXMF/tex/{context,plain,generic,}//
 
-% jadetex
+% jadetex.
 TEXINPUTS.jadetex       = .;$TEXMF/tex/{jadetex,latex,generic,}//
 TEXINPUTS.pdfjadetex    = .;$TEXMF/tex/{jadetex,latex,generic,}//
 
@@ -304,10 +305,10 @@ T1FONTS = .;$TEXMF/fonts/type1//;$OSFONTDIR//
 AFMFONTS = .;$TEXMF/fonts/afm//;$OSFONTDIR//
 
 % TrueType outline fonts.
-TTFONTS = .;$TEXMF/fonts/truetype//;$OSFONTDIR//
+TTFONTS = .;$TEXMF/fonts/{truetype,opentype}//;$OSFONTDIR//
 
 % Opentype outline fonts.
-OPENTYPEFONTS = .;$TEXMF/fonts/opentype//;$OSFONTDIR//
+OPENTYPEFONTS = .;$TEXMF/fonts/{opentype,truetype}//;$OSFONTDIR//
 
 % Type 42 outline fonts.
 T42FONTS = .;$TEXMF/fonts/type42//
@@ -387,6 +388,10 @@ TEX4HTINPUTS = .;$TEXMF/tex4ht/base//;$TEXMF/tex4ht/ht-fonts/{$TEX4HTFONTSET}//
 TW_LIBPATH = $TEXMFCONFIG/texworks
 TW_INIPATH = $TW_LIBPATH
 
+% For security, do not look in . for dvipdfmx.cfg, since the D option
+% would allow command execution.
+DVIPDFMXINPUTS = $TEXMF/dvipdfmx
+
 % Find scripts that are distributed/installed in the texmf tree.
 
 % Lua needs to look in TEXINPUTS for lua scripts distributed with packages.
@@ -488,6 +493,13 @@ repstopdf,\
 
 % plain TeX should remain unenhanced.
 shell_escape.tex = f
+shell_escape.initex = f
+
+% This is used by the Windows script wrapper for restricting searching
+% for the purportedly safe shell_escape_commands above to system
+% directories.
+TEXMF_RESTRICTED_SCRIPTS = \
+  {!!$TEXMFMAIN,!!$TEXMFLOCAL,!!$TEXMFDIST}/scripts/{$progname,$engine,}//
 
 % Allow TeX \openin, \openout, or \input on filenames starting with `.'
 % (e.g., .rhosts) or outside the current tree (e.g., /etc/passwd)?
@@ -499,7 +511,7 @@ openout_any = p
 openin_any = a
 
 % Write .log/.dvi/etc. files here, if the current directory is unwritable.
-% TEXMFOUTPUT = /tmp
+%TEXMFOUTPUT = /tmp
 
 % If a dynamic file creation fails, log the command to this file, in
 % either the current directory or TEXMFOUTPUT.  Set to the
@@ -521,6 +533,7 @@ parse_first_line = t
 % file_line_error_style settings, as well as the options -enctex,
 % -mltex, -8bit, etc., also affect this, but they are all off by default.
 parse_first_line.tex = f
+parse_first_line.initex = f
 
 % Control file:line:error style messages.
 file_line_error_style = f
@@ -534,13 +547,13 @@ file_line_error_style = f
 % set DVIPSMAKEPK to `foo', what counts is the value of the environment
 % variable/config value `FOO', not the `MKTEXPK' value.
 %
-% MKTEXTEX = 0
-% MKTEXPK = 0
-% MKTEXMF = 0
-% MKTEXTFM = 0
-% MKTEXFMT = 0
-% MKOCP = 0
-% MKOFM = 0
+%MKTEXTEX = 0
+%MKTEXPK = 0
+%MKTEXMF = 0
+%MKTEXTFM = 0
+%MKTEXFMT = 0
+%MKOCP = 0
+%MKOFM = 0
 
 % Used by makempx to run TeX.  We use "etex" because MetaPost is
 % expecting DVI, and not "tex" because we want first line parsing.