mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/wt to 3.3.7-1
This commit is contained in:
parent
f9a9cf6b27
commit
402075b604
2 changed files with 5 additions and 23 deletions
|
@ -7,9 +7,9 @@
|
|||
# - add -fsigned-char to cflags
|
||||
|
||||
pkgname=wt
|
||||
pkgver=3.3.6
|
||||
_pkgver=3.3.6
|
||||
pkgrel=6
|
||||
pkgver=3.3.7
|
||||
_pkgver=3.3.7
|
||||
pkgrel=1
|
||||
pkgdesc="a C++ library and application server for developing and deploying web applications"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.webtoolkit.eu/"
|
||||
|
@ -23,15 +23,8 @@ optdepends=('openssl: for SSL support in built-in webserver'
|
|||
'mysql++: for the hangman example'
|
||||
'qt4: for the Wt/Qt interopability example (wtwithqt)')
|
||||
backup=('etc/wt/wt_config.xml')
|
||||
source=(https://github.com/kdeforche/wt/archive/${_pkgver}.tar.gz wt-boost-1.63.patch)
|
||||
md5sums=('a5be5f7efa93c4eae7f1d8812ff78c70'
|
||||
'87a0c637d7014e764892686891393d6b')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$_pkgver
|
||||
# Fix build with boost 1.63 https://github.com/emweb/wt/pull/102
|
||||
patch -p0 -i ../wt-boost-1.63.patch
|
||||
}
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/kdeforche/wt/archive/${_pkgver}.tar.gz")
|
||||
sha512sums=('f179b42eedcfd2e61f26ef92c6aad40c55c76c9a688269c4d5bd55dd48381073d6269d9c2ab305f15ef455616d48183a3fc0ba08c740a8e18318a2ad2fb13826')
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/${pkgname}-${_pkgver}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Wt/Render/CssParser.C.orig 2016-07-13 12:27:26 UTC
|
||||
+++ src/Wt/Render/CssParser.C
|
||||
@@ -372,7 +372,7 @@ CssGrammer<Iterator>::CssGrammer()
|
||||
on_error<qi::fail>
|
||||
(
|
||||
rulesetArray_,
|
||||
- error_report(qi::_2, qi::_3, qi::_4, "styleSheetText()", fs_error_tag())
|
||||
+ error_report(qi::_2, qi::_3, qi::_4, phoenix::val("styleSheetText()"), fs_error_tag())
|
||||
);
|
||||
|
||||
}
|
Loading…
Reference in a new issue