mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/pyqt5 to 5.9-1
This commit is contained in:
parent
cf4ec09939
commit
4022715e03
2 changed files with 6 additions and 24 deletions
|
@ -7,12 +7,11 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove qt5-webengine makedepend, not built for ARM
|
||||
# - hack for OpenGLES
|
||||
|
||||
pkgbase=pyqt5
|
||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||
pkgver=5.8.2
|
||||
pkgrel=4
|
||||
pkgver=5.9
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
|
||||
license=('GPL')
|
||||
|
@ -21,21 +20,15 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
|||
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
||||
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
|
||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz"
|
||||
'opengles-hack.patch'
|
||||
'pyqt-support-new-qt.patch')
|
||||
sha512sums=('8b765b9ae6210b7312a2dc6ed94d2664ae569625fe8a27443bae4230d9d9c00e0cf3b4be6904c66ebceff5cd5bbd19a5a9794a0b3222c8098a55f0b94fc8d89b'
|
||||
'6be0458a53dc96919d2dfe7a3e932ac663e6e9ebcc2516809f8c53ad923566bf3f96f622ee52ee8a97bf1bea2fc72f78e60333daa6bb3555ff3ca8371141f2b7'
|
||||
sha512sums=('6e925dee751d6b2ab97b3614b0150f305798b89920e11db7a2cbef579e4c21839a38f4ad7eee5828a0c28942999955715a265e043004ee7838d376025d32e4aa'
|
||||
'5b0793b281ec7136670fe1b8785704a09d71f79ac4d6479c966a3ec43a76cb3e225311a121a34e3a274a627bd929be2a6e8d108a12a10967f8d1cf888be5030f')
|
||||
|
||||
prepare() {
|
||||
pushd PyQt5_gpl-$pkgver
|
||||
patch -p1 -i ../opengles-hack.patch
|
||||
popd
|
||||
|
||||
# Support new versions of Qt - don't remove, needs to be reapplied after every new Qt release
|
||||
pushd PyQt5_gpl-$pkgver
|
||||
patch -p1 -i ../pyqt-support-new-qt.patch
|
||||
popd
|
||||
# pushd PyQt5_gpl-$pkgver
|
||||
# patch -p1 -i ../pyqt-support-new-qt.patch
|
||||
# popd
|
||||
|
||||
# The additional include path was removed due to this line, I don't really know why they are doing this...
|
||||
sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-$pkgver/configure.py
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
diff -urN a/configure.py b/configure.py
|
||||
--- a/configure.py 2017-01-28 20:39:01.562407718 -0700
|
||||
+++ b/configure.py 2017-01-28 22:08:41.670433124 -0700
|
||||
@@ -688,6 +688,7 @@
|
||||
#elif defined(QT_OPENGL_ES_2)
|
||||
out << "PyQt_Desktop_OpenGL\\n";
|
||||
#endif
|
||||
+ out << "PyQt_Desktop_OpenGL\\n";
|
||||
|
||||
#if QT_VERSION < 0x050200
|
||||
// This is the test used in qglobal.h in Qt prior to v5.2. In v5.2 and later
|
Loading…
Reference in a new issue